Welcome!
Important information
-- Spectre and Meltdown vulnerabilities
-- Change in MX sources

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-17.1 Final release info here
-- antiX-17 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

trouble mounting an ntfs partition

Post Reply
Message
Author
User avatar
brucedixon
Forum Novice
Forum  Novice
Posts: 2
Joined: Wed Apr 04, 2018 8:55 pm

trouble mounting an ntfs partition

#1 Post by brucedixon » Wed Apr 04, 2018 10:27 pm

I've got an HP Elitebook 8570w laptop with an Nvidia video bios and 16G RAM. For a couple years i've been triple booting it with 2 flavors of Linux Mint or Bodhi, or other Ubuntu derivatives, and Windows, all three accessing my data on the ntfs Windows partition. Every four or five months, or when major updates come along or when I do something to fry a Linux install or it just slows down a little or I want to try something new, I wipe one of the ext4 partitions and install or reinstall, no problem. But last month the installer all the Ubuntu derivatives use stopped talking to my Nvidia audio/video bios and the installs will not complete. So no more Ubuntu derivatives.

After trying Fedora and some others, MX was one of the first two suitable distros whose installer allowed me to choose the partition to which I installed, enabling me to successfully and dependably do my triple UEFI boot alongside Windows 10. Antegros, an Arch derivative is the other. In Mint and the other Ubuntu derivatives, and Antegros too all I need to mount my ntfs partition is to harvest the UUID from blkid and add a line to the /etc/fstab file...

But this doesn't seem to do the trick with MX... Here is my modified /etc/fstab

# /etc/fstab: static file system information
#
# Created by make-fstab on Tue Apr 3 18:54:04 EDT 2018
# <file system> <mount point> <type> <options> <dump/pass>
#-> /dev/sda7 label=rootMX17
UUID=ec80c36f-8f36-41b3-a083-3cb688725135 / ext4 defaults 1 1
#-> /dev/sda2 label=SYSTEM
UUID=643F-3B54 /boot/efi vfat defaults 1 2
#-> /dev/sda4 label=Windows
UUID=FC6C40DA6C4090F6 /Windows ntfs defaults 1 2
#-> /dev/sda5
UUID=48058d4a-1078-44b0-8670-747d71079135 swap swap defaults 0 0

During boot I get this message:

Mounting local file system... ntfs-3g mount... failed to access mountpoint /Windows... no such directory or file system, and of course the thing does not mount. Been a long time since I tried to install Debian, but I think I had this problem with Debian too.

I believe the ntfs partition is healthy, Windows 10 still works as well as Windows ever does, and my Antegros Linux on a neighboring partition mounts it flawlessly. Synaptic says that there is an ntfs-3g dev driver, and a couple of other ntfs drivers too. Should I try them?

I here express profound gratitude in advance for any helpful suggestions, and nice work to the developers/maintainers, MX is good stuff.

Bruce in Atlanta GA USA

User avatar
dolphin_oracle
Forum Veteran
Forum Veteran
Posts: 8667
Joined: Sun Dec 16, 2007 1:17 pm

Re: trouble mounting an ntfs partition

#2 Post by dolphin_oracle » Wed Apr 04, 2018 11:08 pm

yes you have 2 issues.

1 is that you need to use ntfs-3g as the type in your fstab. (this might not strictly speaking actually be necessary due to some symlinking in debian but it wont hurt)

the other is that you need to pre-create the /Windows mount point.

Code: Select all

sudo mkdir /Windows
should do it.

you could also set this up with Disk Manager (preinstalled)
http://www.youtube.com/runwiththedolphin
eeepc 904ha antix 17 32 bit (streaming media player)
lenovo ThinkPad T530 - MX-17
lenovo s21e - antiX-17, MX17(live-usb)

User avatar
penguin
Forum Regular
Forum Regular
Posts: 227
Joined: Wed Jan 04, 2017 3:15 pm

Re: trouble mounting an ntfs partition

#3 Post by penguin » Thu Apr 05, 2018 4:31 am

Hi. Look at the follow link:
A very interesting and simple method to mount ntfs partitions.

Code: Select all

https://linuxnewbieguide.org/how-to-read-and-write-to-windows-ntfs-drives-as-any-user/
Also read my post on the forum :

Code: Select all

https://forum.mxlinux.org/viewtopic.php?f=94&t=43691&p=435937&hilit=nfts#p435937
when your NFTS partition is locked (you mount it but only as a read only)

P.S.
HP 8570W is a very great laptop.I actually use it, but also fellow HP 8470W on a smaller size.
Very good are also HP 8470p or HP 8570p
Very good are also HP 2570p or HP 2170p

User avatar
brucedixon
Forum Novice
Forum  Novice
Posts: 2
Joined: Wed Apr 04, 2018 8:55 pm

Re: trouble mounting an ntfs partition

#4 Post by brucedixon » Thu Apr 05, 2018 12:08 pm

MANY THANKS to the several responders.
The first suggestion was the easiest. I just did

Code: Select all

sudo mkdir /Windows
That did it. I really should have seen that one myself, as the error message
no file or directory
is the same one you get when you refer to a nonexistent directory.

Also helpful was the second linked suggestion that I could mount the stuff with

Code: Select all

sudo mount -a
instead of another reboot. didn't know that either...

At a couple points in the past I tried installing Debian alongside Windows on this and somebody else's laptop but could never get it to recognize that ntfs partition. Bet this was what I should have done back then. Live and learn, huh?

Now if I can find a way to make the sound work in Skype, which I have to use once a week I'll be using MX most of the time.

Thanks again.

Post Reply

Return to “Software / Configuration”