Welcome!
Important information
-- Spectre and Meltdown vulnerabilities
-- Change in MX sources

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-17.1 Final release info here
-- antiX-17 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

Recent Update Problem - Hangs Before Login

Help for Current Versions of MX
Message
Author
User avatar
grasshopper
Forum Regular
Forum Regular
Posts: 160
Joined: Thu Jun 19, 2008 12:56 pm

Recent Update Problem - Hangs Before Login

#1 Post by grasshopper » Fri Nov 11, 2016 11:26 pm

MX-15..did the recent updates, lot of them after the repo list got updated I assume.
The system boots up to just before the login splash screen and hangs a dead prompt.

If I open up a terminal and log in and type 'startx' it does boot the desktop almost normally..the 'start' icon (forget the name, see image below) does not display correctly image. I've not seriously looked for bugs beyond my normal everyday programs, which seem to be okay.
Screenshot-1.png
When booting into root..whoa! I don't recognize that desktop at all! Different background, menu structure, everything (mouse image on desktop)..weird! Is that default antiX?

How can I get it to work again normally?
You do not have the required permissions to view the files attached to this post.

User avatar
tascoast
Forum Guide
Forum Guide
Posts: 1086
Joined: Sat Aug 06, 2011 4:58 am

Re: Recent Update Problem - Hangs Before Login

#2 Post by tascoast » Sat Nov 12, 2016 7:38 am

Hi. If you can post the output of

Code: Select all

 inxi -F
(or

Code: Select all

inxi -Fxz
for a live USB it was mentioned recently elsewhere) in a terminal it will provide some details to help wiser users to offer you some ideas. Is it MX-15 or MX-16? I am yet to update my MX-15, MX-16 beta being so pleasant to use. The output of inxi -F will clarify this part and more.
Lenovo ThinkCentre A58 4GBRAM, MX-16 RC1/MX14.04/MX-15.01/antiX16(64-bit)-Aspire One D255E 1.66GHz, 512KB cache, 1GB RAM-MX-15.01/W10

User avatar
v3g4n
Forum Guide
Forum Guide
Posts: 1783
Joined: Sat Jan 16, 2016 8:20 pm

Re: Recent Update Problem - Hangs Before Login

#3 Post by v3g4n » Sat Nov 12, 2016 11:47 am

First make sure that you disable the MX16 repo. Then refresh your sources and remove desktop-defaults-xfce-mx16 and mx-docs. Now install desktop-defaults-xfce-mx and mx-docs. Then reboot and lightdm should allow you to login. I just tested this in a VM by upgrading and getting to the point you are currently at and it worked for me. As far as the logo for whiskermenu goes just right click the botton, select properties, then icon and the icon can be found at /usr/local/share/icons/mxfcelogo-rounded.png.
Last edited by v3g4n on Sat Nov 12, 2016 11:57 am, edited 2 times in total.

User avatar
Eadwine Rose
Forum Veteran
Forum Veteran
Posts: 6058
Joined: Wed Jul 12, 2006 2:10 am

Re: Recent Update Problem - Hangs Before Login

#4 Post by Eadwine Rose » Sat Nov 12, 2016 11:51 am

How is this going to be done when you cannot get to the desktop?
MX-17.1_x64 Horizon 14-3-2018 * 4.15.0-1-amd64 ext4 Xfce 4.12.3 * AMD Asus M4A785TD-V EVO AM3 * ASUS GF GT640-1GD5-L NVIDIA 384.130 * AMD Proc. Athl II X4 635, sAM3 * HDA ATI SB VT1708S An * 2x4Gb DDR3 1600 Kingst * 22" Samsung SyncM P2250 * HP F2280

User avatar
v3g4n
Forum Guide
Forum Guide
Posts: 1783
Joined: Sat Jan 16, 2016 8:20 pm

Re: Recent Update Problem - Hangs Before Login

#5 Post by v3g4n » Sat Nov 12, 2016 11:53 am

Hit ctl-alt f1 once lightdm doesn't appear and you are left with a black screen and login then type startx and your desktop will start. It's only lightdm that isn't working after the problem upgrade.

User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 16318
Joined: Fri Dec 15, 2006 8:07 pm

Re: Recent Update Problem - Hangs Before Login

#6 Post by Stevo » Sat Nov 12, 2016 1:13 pm

Eadwine Rose wrote:How is this going to be done when you cannot get to the desktop?
The geek way if all you have is a command prompt (faster, too) I'm too lazy to write up the command to disable the MX 16 repo in the CLI, unless it's sitting in mx16.list or something (Edit: added command to remove mx16.list).:

Code: Select all

sudo rm -f /etc/apt/sources.list.d/mx16.list
sudo apt-get update
sudo apt remove apt-mx mx-docs desktop-defaults-xfce-mx16
sudo apt install desktop-defaults-xfce-mx mx-docs apt-mx
sudo reboot
Last edited by Stevo on Sat Nov 12, 2016 4:01 pm, edited 1 time in total.

User avatar
GuiGuy
Forum Guide
Forum Guide
Posts: 1429
Joined: Sun Dec 16, 2007 6:29 pm

Re: Recent Update Problem - Hangs Before Login

#7 Post by GuiGuy » Sat Nov 12, 2016 2:10 pm

Phew!! Been fighting this on my 32-bit MX-15 for a couple of hours, but now almost back to normal.
Still a couple of problems, e.g. the apt-notifier is now a blank white square and I am informed that virtualbox(not installed BTW) is not working.

User avatar
kmathern
Forum Veteran
Forum Veteran
Posts: 9333
Joined: Wed Jul 12, 2006 2:26 pm

Re: Recent Update Problem - Hangs Before Login

#8 Post by kmathern » Sat Nov 12, 2016 2:30 pm

GuiGuy wrote:Phew!! Been fighting this on my 32-bit MX-15 for a couple of hours, but now almost back to normal.
Still a couple of problems, e.g. the apt-notifier is now a blank white square ...
The apt-notifer icons have been updated for mx16, and the only difference between mx15 & mx16 apt-notifier packages are the icons.

This will reinstall the mx15 version

Code: Select all

apt-get install apt-notifier=1.3.4mx150+1
If you still have the mx16 repos enabled you'll then need to pin it so doesn't upgraded again, you can do that in Synaptic.


I'm thinking of maybe doing an update that will include both the older icons and the new mx16 icons in the apt-notifier package, and make it so they be changed using the update-alternatives command.

User avatar
Eadwine Rose
Forum Veteran
Forum Veteran
Posts: 6058
Joined: Wed Jul 12, 2006 2:10 am

Re: Recent Update Problem - Hangs Before Login

#9 Post by Eadwine Rose » Sat Nov 12, 2016 2:38 pm

kmathern wrote:I'm thinking of maybe doing an update that will include both the older icons and the new mx16 icons in the apt-notifier package, and make it so they be changed using the update-alternatives command.
Thanks and oh please yes do, and do share how to, because I really don't like the newer ones in MX16 :frown:
MX-17.1_x64 Horizon 14-3-2018 * 4.15.0-1-amd64 ext4 Xfce 4.12.3 * AMD Asus M4A785TD-V EVO AM3 * ASUS GF GT640-1GD5-L NVIDIA 384.130 * AMD Proc. Athl II X4 635, sAM3 * HDA ATI SB VT1708S An * 2x4Gb DDR3 1600 Kingst * 22" Samsung SyncM P2250 * HP F2280

User avatar
Jerry3904
Forum Veteran
Forum Veteran
Posts: 22481
Joined: Wed Jul 19, 2006 6:13 am

Re: Recent Update Problem - Hangs Before Login

#10 Post by Jerry3904 » Sat Nov 12, 2016 2:41 pm

I really don't like the newer ones in MX16
So just change them: Settings Manager > Appearance > Icons
Production: 4.15.0-1-amd64, MX-17.1, AMD FX-4130 Quad-Core, GeForce GT 630/PCIe/SSE2, 8 GB, Kingston SSD 120 GB and WesternDigital 1TB
Testing: AAO 722: 4.15.0-1-386. MX-17.1, AMD C-60 APU, 4 GB

Post Reply

Return to “MX Help”