Welcome!
Important information
-- Spectre and Meltdown vulnerabilities
-- Change in MX sources

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-17.1 Final release info here
-- antiX-17 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

FF46 not launching in M11 [Resolved]

Message
Author
User avatar
TenderFoot
Forum Regular
Forum Regular
Posts: 604
Joined: Sun May 03, 2009 2:34 pm

FF46 not launching in M11 [Resolved]

#1 Post by TenderFoot » Wed Nov 09, 2016 3:45 pm

Re-installing M11(and M8!) on my Tosh yet again - because I still like them but please don't question my sanity. And they're younger then Win XP and 7 which are still used regularly!

Anyway, after sorting out the repos and gpgs' updated fine. Then checked the test repo for updates to FF and hplip (and screenlets). All installed without any apparent problem. However, FF46 won't launch so checked the link but that seems ok so went to /opt/firefox and clicked on firefox executable but still nothing?

In the meantime, wanted to "Get New Decorations" but it sticks infinitely at initializing, presumably because it can't touch bases with the resource? It wouldn't matter if they were included by aptoncd or I knew where they are stored on the old the hdd which is (still accessible?

[Judging by the lack of queries in this section of the forum, I am (one of) the last oldie stalwarts! I've tried to love MX14/15 which are also installed (elsewhere at the moment!) and will have another look at M16 beta.]
Last edited by TenderFoot on Thu Nov 10, 2016 10:35 am, edited 1 time in total.

User avatar
v3g4n
Forum Guide
Forum Guide
Posts: 1783
Joined: Sat Jan 16, 2016 8:20 pm

Re: FF46 not launching in M11

#2 Post by v3g4n » Wed Nov 09, 2016 3:50 pm

open a terminal and try and launch firefox from it and post the output.

User avatar
TenderFoot
Forum Regular
Forum Regular
Posts: 604
Joined: Sun May 03, 2009 2:34 pm

Re: FF46 not launching in M11

#3 Post by TenderFoot » Wed Nov 09, 2016 4:12 pm

Good idea - should have thought of that!

Code: Select all

Chris@Toshiba:~$ firefox
XPCOMGlueLoad error for file /opt/firefox/libmozgtk.so:
libgtk-3.so.0: cannot open shared object file: No such file or directory
Couldn't load XPCOM.
Chris@Toshiba:~$ 

User avatar
Jerry3904
Forum Veteran
Forum Veteran
Posts: 22480
Joined: Wed Jul 19, 2006 6:13 am

Re: FF46 not launching in M11

#4 Post by Jerry3904 » Wed Nov 09, 2016 4:14 pm

Not sure how much longer we can continue to support M11, just so you know.
Production: 4.15.0-1-amd64, MX-17.1, AMD FX-4130 Quad-Core, GeForce GT 630/PCIe/SSE2, 8 GB, Kingston SSD 120 GB and WesternDigital 1TB
Testing: AAO 722: 4.15.0-1-386. MX-17.1, AMD C-60 APU, 4 GB

User avatar
v3g4n
Forum Guide
Forum Guide
Posts: 1783
Joined: Sat Jan 16, 2016 8:20 pm

Re: FF46 not launching in M11

#5 Post by v3g4n » Wed Nov 09, 2016 4:22 pm

Have you ever gotten FF46 to work with M11? From a quick google search the error you are getting is do to the fact the FF46 requires gtk3.4 or newer. If I was you I would stick with the 45 ESR version since it is getting security fixes while 46 is not.

Edit: Also found this article, it's for Debian 6 though, and the writer was able to solve it by installing libdbus-glib-1-2. Do you have that package installed?
http://el.web.id/how-to-solve-xpcomglue ... debian-149

User avatar
TenderFoot
Forum Regular
Forum Regular
Posts: 604
Joined: Sun May 03, 2009 2:34 pm

Re: FF46 not launching in M11

#6 Post by TenderFoot » Wed Nov 09, 2016 4:29 pm

Jerry
Which is why snapshot in MX1x (remastering in other distros) is so useful for installing/reinstalling across machines when you have tweaked it to your liking and continues to work to ones liking.

Doesn't explain why FF46 is available but non-functioning in a fresh install...

v3g4n
Except that FF45 was never an option but will study your suggestion and report back

EDIT Yes FF45-esr is an option so will try uninstalling FF46 and install that....

EDIT 2 Yes FF45 working fine. I don't mind not having the latest as Mozilla keep b.....ing around with the bookmarks menu!

Now for accessing the Window Decorations or copying from old install?
Last edited by TenderFoot on Wed Nov 09, 2016 5:03 pm, edited 2 times in total.

User avatar
anticapitalista
Forum Veteran
Forum Veteran
Posts: 5714
Joined: Sat Jul 15, 2006 10:40 am

Re: FF46 not launching in M11

#7 Post by anticapitalista » Wed Nov 09, 2016 4:42 pm

Has snapshot ever worked on MEPIS 11 or even MEPIS 8? WOW if it has.
anticapitalista
Reg. linux user #395339.

Philosophers have interpreted the world in many ways; the point is to change it.

antiX-17 "Heather Heyer" - lean and mean.
https://antixlinux.com

User avatar
kmathern
Forum Veteran
Forum Veteran
Posts: 9333
Joined: Wed Jul 12, 2006 2:26 pm

Re: FF46 not launching in M11

#8 Post by kmathern » Wed Nov 09, 2016 4:42 pm

TenderFoot wrote:...Doesn't explain why FF46 is available but non-functioning in a fresh install...
This came up before back in May: viewtopic.php?p=387154#p387154
Stevo wrote:The latest Firefox requires GTK 3 instead of GTK 2 now, which is not available for MEPIS 11. Those packages need to be pulled from the repo, and Firefox "sunsetted" for M11. ...
It must not have gotten pulled like Stevo recommended.

User avatar
TenderFoot
Forum Regular
Forum Regular
Posts: 604
Joined: Sun May 03, 2009 2:34 pm

Re: FF46 not launching in M11

#9 Post by TenderFoot » Wed Nov 09, 2016 4:56 pm

Has snapshot ever worked on MEPIS 11 or even MEPIS 8? WOW if it has.
I don't think I said that - quite the opposite! If I could it would have more than halved my need for posts...

But thanks for your comments all.

User avatar
v3g4n
Forum Guide
Forum Guide
Posts: 1783
Joined: Sat Jan 16, 2016 8:20 pm

Re: FF46 not launching in M11

#10 Post by v3g4n » Wed Nov 09, 2016 5:13 pm

TenderFoot wrote:Now for accessing the Window Decorations or copying from old install?
Themes are usually stored in one of two places. For KDE though they may be placed somewhere in the .kde folder.
/usr/share/themes/
~/.themes
~/.kde

Post Reply

Return to “Software / Configuration”