Fast news: @MX_Linux

The Forum is now on mxlinux.org and uses an encrypted (https) connection

Please read this Important information: Linux kernel exploit

  • antiX-16, release info here -- watch the video. Torrents here
  • MX-15 (antiX MX), release info here: here. Monthly update/upgrade available here.
  • Older MX Linux releases available on the download page

New users
  • Please read this first, and don't forget to add system and hardware information to posts!

Antix reposititory

Forum Regular
Forum Regular
Posts: 278
Joined: Mon Apr 16, 2012 4:51 pm

Antix reposititory

#1 Postby antiX-Dave » Mon Apr 16, 2012 5:21 pm

Hello mepis people,

I with the help of others have been working on putting together an apt repository for antix. While trying to set it up, I have come accross a problem that is proving to be rather difficult to solve.

Currently I am trying to build the repository using reprepro. It works out great as the root user, or as a regular user with root priveleges. I would like to have it working as a regular user without the need to be referanced to "root" in any way. Every thing that I can think of at the moment allways ends up with the same result from reprepro.

Code: Select all

gpgme gave error GPGME:150:  Invalid crypto engine
Exporting testing...
gpgme gave error GPGME:150:  Invalid crypto engine
ERROR: Could not finish exporting 'testing'!
There have been errors!


Code: Select all

Origin: daveserver.info
Label: antiX repository
Suite: testing
Codename: testing
Version: 3.1
Architectures: i386 i486 i686 m68k sparc alpha powerpc arm armel mips mipsel hppa ia64 s390 amd64
Components: main full base core
Description: A place for all the antix apps
SignWith: 3465FC9B


Code: Select all


The gpg key for the SignWith option is made as root using the gpg --gen-key command
gpg --gen-key
option (1) RSA and RSA
keysize 1024
0 = key does not expire

From my lack of ability to solve this we have looked into other repository management utilities such as apt-move which skips every single file I tried to add. Right now I am feeling open to any comments / suggestions that people may have on how to setup and run an apt repository.
The basic requirements we are looking for: (That I can think of)
1. multiple user access. (So that all contributing developers can upload to the repository)
2. gpg signed ( So apt does not ask to verify the install )
3. Support for multiple branches
> http://antix.example/repo testing full main
> http://antix.example/repo testing base main
> http://antix.example/repo testing core main

Any comments / suggestions / questions will be greatly appreciated

User avatar
Forum Veteran
Forum Veteran
Posts: 12373
Joined: Wed Jul 12, 2006 5:54 am

Re: Antix reposititory

#2 Postby lucky9 » Mon Apr 16, 2012 7:42 pm

I suspect that the Linux security model is your problem. root privileges are required for this sort of thing I'd think. Perhaps someone more familiar might be able to help but I'd be surprised if you can do much without root privileges.
Yes, even I am dishonest. Not in many ways, but in some. Forty-one, I think it is.
--Mark Twain

User avatar
Forum Guide
Forum Guide
Posts: 1483
Age: 58
Joined: Wed Jul 12, 2006 4:30 pm

Re: Antix reposititory

#3 Postby JBoman » Mon Apr 16, 2012 8:40 pm

Don't know much about it but searching around I found this> http://linuxconfig.org/easy-way-to-crea ... repository ...looks to me like you just need a server installed like apache and then configure everything like permissions from the server admin. :confused: Jerry
AMD 64x2 2.6GHz 4GB ram MX-15 regular updates
"beware a frequent flirt with potential disaster"

Forum Regular
Forum Regular
Posts: 278
Joined: Mon Apr 16, 2012 4:51 pm

Re: Antix reposititory

#4 Postby antiX-Dave » Tue Apr 17, 2012 2:47 pm

Thanks for the replies,
Apache is installed and configured to point to the directory which holds the apt repository, this seems to function correctly. It is possible, though I am hoping not, that it is the linux security model. I believe that this is not the case because in a lot of howtos I have read it has used reprepro as the root user and as regular user. I was thinking that it may be because I made the gpg key as root that I would need to remain root. However changing the repository to use a key made by a regular user did not help.

Return to “antiX”

Who is online

Users browsing this forum: No registered users and 1 guest