Fast news: @MX_Linux

The Forum is now on mxlinux.org and uses an encrypted (https) connection

  • antiX-16, release info here -- watch the video. Torrents here
  • MX-15 (antiX MX), release info here: here. Monthly update/upgrade available here.
  • Older MX Linux releases available on the download page

New users
  • Please read this first, and don't forget to add system and hardware information to posts!

VMWare Workstation 7 on Mepis11 and Windows98 as Guest

Here you can post threads/topics about programs like vmware, parallels, qemu, virtualbox, dosbox and all the other virtual machines/emulators that exist. This includes how to setup, suggestions on what works well with MEPIS and what doesn't, etc.
Forum Novice
Forum  Novice
Posts: 27
Joined: Tue Jan 24, 2012 12:58 am

VMWare Workstation 7 on Mepis11 and Windows98 as Guest

#1 Postby mr.Lauren » Tue Feb 07, 2012 12:54 am

Perhaps someone will be helped by my experience of installing VMWare Workstation 7.1.4 on Mepis11, and then Windows98 as Guest. I'm not sure whether this should have been placed in the "Success" or the "Testimonials" forums instead. If so, someone is welcome to move it, or, if it is of no value, delete it.

In the first place, I was amazed that VMWare installed with zero problems! I was expecting some significant problems here because it doesn't seem to be directly supported. The steps here were to download it to the folder of your choice. Then in a terminal (Konsole), as root, move to the folder where it was placed, and enter the command:

Code: Select all

sh [package name].

When I tried to install Windows98, the first thing that happened was I got the error message that there is no /dev/vmmon device. When this happened in SLED11, I had found on Internet the command

Code: Select all

mknod /dev/vmmon c 18 165
. Somehow I "slipped though the crack", because I believe that is not correct. There is a "Devices.txt" list maintained at this Web site:
which shows the /dev/vmmon to be located at 165 in group 10. So I used the command:

Code: Select all

mknod /dev/vmmon c 10 165
and it worked.

Next I got the error message about "Too Many Virtual Machines Running". The fix for that was the command

Code: Select all

Now I could start the install.

In the install of Windows98, I first tried to install directly from the CD. It didn't work. Mine needs the boot floppy, and I used a boot floppy image. Here are 2 sources for boot floppy images:
In the VMWare settings, set the Floppy to "connected" and to "image", and browse to the file. After this was done, it found the A: drive.

Use FDISK to define all the drives you established when defining the Windows98 guest in VMWare, and then format them. I think you have to exit before you can FORMAT.

Now you can go to the cd drive where Windows98 is mounted. If you have both 98 & 98SE, choose the one you want and find the "setup.exe" file and enter it. The Install process will begin. Sometime after the point that it offers to make a "Start-up Floppy", and before it wants to re-start Windows, you need to disconnect the boot image, or it won't restart. I went through the installation 3 times before I realized that was the problem! Also, after Windows is installed, Install the "VMWare Tools" if you didn't get them initially.

There is a 2-Part set of a youtube tutorial that you might like to see at:

I am happy that this worked, as I was afraid it might take a lot more study.

Return to “VMs/Emulators”

Who is online

Users browsing this forum: No registered users and 1 guest