Fast news: @MX_Linux

The Forum is now on mxlinux.org and uses an encrypted (https) connection

Please read this Important information Linux kernel exploit

  • antiX-16, release info here -- watch the video. Torrents here
  • MX-15 (antiX MX), release info here: here. Monthly update/upgrade available here.
  • Older MX Linux releases available on the download page

New users
  • Please read this first, and don't forget to add system and hardware information to posts!

How To: NetworkManager in Debian Squeeze: Enabling Interface

Questions about Networking that deals with wireless cards, ethernet, modems, samba and anything else related to these, including software help. Tutorials for any of these can be posted too.

Remember to provide relevant info in your posts, such as the following information:

Version of Mepis being used
Card Manufacturer (i.e. Linksys)
Card Model (i.e. WMP54G)
Type: (PCI or PCMCIA)
Current Kernel in use on their system (i.e. 2.6.10)
Udev or Hotplug
Exact steps taken to get the card working if it is not immediately recognized by MEPIS.
User avatar
Forum Novice
Forum  Novice
Posts: 8
Joined: Mon May 21, 2012 8:22 pm

How To: NetworkManager in Debian Squeeze: Enabling Interface

#1 Postby eeepcuser » Wed May 23, 2012 3:21 pm

How To: NetworkManager in Debian Squeeze: Enabling Interface Management

As of Debian Squeeze, NetworkManager does not manage any interface defined in /etc/network/interfaces by default:
Since network-manager version 0.8.1-4, existing wired/wireless interfaces in /etc/network/interfaces
are disabled with a #NetworkManager# prefix during package installation, then re-enabled when the network-manager package
is removed (Debian bug 530024).

Unmanaged devices means NetworkManager doesn't handle those network devices.

Enabling Interface Management:
If you want NetworkManager to handle interfaces that are enabled in /etc/network/interfaces:
Set managed=true in /etc/NetworkManager/NetworkManager.conf.
Restart NetworkManager:
/etc/init.d/network-manager restart

Source: http://wiki.debian.org/NetworkManager#doc

My wlan0 stettings within the NetworkManager are: „Use static IP settings“.

Therefor, I disabled the „auto wlano“ file entry in /etc/network/interfaces that would otherwhise conflict with a static setting by commenting it out.
My system profile:

User avatar
Forum Veteran
Forum Veteran
Posts: 3070
Joined: Sat May 16, 2009 3:59 pm

Re: How To: NetworkManager in Debian Squeeze: Enabling Inter

#2 Postby DBeckett » Wed May 23, 2012 10:03 pm

It's ironic that you would post this now.

Some weeks ago my wired connection quit working in Wheezy after an update. I gave up trying to figure out why, and loaded wicd instead, which worked just fine.

Just last night I figured out by trial and error that changing "managed" to "true" would get Network-Manager working again. The connection is named "ifupdown (eth0)." That's a little weird, but it works fine now.
Gigabyte 990FXA-UD3, AMD FX-6100 hex-core, 3.3GHz, 8G, Radeon HD6570

Return to “Networking”

Who is online

Users browsing this forum: No registered users and 1 guest