Fast news: @MX_Linux

The Forum is now on mxlinux.org and uses an encrypted (https) connection

  • antiX-16, release info here -- watch the video. Torrents here
  • MX-15 (antiX MX), release info here: here. Monthly update/upgrade available here.
  • Older MX Linux releases available on the download page

New users
  • Please read this first, and don't forget to add system and hardware information to posts!

Printer config failure: no kcmodule - known bug elsewhere

Questions about printers and scanners, hardware-related and/or software-related can be asked here, as well as posting of tutorials.
User avatar
Forum Novice
Forum  Novice
Posts: 71
Age: 71
Joined: Fri Jul 21, 2006 2:28 am

Re: Printer config failure: no kcmodule - known bug elsewher

#21 Postby arjay » Tue Dec 06, 2011 2:05 pm

UPDATE re upgrade to kde 4.6.5. Thanks go to those who suggested this was the way to get Printer Config to work. Although I successfully got my printer configured via CUPS, I still wanted to get the kde print config to work again. I have now done it by upgrading to kde 4.6.5

However, it was a scary process as I had already borked my production PC's install of Mepis 11 by not carefully following the various guides on how to do it. Since then I have had to install a new copy of Mepis and had to copy back all my backed up files then set everything back up to my ways again - not recommended :mad: .

I then reinstalled Mepis 11 (32 bit) on a spare PC to try a 4.6.5 upgrade before doing it on the main PC. This is how I upgraded. CAUTION - it is a big upgrade and AFAICS not all guides agree on the best way to do it. You follow this at your own risk:

1. Update your install with the standard repos enabled.

2. In Synaptic, enable the community repo (looks like: this http://main.mepis-deb.org/mepiscr/repo/)

3. Under Settings/Preferences/Distribution check "Prefer versions from mepis" - crucial: not doing this was what eventually borked my last attempt!!

4. Reload - Mark Upgrades - Apply as usual.

5. I then rebooted and checked all was working OK - it was.

6. Open Synaptic again and enable the test repo (http://main.mepis-deb.org/mepiscr/testrepo/)

7. Repeat 4 and 5 above

8. Afrer rebooting again open Synaptic and DISABLE/UNCHECK the main mepis repo. Then create a new repo for kde - should be like this:

Code: Select all

    URI:          http://main.mepis-deb.org/mepiscr/kde/
 Distribution: experimental
 Section(s):   test        

9. Choose Reload and Apply. Before committing, just check that the list looks about right. It should offer to remove only 5 packages - if it says it is going to remove dozens then cancel the update and come back here or read other guides. There should be around 37 new packages to be installed and 200+ to be upgraded. If all looks OK then Apply.

10. After the upgrade, I found that none of the icons on the panel would work - they just opened the "Open With" dialogue. Don't panic - a reboot fixes this. So REBOOT and all should be well

10. Not sure if this is right but after the reboot I opened Synaptic and re-enabled the main mepis repo.

Hope this helps those who can't get their printers configured.


User avatar
Posts: 13273
Joined: Wed Jul 12, 2006 2:17 pm

Re: Printer config failure: no kcmodule - known bug elsewher

#22 Postby richb » Tue Dec 06, 2011 2:06 pm

kmathern wrote:
Utopia wrote:
Did you add it yourself as I do not have that package, nor do I see it in the repos

It's in the repos, but you have to add it yourself. Search for system-config-printer and get all recommended and suggested packages.

That package, system-config-printer, is installed by default in M11. The system-config-printer-kde package is also preinstalled (on a 32bit anyway).

I did notice that when I looked earlier, that I didn't find the Kmenu "Printing" entries added by system-config-printer. I removed it (and it's autoremove dependencies) and reinstalled and I now have the KMenu entries.

A bug? Removing and re-installing did add it to the menu.
Forum Rules
Guide - How to Ask for Help


Laptop: Acer V5-572G: Intel i5, 12 GIG mem, Intel graphics, SanDisk SSD, 256GB
Virtualbox: Win 7
Desktop: MX-15- 64, AMD A8 7600 FM2+ CPU R7 Graphics, fglrx driver, 16 GIG Mem. Samsung EVO SSD 250 GB

User avatar
Forum Veteran
Forum Veteran
Posts: 3732
Joined: Sun Apr 29, 2007 11:53 am

Re: Printer config failure: no kcmodule - known bug elsewher

#23 Postby Utopia » Tue Dec 06, 2011 2:17 pm

A bug? Removing and re-installing did add it to the menu.

Yes, and it was a bug that made me believe it wasn't installed from the beginning.
Isn't it kmenu that is slightly buggy? Or maybe it isn't working like it used to.

User avatar
Forum Guide
Forum Guide
Posts: 1569
Age: 58
Joined: Tue Jul 25, 2006 12:47 pm

Re: Printer config failure: no kcmodule - known bug elsewher

#24 Postby JimC » Tue Dec 06, 2011 2:47 pm

I removed system-config-printer and system-config-printer-kde, and now I have a Printing menu choice under KMenu>System, and it does load. It won't give me ink levels from my HP though (gives some type of unsupported by client error).

Removing and reinstalling those two packages also made my Printer Configuration icon move down into the "Lost and Found" section of System Settings (when it was in the Hardware Section before), and I still get the same error screen as before if I click on it. The HPLIP Printer Toolbox still won't load either.

But, I can print now (I was able to after using the Resume choice earlier from the CUPS Web Interface for it) so that's progress.

Note that I did try running hp-check from a console, and see a problem that may or may not have something to do with it. It checks a lot of things, but this is being reported as an error:

Code: Select all

Checking for dependency: PyQt 4 DBus - DBus Support for PyQt4...
error: NOT FOUND! This is a REQUIRED/RUNTIME ONLY dependency. Please make sure that this dependency is installed before installing or running HPLIP.

Note that if I search for pyqt4 using Synaptic, I see that python-qt4-dbus and python-qt4 are both installed and at version 4.7.3-1+b1 (which is the only version I see available for them under the Versions tab).

I also see an error related to DBus when I run the same command I see KMenu is using for the HPLIP toolbox from a console. See what happens when I try to run the HPLIP toolbox here:

Code: Select all

jimcockfield@jimdesktop:~$ /usr/bin/hp-toolbox

HP Linux Imaging and Printing System (ver. 3.10.6)
HP Device Manager ver. 15.0

Copyright (c) 2001-9 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

error: Unable to load DBus libraries. Please check your installation and try again.

So, I'm guessing it has something to do with Dbus, but I see python-qt4-dbus already installed.

Return to “Print/Scan”

Who is online

Users browsing this forum: No registered users and 1 guest