Fast news: @MX_Linux

The Forum is now on mxlinux.org and uses an encrypted (https) connection

  • antiX-16, release info here -- watch the video. Torrents here
  • MX-15 (antiX MX), release info here: here. Monthly update/upgrade available here.
  • Older MX Linux releases available on the download page

New users
  • Please read this first, and don't forget to add system and hardware information to posts!

how do you "remove" a sound card? "resolved"

Problems with your sound card are to be posted here, as well as tutorials to share with others.
User avatar
Forum Regular
Forum Regular
Posts: 182
Joined: Tue May 01, 2007 4:31 am

how do you "remove" a sound card? "resolved"

#1 Postby savvy_cowgirl » Mon Aug 01, 2011 1:31 am

It appears my somewhat confused HP g6-1b59wm thinks it has TWO sound cards, it does not. According to the specs off the HP web site, it has SRS Premium Sound with Altec Lansing speakers. According to inxi it has
inxi -xrFA
System: Host: daisy Kernel: 2.6.39-2.dmz.1-liquorix-686 i686 (32 bit, gcc: 4.4.5)
Desktop KDE 4.5.3 (Qt 4.7.1) Distro: MEPIS 11.0 squeeze
Machine: System: Hewlett-Packard (portable) product: HP Pavilion g6 Notebook PC version: 0581110003203F10000620100
Mobo: Hewlett-Packard model: 169B version: KBC Version 18.09 Bios: Hewlett-Packard version: F.21 date: 05/13/2011
CPU: Dual core AMD A4-3300M APU with Radeon HD Graphics (-MCP-) cache: 2048 KB flags: (lm nx sse sse2 sse3 sse4a svm) bmips: 7587.7
Clock Speeds: 1: 1896.928 MHz 2: 1896.928 MHz
Graphics: Card: ATI Device 9648 bus-ID: 00:01.0
X.Org: 1.7.7 drivers: ati,vesa (unloaded: fbdev,radeon) Resolution: 1368x768@0.0hz
GLX Renderer: N/A GLX Version: N/A Direct Rendering: N/A
Audio: Card-1: Advanced Micro Devices [AMD] Hudson Azalia Controller driver: HDA Intel bus-ID: 00:14.2
Card-2: ATI Device 1714 driver: HDA Intel bus-ID: 00:01.1
Sound: Advanced Linux Sound Architecture ver: 1.0.24

Network: Card-1: Ralink Device 5390 driver: rt2800pci ver: 2.3.0 bus-ID: 07:00.0
IF: wlan0 state: up speed: N/A duplex: N/A mac: d0:df:9a:05:5e:19
Card-2: Realtek RTL8101E/RTL8102E PCI Express Fast Ethernet controller
driver: r8169 ver: 2.3LK-NAPI port: 3000 bus-ID: 01:00.0
IF: eth0 state: down speed: 10 Mbps duplex: half mac: 78:e3:b5:50:6f:1f
Drives: HDD Total Size: 640.1GB (2.1% used) 1: /dev/sda TOSHIBA_MK6476GS 640.1GB
Partition: ID: / size: 74G used: 4.7G (7%) fs: ext3 ID: /home size: 354G used: 8.0G (3%) fs: ext3
ID: swap-1 size: 5.37GB used: 0.00GB (0%) fs: swap
Sensors: System Temperatures: cpu: 53.5C mobo: 0.0C
Fan Speeds (in rpm): cpu: N/A
Repos: Active apt sources in file: /etc/apt/sources.list
deb ftp://ftp.mirrorservice.org/sites/ftp.mepis.org/mepis/ mepis-11.0 main
deb ftp://ftp.debian.org/debian/ squeeze main contrib non-free
deb http://security.debian.org/ squeeze/updates main contrib non-free
deb http://ftp.debian.org/debian/ squeeze-updates main
deb http://www.debian-multimedia.org/ squeeze main non-free
deb http://main.mepis-deb.org/mepiscr/repo/ mepis11cr main non-free
deb http://restricted.mepis-deb.org/mepiscr/repo/ mepis11cr restricted restricted-non-free
Info: Processes: 146 Uptime: 9 min Memory: 418.7/3036.2MB Runlevel: 5 Gcc sys: 4.4.5 Client: Shell inxi: 1.7.23

this is a picture of my device viewer, it looks like there is way more listed than should be.

here is the weird stuff. I can play a DVD using kaffeine, but vlc can't. VLC wants updated alsa-libs I can't find in synaptic. Kaffeine can play video clips fine, VLC can't. I can play audio clips through amorok, but, and this is the killer, NO sound on the internet. Firefox can't play a youtube. The video portion is fine, the audio portion is absent. KMix shows TWO HD-Audio Generic tabs, one has IEC958 and it looks like a speaker plug in jack, the other tab has all, master, headphone, internal mic, speaker and capture and another mic (I guess cause you can plug one in). If you hover over KMix, it shows volume as "0". But, system sound plays fine on boot up and shut down, and I control the volume by the slider switch on kmix because the keys on the keyboard while they bring up the volume bar, don't change the volume. The other function keys like screen brightness or dimness do work. I've run update pciids and usbids hoping maybe it was just mis-identifying something, but that didn't fix it. I think it's a conflict, I just don't know what to do about it.
Thanks!!! :crossfingers:
Last edited by savvy_cowgirl on Sat Aug 06, 2011 5:15 pm, edited 1 time in total.

User avatar
Forum Veteran
Forum Veteran
Posts: 16019
Joined: Wed Jul 19, 2006 6:13 am

Re: how do you "remove" a sound card?

#2 Postby Jerry3904 » Mon Aug 01, 2011 8:01 am

In the past I have done this by entering the BIOS at boot up (watch the screen for which key to press, e.g., F2, F10, etc.), then click on an Advanced tab or something like it, where you can then uncheck the card and save the new settings.
Production: 4.7.0-0.bpo.1-amd64, MX-15 RC1, AMD FX-4130 Quad-Core, GeForce GT 630/PCIe/SSE2, 8 GB, Kingston SSD 120 GB and WesternDigital 1TB
Testing: AAO 722: 3.16-0-4-686-pae. MX-15, AMD C-60 APU, 4 GB

User avatar
Forum Veteran
Forum Veteran
Posts: 3510
Joined: Wed Jul 12, 2006 4:05 pm

Re: how do you "remove" a sound card?

#3 Postby timkb4cq » Mon Aug 01, 2011 10:36 am

Your second sound card is the audio for the HDMI connector on your Video. If you were ever to hook up to your TV instead of a monitor you would use that "sound card".
There's generally no need to remove it as such. Just go to System Settings -> Hardware -> Multimedia -> Device Preference -> Audio Output and make sure the correct device is selected for each of the sound types.

As to VLC - the installed debian squeeze vlc 1.1.3 is built against the squeeze ffmpeg and doesn't work properly on some audio types with Warren's supplied ffmpeg.

The Community Repository has an updated 1.1.10 vlc (1.1.11 in the testing CR) built against Warren's ffmpeg that does work correctly. Firefox is set up to use the vlc-plugin so upgrading the vlc packages may help there as well.
MSI 970A-G43 MB, AMD FX-6300 (six core), 16GB RAM, GeForce 730, Samsung 850 EVO 250GB SSD, Seagate Barracuda XT 3TB

User avatar
Forum Regular
Forum Regular
Posts: 521
Joined: Thu Apr 19, 2007 11:42 am

Re: how do you "remove" a sound card?

#4 Postby entropyfoe » Mon Aug 01, 2011 2:35 pm

See this thread for what I have tried

starting with post#273847 and proceeding on 4 pages. As you can read Amarok and system sounds play fine, so I know the sound can work.

On the system in question, specs in the signature below, I still have no sound from Firefox, despite many things tried. Chrome does not have sound either.
About the only thing not tried is the vlc (1.1.11 in the testing CR) timkb4cq wrote.

That's something to check tonight. This is a tough one, as I have another similar system, where the sound works well in Fire Fox.
I have gotten it to work twice, but it was not persistent after a reboot, even though the synaptic changes were still there.

Jerry's comment about disabling one in the BIOS sounds good, as the system I have with no browser sound also has an added sound card, and the motherboard's on-board sound is turned off in the BIOS.

Asus Sabertooth 990FX R2.0 MB
AMD FX8320 3.5 GHz octo-core
16 Gig DDR3 1600 (Crucial)
Nvidia -ASUS 210 fanless
OCZ Vertex4 128G SSD (sda1,2, and 3=MX-15) sda4=AntiX 16
2TB WD sdb1= data
on-board ethernet & sound

User avatar
Forum Regular
Forum Regular
Posts: 182
Joined: Tue May 01, 2007 4:31 am

Re: how do you "remove" a sound card?

#5 Postby savvy_cowgirl » Mon Aug 01, 2011 8:48 pm

Thanks Jerry, I tried, but my bios setting doesn't give me that option. I can change languages, boot order, boot device preference, but not disable cards...
I did go to the settings>multimedia, and under the phonon tab, moved the STAC92xx analog to the top position for every category. There is a "remove" button I would have used on the HDMI choice, but it's greyed out.
I THINK, it's an alsa problem. Or Kmix (which I uninstalled and re-installed). If I type alsaconf in a konsole, I get: No supported PnP or PCI. It ends up configuring snd-opl35a2 (I think, if I read my own writing properly). Alsa is configuring the ATI, which I think is the HDMI.
Typing alsamixer in konsole gives me this
and I have a choice of the two cards.
Starting it from the menu gives me this
Kmix has two tabs,both labeled Generic Audio-HD, neither of them has a pcm.....and the tab shown is the second one listed. I think alsa has the wrong card dominate. Aren't I suppose to have a pcm?
I installed the latest flash from their web site using your post entropyfoe, no joy, not even as much as you got! I guess it worked, before I installed it firefox was showing it needed a plugin (I made sure I removed the flashplayer mozilla) Firefox won't even play a .mp3 off a web site, though I have kaffeine set to handle mp3. I also changed it in file associations. Now, Konqueror will play mp3 from a web link, fires kaffeine up just like firefox did on Mepis 8, but it crashes on a youtube.
I've done some yahoo searching, still haven't found a good solution.
Is there something besides alsa? Is there some way to make alsa pick the IDT High Def Audio 92HD81B1X5? Which seems to show up as the STAC92xx?
I see there is another person that has posted with the same issue. I wonder if we all have the same cards?
Thanks!! :p

I forgot to say I checked my version of VLC, it is the latest one. I'm getting the same error message as entropyfoe about alsa lib, which after Stevo told what they're called in synaptic, I checked, and have the latest version of those too!

User avatar
Forum Veteran
Forum Veteran
Posts: 11601
Age: 58
Joined: Fri Dec 15, 2006 8:07 pm

Re: how do you "remove" a sound card?

#6 Postby Stevo » Mon Aug 01, 2011 10:17 pm

I'm still curious--are you sure you have vlc 1.1.11 instead of 1.1.3?

Also with KMix, on my system there were some sliders missing on the default mixer that came up. I had to go into Settings / Configure Channels and add them, plus make sure they were enabled.

Since I installed pulseaudio to get Kazam to work, I only have one volume slider available in Kmix, but the internal mic and all volume still works, so I'm leaving it as is for now.
The optimist proclaims that we live in the best of all possible worlds, and the pessimist fears this is true.

James Branch Cabell

User avatar
Forum Regular
Forum Regular
Posts: 182
Joined: Tue May 01, 2007 4:31 am

Re: how do you "remove" a sound card?

#7 Postby savvy_cowgirl » Mon Aug 01, 2011 11:37 pm

Ok, I enabled the testing repos and got the 1.1.11, instead of, I think it was .10 in the regular repos. I popped in a DVD and am still getting
Potential ALSA version problem:
VLC failed to initialize your sound output device (if any).
Please update alsa-lib to version 1.0.23-2-g8d80d5f or higher to try to fix this issue.
I've double checked even with testing enabled, libsound2 is the highest. Kaffeine can play it though.
I've added all the available sliders to the right side of configure kmix, so they all show up (though I still don't have a pcm).
Alsamixer started from the menu only has the card that won't do anything, if I start if from konsole, I can select the other card, but I can't make it top priority. I've been reading in the alsa wiki.....oh Steveo! I am SO in over my head!
I think Tim has it nailed, it's due to the webcam & mike which alsawiki says will be detected as another sound card. I can play a file from konsole like it said in alsa wiki, by choosing my device (of which a whole bunch were listed, most of them with surround in front of the name) and I can make the STAC92xx play a file. I just can't figure out where to go from there. Alsawiki says alsa needs to be loaded as modules not in with the kernel, and it sounds like it would be so simple to just change the preferred order in some file, and I may have to make a .asoundrc which the alsawiki says is complicated you probably shouldn't need one but if you do there is a problem. So, it seems like the problem is due to more than one "sound card" and the dominate card is not the one I want, and I haven't figured out how to change that. I tried in settings>multimedia then the phonon tab, but that didn't seem to do it. I think that's why the dvd won't play in vlc, is it can't initialize a sound device. Don't know why that doesn't affect kaffeine though, or amarok either..

User avatar
Forum Veteran
Forum Veteran
Posts: 12373
Joined: Wed Jul 12, 2006 5:54 am

Re: how do you "remove" a sound card?

#8 Postby lucky9 » Tue Aug 02, 2011 12:13 am

With the CR testing enabled you need to change Preferences to Prefer mepis temporarily. Change it back after you get vlc 1.1.3 installed.
Yes, even I am dishonest. Not in many ways, but in some. Forty-one, I think it is.
--Mark Twain

User avatar
Forum Regular
Forum Regular
Posts: 182
Joined: Tue May 01, 2007 4:31 am

Re: how do you "remove" a sound card?

#9 Postby savvy_cowgirl » Tue Aug 02, 2011 1:13 am

Do I want 1.1.3 or 1.1.11?? I thought I wanted 1.1.11, so that's why I enabled testing. I took it off after I got 1.1.11.

User avatar
Forum Veteran
Forum Veteran
Posts: 3259
Age: 49
Joined: Sat Apr 21, 2007 11:59 pm

Re: how do you "remove" a sound card?

#10 Postby Brooko » Tue Aug 02, 2011 6:20 am

Hi Savvy

I feel for you - I had the same issue. It was a killer for me - I can't do without consistent sound. In the end (same hardware) I installed pure Debian (netinst) - just a base install, then added KDE4 on top. I'm currently running 64b Testing. The problem is gone. I'll wait for the next version of Mepis and try again when it's released.

You could try from an Antix base - or just dabble with Debian. It's actually not that hard and I'm really happy with the system. Might be an option if you can't get 11 rocking.
Desktop - Win 8-64 : Corsair 520HX, P5Q Pro, Q6600 G0 @ 3Ghz, 4Gb DDR2 1066, Asus GTX560 OC, 3xWD 500Gb Sata2, Asus CD/DVD, Logitech Wave Kb, G5, C300 Cam, Audio-gd NFB-12 + LD MKIV + GigaWorks T20.
Netbook - Ubuntu 12.04 64b, Asus 1015PED 2Gb Ram

Return to “Sound”

Who is online

Users browsing this forum: No registered users and 1 guest