Welcome!
Forum users
  • Please read this before asking for help, and don't forget to add Quick System Info to help requests!
  • Please follow the Forum Rules

Current releases
--MX-21 release info here
--Migration information to MX-21 here
--antiX-21 (Grup Yorum) release info here

Important information
-- Spectre and Meltdown vulnerabilities

News
-- MX Linux on social media: here
-- New Forum Features, Marking Solved and Referencing a User: here

Is it something wrong in repositories ?  [Solved]

Message
Author
User avatar
abhidesh128
Posts: 72
Joined: Sun Nov 08, 2020 7:03 am

Re: Is it something wrong in repositories ?  [Solved]

#21 Post by abhidesh128 »

As most of the guys said here, waiting a few hours is the most probable solution. Sometimes repositories may take a while to get up to the mark. I had not faced such a situation before this issue, so I thought something went wrong...!
Loving Linux...Since ages...!

User avatar
asqwerth
Developer
Posts: 8413
Joined: Sun May 27, 2007 5:37 am

Re: Is it something wrong in repositories ?

#22 Post by asqwerth »

figueroa wrote: Sat Sep 25, 2021 1:07 pm @Eadwine Rose
... In other words, are there possible unintended consequences? Sometimes a package is upgraded because the new specific version is a dependency of another package being upgraded. I see the possibility of cascading "dependency hell" as a result of over-management.

...
Nah, this is not a rolling distro like your Gentoo . If the upgradable package you deselect in synaptic has other dependencies that are also upgradable, synaptic will give you a pop up to inform you, and ask if you wish to deselect those. As long as you say yes, the rest of the updates will go through fine with no dependency issues.

All it means is that after that update, your apt-notifier icon will still stay green, because there are still updates available.

And if you reopen synaptic some time later, the upgradeable section will still contain those packages you deselected.

(ADDED) of course this assumes you don't have other error messages about repo failures or sync errors, which might give your system a wrong picture of the upgradeable packages. Where such exist, wait a while for the repos to sync properly, before trying to upgrade.

But when everything is fine with the repos, one can always selectively upgrade packages in Debian stable.
Desktop: Intel i5-4460, 16GB RAM, Intel integrated graphics
Clevo N130WU-based Ultrabook: Intel i7-8550U (Kaby Lake R), 16GB RAM, Intel integrated graphics (UEFI)
ASUS X42D laptop: AMD Phenom II, 6GB RAM, Mobility Radeon HD 5400

User avatar
figueroa
Posts: 1316
Joined: Fri Dec 21, 2018 12:20 am

Re: Is it something wrong in repositories ?

#23 Post by figueroa »

@asqwerth Thanks for filling in the rest of the story.
Andy Figueroa
Using Unix from 1984; GNU/Linux from 1993

Post Reply

Return to “General”