Welcome!
Forum users
  • Please read this before asking for help, and don't forget to add Quick System Info to help requests!
  • Please follow the Forum Rules

Current releases
--MX-19.4 release info here
--Migration information to MX-19.4 here
--antiX-19.4 (Grup Yorum) release info here

Important information
-- Spectre and Meltdown vulnerabilities

News
-- MX Linux on social media: here
-- New Forum Features, Marking Solved and Referencing a User: here

Boot: remove Nvidia logo and disable Plymouth

Message
Author
User avatar
JayM
Qualified MX Guide
Posts: 9850
Joined: Tue Jan 08, 2019 4:47 am

Re: Boot: remove Nvidia logo and disable Plymouth

#11 Post by JayM »

Huckleberry wrote: Sat Oct 26, 2019 8:06 am
palimmo wrote: Sat Oct 26, 2019 7:28 am No way to get a functioning plymouth with nvidia drivers?
But, have you tried another theme as suggested by Chris? Also agree with the Ribbon theme.
In fact I removed plymouth on both laptops, but before that, the Nvidia one was working flawlessly with splash..
Or disabled the boot theme and/or splash screen altogether as also suggested by Chris??
Please read the Forum Rules, How To Ask For Help, How to Break Your System and Don't Break Debian. Always include your full Quick System Info (QSI) with each and every new help request.

caprea
Posts: 225
Joined: Sat Aug 23, 2014 7:01 am

Re: Boot: remove Nvidia logo and disable Plymouth

#12 Post by caprea »

Code: Select all

Graphics:  Device-1: NVIDIA G98M [GeForce G 105M] vendor: Acer Incorporated ALI driver: nvidia 
           v: 340.107 bus ID: 01:00.0 
           Display: x11 server: X.Org 1.20.4 driver: nvidia resolution: 1366x768~60Hz 
           OpenGL: renderer: N/A v: N/A direct render: N/A 
@palimmo, it looks as if the nvidia-driver isn't working properly.
I normally use the same legacy-driver with another card(GeForce 8400M), but since buster I stick with nouveau.
It's not clear to me what the problem is, the driver installs without errors, it builds fine against the kernel, but

Code: Select all

glxgears
from terminal shows errors.

User avatar
JayM
Qualified MX Guide
Posts: 9850
Joined: Tue Jan 08, 2019 4:47 am

Re: Boot: remove Nvidia logo and disable Plymouth

#13 Post by JayM »

Code: Select all

OpenGL: renderer: N/A v: N/A direct render: N/A 
is the problem, vs.

Code: Select all

OpenGL: renderer: NVA5 v: 3.3 Mesa 18.3.6
when using nouveau. It's an issue with the legacy Nvidia driver 340 in MX-19 (or in Buster if that driver came from upstream, which appears to be the case.) Everything installs OK and all the log files look fine but OpenGL doesn't work. I reported it in the RC1 feedback thread but no one was able to find what was causing it at the time.
Please read the Forum Rules, How To Ask For Help, How to Break Your System and Don't Break Debian. Always include your full Quick System Info (QSI) with each and every new help request.

User avatar
palimmo
Posts: 36
Joined: Tue Jan 03, 2017 2:43 pm

Re: Boot: remove Nvidia logo and disable Plymouth

#14 Post by palimmo »

I've tried some of them.
No chance apparently.
:frown:
Dai diamanti non nasce niente, dal letame nascono i fior. https://aquilone.wordpress.com/

User avatar
JayM
Qualified MX Guide
Posts: 9850
Joined: Tue Jan 08, 2019 4:47 am

Re: Boot: remove Nvidia logo and disable Plymouth

#15 Post by JayM »

Perhaps someone who knows how to purge the nvidia driver and reinstall nouveau will be along soon and can tell you how.

It would be nice if this ability could be added to the nvidia installer script, /usr/local/bin/ddm-mx. Then if someone installs ndivia drivers and gets the black screen of death after rebooting they could boot from their live USB, delete /etc/X11/xorg.conf, reboot in vesa graphics mode, run the script, and go back to using nouveau.
Please read the Forum Rules, How To Ask For Help, How to Break Your System and Don't Break Debian. Always include your full Quick System Info (QSI) with each and every new help request.

caprea
Posts: 225
Joined: Sat Aug 23, 2014 7:01 am

Re: Boot: remove Nvidia logo and disable Plymouth

#16 Post by caprea »

OK, I got the legacy-driver running properly on MX19 and antiX19 buster

Code: Select all

System:
  Host: antix1 Kernel: 4.9.193-antix.1-amd64-smp x86_64 bits: 64 
  compiler: gcc v: 8.3.0 Desktop: IceWM 1.5.5+git20190610 dm: SLiM 1.3.6 
  Distro: antiX-19_x64-full Marielle Franco 16 October 2019 
  base: Debian GNU/Linux 10 (buster) 
  Graphics:
  Device-1: NVIDIA G86M [GeForce 8400M GS] vendor: Wistron driver: nvidia 
  v: 340.107 bus ID: 01:00.0 chip ID: 10de:0427 
  Display: x11 server: X.Org 1.20.4 driver: nvidia resolution: 1280x800~60Hz 
  OpenGL: renderer: GeForce 8400M GS/PCIe/SSE2 v: 3.3.0 NVIDIA 340.107 
  direct render: Yes 
It was loading the wrong glx-module, from /var/log/Xorg.log

Code: Select all

 LoadModule: "glx"
 Loading /usr/lib/xorg/modules/extensions/libglx.so
 
 (EE) NVIDIA(0): Failed to initialize the GLX module; please check in your X 
 log file that the GLX module has been loaded in your X
/usr/lib/xorg/modules/extensions/libglx.so instead the one from nvidia

What I did is renamed the libglx.so

Code: Select all

sudo mv /usr/lib/xorg/modules/extensions/libglx.so /usr/lib/xorg/modules/extensions/libglx.so.bac
and symlinked the one from nvidia to libglx.so

Code: Select all

sudo ln -s /usr/lib/nvidia/legacy-340xx/libglx.so.340.107 /usr/lib/xorg/modules/extensions/libglx.so
Looks good to me now, no errors in Xorg.log

Code: Select all

10.911] (II) LoadModule: "glx"
[    10.922] (II) Loading /usr/lib/xorg/modules/linux/libglx.so
[    11.081] (II) Module glx: vendor="NVIDIA Corporation"
glxgears runs fine.

Is this a problem of the nvidia-driver, or buster or who ?

User avatar
Stevo
Developer
Posts: 23422
Joined: Fri Dec 15, 2006 8:07 pm

Re: Boot: remove Nvidia logo and disable Plymouth

#17 Post by Stevo »

Seems to be a Debian bug, but am happy to see you've discovered the fix!

It was also asked if ddm-mx had an option to remove the nvidia driver, and it does:

Code: Select all

sudo ddm-mx -p nvidia
but I have to say IDK if that also works with the legacy drivers.

User avatar
JayM
Qualified MX Guide
Posts: 9850
Joined: Tue Jan 08, 2019 4:47 am

Re: Boot: remove Nvidia logo and disable Plymouth

#18 Post by JayM »

caprea wrote: Sun Oct 27, 2019 6:43 pm OK, I got the legacy-driver running properly on MX19 and antiX19 buster

Code: Select all

System:
  Host: antix1 Kernel: 4.9.193-antix.1-amd64-smp x86_64 bits: 64 
  compiler: gcc v: 8.3.0 Desktop: IceWM 1.5.5+git20190610 dm: SLiM 1.3.6 
  Distro: antiX-19_x64-full Marielle Franco 16 October 2019 
  base: Debian GNU/Linux 10 (buster) 
  Graphics:
  Device-1: NVIDIA G86M [GeForce 8400M GS] vendor: Wistron driver: nvidia 
  v: 340.107 bus ID: 01:00.0 chip ID: 10de:0427 
  Display: x11 server: X.Org 1.20.4 driver: nvidia resolution: 1280x800~60Hz 
  OpenGL: renderer: GeForce 8400M GS/PCIe/SSE2 v: 3.3.0 NVIDIA 340.107 
  direct render: Yes 
It was loading the wrong glx-module, from /var/log/Xorg.log

Code: Select all

 LoadModule: "glx"
 Loading /usr/lib/xorg/modules/extensions/libglx.so
 
 (EE) NVIDIA(0): Failed to initialize the GLX module; please check in your X 
 log file that the GLX module has been loaded in your X
/usr/lib/xorg/modules/extensions/libglx.so instead the one from nvidia

What I did is renamed the libglx.so

Code: Select all

sudo mv /usr/lib/xorg/modules/extensions/libglx.so /usr/lib/xorg/modules/extensions/libglx.so.bac
and symlinked the one from nvidia to libglx.so

Code: Select all

sudo ln -s /usr/lib/nvidia/legacy-340xx/libglx.so.340.107 /usr/lib/xorg/modules/extensions/libglx.so
Looks good to me now, no errors in Xorg.log

Code: Select all

10.911] (II) LoadModule: "glx"
[    10.922] (II) Loading /usr/lib/xorg/modules/linux/libglx.so
[    11.081] (II) Module glx: vendor="NVIDIA Corporation"
glxgears runs fine.

Is this a problem of the nvidia-driver, or buster or who ?
Very, VERY good work! I was having the same issue with the 340 driver on my system and your solution fixed it for me!

Code: Select all

$ inxi -G
Graphics:  Device-1: NVIDIA GT216M [GeForce GT 230M] driver: nvidia v: 340.107 
           Display: x11 server: X.Org 1.20.4 driver: nvidia resolution: 1366x768~60Hz 
           OpenGL: renderer: GeForce GT 230M/PCIe/SSE2 v: 3.3.0 NVIDIA 340.107 
Please read the Forum Rules, How To Ask For Help, How to Break Your System and Don't Break Debian. Always include your full Quick System Info (QSI) with each and every new help request.

User avatar
JayM
Qualified MX Guide
Posts: 9850
Joined: Tue Jan 08, 2019 4:47 am

Re: Boot: remove Nvidia logo and disable Plymouth

#19 Post by JayM »

By the way, the three grey rectangles during boot are also from the Nvidia 340 driver and somehow override MX's boot theme and splash screen. i played with those settings in MX Boot Options but nothing I tried got rid of the grey boxes or returned the nice-looking encryption passphrase entry field (it's now just a text prompt.) So it seems that the only way to get rid of the boxes and splash screen is to purge your Nvidia driver as per Stevo's instructions and go back to using Nouveau, or else get a newer Nvidia video card (or a computer with a newer onboard Nvidia GPU) that's supported by newer drivers.
Please read the Forum Rules, How To Ask For Help, How to Break Your System and Don't Break Debian. Always include your full Quick System Info (QSI) with each and every new help request.

Post Reply

Return to “Software / Configuration”