Page 1 of 2

New Laptop back to win 10

Posted: Tue Dec 04, 2018 5:31 pm
by j2mcgreg
My old laptop died and I replaced it with an Acer Aspire 3 A315 -41-R2W5. The new machine has an InsydeH2O Setup Utility as it's BIOS which I'm finding a bit daunting. I've gotten as far as enabling a supervisor's password in order to unlock the advance settings and disable Secure Boot, but it still won't boot the MX install on the USB drive. I'm hoping that folks here with more experience can tell me what are the other steps I obviously have missed.

Thanks

Edit: it was working fine and then last night a bunch of updates were applied. This morning when I started it up wifi did not work at all. I tried everything I could think of including using the Win 10 driver with ndiswrapper but it's a no go. I have reinstalled Win 10 for now and hopefully Acer will push out a bios update in the future that will allow MX to be installed at a later date.

Re: New Laptop

Posted: Tue Dec 04, 2018 5:41 pm
by Stevo
If this is the one with an AMD Ryzen 3 APU, it might require MX 18 with its newer hardware support.

Re: New Laptop

Posted: Tue Dec 04, 2018 6:14 pm
by j2mcgreg
Yeah, that's my intention.

Re: New Laptop

Posted: Tue Dec 04, 2018 7:27 pm
by Stevo
So, you plan to try the MX 18 beta with it, or is that the one that's failing to boot?

Re: New Laptop

Posted: Tue Dec 04, 2018 8:56 pm
by j2mcgreg
Stevo wrote:
Tue Dec 04, 2018 7:27 pm
So, you plan to try the MX 18 beta with it, or is that the one that's failing to boot?
Yes, the MX 18 beta is failing to boot, but I currently think that the solution to the problem lies in figuring out how to turn off fast boot as well.

Re: New Laptop

Posted: Tue Dec 04, 2018 11:31 pm
by Stevo
You might want to try Rufus on Windows if you can; I remember that working better to make a bootable USB for my Acer. After installing, I also had to go into the UEFI setup and manually add the new .efi file to a list to make it appear as the boot option instead of the Windows one.

Re: New Laptop

Posted: Wed Dec 05, 2018 11:05 am
by j2mcgreg
Following Steve0's advice, I used Rufus to create the usb boot drive and the good news is that it now boots with no problem. The bad news is that the boot quickly errors out with this message:

Amd-VI: ioapic not in IVRS Table

and then it continues on to generate a whole slew of other errors. I'm going to put this on hold until MX 18 Final is released.

Re: New Laptop

Posted: Sat Jan 12, 2019 5:37 pm
by j2mcgreg
Update:
MX 18 is installed --> it required an update to the bios and the "pci=noacpi" boot parameter. However there is a problem in that wifi does not work (but does work using the live usb drive).

The desktop shows that updates are available,so it would seem that wifi is working on some level, but neither the root user or myself can access it. Is this a permissions problem?

The wireless card in the machine is a Qualcom Atheros QCA9377 802.11 AC

The loaded drivers as shown by Network Assistant are ( on the laptop and the live usb) :

wl
Ath 10K_pci
Ath 10K_Core
Ath
R8169
libphy

Anybody have any ideas on how I should proceed?

Re: New Laptop Solved

Posted: Sat Jan 12, 2019 6:36 pm
by j2mcgreg
I reinstalled, but this time I first set up wifi on the live desktop and then selected "carry over changes made on the live desktop" during the last stages of the install -- and it worked!

Later tonight I'll create a new post in Tips and Tricks to show all the steps needed to get MX18 installed on this beast.

Re: New Laptop Solved

Posted: Sat Jan 12, 2019 6:55 pm
by KoO
Have you tried to turn acpi back on now mx18 is installed and or will it boot to MX if it is turned back on.
Wifi card is a pci device..

https://askubuntu.com/questions/991414/ ... -ubuntu-16

noapic= [SMP,APIC] Tells the kernel not to make use of any APIC that may be present on the system.

acpi= [HW,ACPI] Advanced Configuration and Power Interface
force Force ACPI on, even if blacklisted platform
off Disable ACPI
ht Limit ACPI to boot-time LAPIC enumeration for HT,
disabling the run-time AML interpreter.

Common Kernel Options

This list is not comprehensive but it contains some common boot options which may be added to the end of the boot command.

Option


Impact

vga=xxx


Set your framebuffer resolution to VESA mode xxx. Check here for a list of possible modes.

acpi=off OR noacpi


This parameter disables the whole ACPI system. This may prove very useful, for example, if your computer does not support ACPI or if you think the ACPI implementation might cause some problems (for instance random reboots or system lockups).

acpi=force


Activates the ACPI system even if your computer BIOS date is older than 2000. This parameter overrides acpi=off and can also be used with current hardware if the ACPI support is not activated despite apm=off.

pci=noacpi OR acpi=noirq


These parameters disable the PCI IRQ routing

pci=acpi


This parameter activates the PCI IRQ routing

acpi_irq_balance


ACPI is allowed to use PIC interrupts to minimize the common use of IRQs.

acpi_irq_nobalance


ACPI is not allowed to use PIC interrupts.

acpi=oldboot


Deactivates the ACPI system almost completely; only the components required for the boot process will be used.

acpi=ht


Deactivates the ACPI system almost completely; only the components required for hyper threading will be used.

noapic


Disable the "Advanced Programmable Interrupt Controller (APIC)".

nolapic


Disable the "local APIC".

apm=off OR noapm


Disable the Advanced Power Management.

irqpoll


Changes the way the kernel handles interrupt calls (set it to polling). Can be useful in case of hardware interrupt issues.

acpi.power_nocheck=1 OR acpi_osi=Linux


Disable the check of power state. Option two modifies the list of supported OS interface strings (changes the OS compatibility reported to the BIOS). Necessary on some broken BIOSes to make temperature/fan control work.