Welcome!

The kernel problem with recent updates has been solved. Find the solution here

Important information
-- Required MX 15/16 Repository Changes
-- Information on torrent hosting changes
-- Information on MX15/16 GPG Keys
-- Spectre and Meltdown vulnerabilities

News
-- Introducing our new Website
-- MX Linux on social media: here

Current releases
-- MX-18.3 Point Release release info here
-- Migration Information to MX-18 here
-- antiX-17.4.1 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

[Work Around] Sound Blaster USB X-Fi Sound Issue Crackling

Post Reply
User avatar
freemx
Forum Novice
Forum  Novice
Posts: 2
Joined: Wed Jun 12, 2019 6:52 am

[Work Around] Sound Blaster USB X-Fi Sound Issue Crackling

#1

Post by freemx » Wed Jun 12, 2019 1:39 pm

Hi,
I just installed successfully and without any difficulty MX linux Debian 4.19.37-2~mx17+1 (2019-05-15) x64
And having the notorious SB X-Fi Surround 5.1 USB sound card lurking around i wanted to try if it works out of the box..
Going Straight to BIT.tube for a test and.. there goes the annoying crackling sound every time a video was switched
So I look around the pulse default config file

Code: Select all

sudo nano /etc/pulse/default.pa
It seemed obvious that the issue had to do with the option that says: Automatically suspend sinks/sources that become idle for too long so i commented out like this:

Code: Select all

Automatically suspend sinks/sources that become idle for too long
#load-module module-suspend-on-idle
Image

Save and Exit nano text editor

Reload Pulseaudio deamon or Restart Mx OS

This Temporary Fix resolved the issue for me although I haven't test it thoroughly with other Sound apps and my native pc sound card. Give me your feedback if you find a better fix. Peace.

Post Reply

Return to “Hardware /Configuration”