Welcome!

The kernel problem with recent updates has been solved. Find the solution here

Important information
-- Required MX 15/16 Repository Changes
-- Information on torrent hosting changes
-- Information on MX15/16 GPG Keys
-- Spectre and Meltdown vulnerabilities

News
-- Introducing our new Website
-- MX Linux on social media: here

Current releases
-- MX-18.3 Point Release release info here
-- Migration Information to MX-18 here
-- antiX-17.4.1 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

MX 18.3 time display problems.

Help for Current Versions of MX
Post Reply
User avatar
p1atypusx
Forum Novice
Forum  Novice
Posts: 2
Joined: Tue Aug 13, 2019 8:04 pm

MX 18.3 time display problems.

#1

Post by p1atypusx » Tue Aug 13, 2019 9:08 pm

Running a MX 18.3 and it shows the time in Conky and Orange incorrectly by 7 hours.

I have the BIOS time correct to my time and the hwclock is set correctly to the timezone 'US/Arizona'.
When I confirm timezone and time through a terminal is shows

$ timedatectl
Local time: Tue 2019-08-13 10:54:13 MST
Universal time: Tue 2019-08-13 17:54:13 UTC <<<<----- This is correct time.
RTC time: Tue 2019-08-13 17:54:13
Time zone: US/Arizona (MST, -0700)
Network time on: yes
NTP synchronized: yes
RTC in local TZ: no


When I run MX Time settings it gives me the following:

hwclock from util-linux 2.29.2
Using the /dev interface to the clock.
Last drift adjustment done at 1565718143 seconds after 1969
Last calibration done at 1565718143 seconds after 1969
Hardware clock is on UTC time
Assuming hardware clock is kept in UTC time.
Waiting for clock tick...
...got clock tick
Time read from Hardware Clock: 2019/08/13 17:55:18
Hw clock time : 2019/08/13 17:55:18 = 1565718918 seconds since 1969
Time since last adjustment is 775 seconds
Calculated Hardware Clock drift is 0.000000 seconds
2019-08-13 10:55:17.561686-0700


It seems to think my computer is GMT and not -0700 so when it adds in the -0700 it puts me 7 hours behind the actual current time.


Any ideas on how to fix this. I've tried changing the settings through MX time setting GUI but it doesn't do anything. Whether its showing UTC or local time it still shows 7 hours earlier.


Any suggestions appreciated.

User avatar
p1atypusx
Forum Novice
Forum  Novice
Posts: 2
Joined: Tue Aug 13, 2019 8:04 pm

Re: MX 18.3 time display problems.

#2

Post by p1atypusx » Tue Aug 13, 2019 9:23 pm

Never mind. I don't know what I did, but it is showing correctly now.

Post Reply

Return to “MX Help”