Welcome!

The kernel problem with recent updates has been solved. Find the solution here

Important information
-- Required MX 15/16 Repository Changes
-- Information on torrent hosting changes
-- Information on MX15/16 GPG Keys
-- Spectre and Meltdown vulnerabilities

News
-- Introducing our new Website
-- MX Linux on social media: here

Current releases
-- MX-18.3 Point Release release info here
-- Migration Information to MX-18 here
-- antiX-17.4.1 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

Having trouble with wifi on HP 500-054

Help for Current Versions of MX
Post Reply
User avatar
eyeconda
Forum Novice
Forum  Novice
Posts: 3
Joined: Sun Apr 14, 2019 10:18 pm

Having trouble with wifi on HP 500-054

#1

Post by eyeconda » Sun Apr 14, 2019 10:25 pm

here's some of the basic stuff i could find

eyeconda@mx:/etc/modprobe.d
$ inxi -N
Network:
Device-1: Qualcomm Atheros AR8161 Gigabit Ethernet driver: alx
Device-2: Ralink RT5390R 802.11bgn PCIe Wireless Network Adapter
driver: rt2800pci

eyeconda@mx:/etc/modprobe.d
$ iwconfig
lo no wireless extensions.

wlan0 IEEE 802.11 ESSID:off/any
Mode:Managed Access Point: Not-Associated Tx-Power=off
Retry short long limit:2 RTS thr:off Fragment thr:off
Power Management:off

User avatar
eyeconda
Forum Novice
Forum  Novice
Posts: 3
Joined: Sun Apr 14, 2019 10:18 pm

Re: Having trouble with wifi on HP 500-054

#2

Post by eyeconda » Sun Apr 14, 2019 10:42 pm

I'm running 64 bit mx 18.2

User avatar
JayM
Qualified MX Guide
Posts: 2137
Joined: Tue Jan 08, 2019 4:47 am

Re: Having trouble with wifi on HP 500-054

#3

Post by JayM » Sun Apr 14, 2019 11:40 pm

What kind of trouble are you having? You don't see any SSIDs? You see them but can't connect?
Please read How To Ask For Help and How to Break Your System.
MX User Manual: hold down ALT and press F1. Further information may be found in the MX Wiki.

User avatar
eyeconda
Forum Novice
Forum  Novice
Posts: 3
Joined: Sun Apr 14, 2019 10:18 pm

Re: Having trouble with wifi on HP 500-054

#4

Post by eyeconda » Sun Apr 14, 2019 11:56 pm

JayM wrote:
Sun Apr 14, 2019 11:40 pm
What kind of trouble are you having? You don't see any SSIDs? You see them but can't connect?
can't connect or see my router or as you say ssid

User avatar
JayM
Qualified MX Guide
Posts: 2137
Joined: Tue Jan 08, 2019 4:47 am

Re: Having trouble with wifi on HP 500-054

#5

Post by JayM » Mon Apr 15, 2019 11:23 pm

I have a desktop with a cabled Ethernet connection so I can't be of much help troubleshooting wifi issues, but hopefully one of the gurus who are smarter than I will reply soon and help.

Meanwhile could you run

Code: Select all

ifconfig wlan0 up
and

Code: Select all

iwlist wlan0 scan
in a terminal and post the results (inside of [ code ] [ /code ] tags, without the spaces)? Also try running both commands with sudo in front, like

Code: Select all

sudo iwlist wlan0 scan
and see if that makes a difference.

I'm suspecting it's a driver/kernel module issue but troubleshooting and fixing that is beyond me.

Also, full system information might be good for remote troubleshooters to know. Can you run MX Tools/Quick System Info and paste the results in a reply?

Another bit of information that will be helpful is the result of running

Code: Select all

lspci
in a terminal, pasted inside of code tags.

Thanks.
Please read How To Ask For Help and How to Break Your System.
MX User Manual: hold down ALT and press F1. Further information may be found in the MX Wiki.

Post Reply

Return to “MX Help”