Welcome!

The kernel problem with recent updates has been solved. Find the solution here

Important information
-- Required MX 15/16 Repository Changes
-- Information on torrent hosting changes
-- Information on MX15/16 GPG Keys
-- Spectre and Meltdown vulnerabilities

News
-- Introducing our new Website
-- MX Linux on social media: here

Current releases
-- MX-18.3 Point Release release info here
-- Migration Information to MX-18 here
-- antiX-17.4.1 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

[SOLVED] Kid3 application removed in an update

Help for Current Versions of MX
Post Reply
alexjack
Forum Novice
Forum  Novice
Posts: 93
Joined: Wed May 02, 2018 3:11 pm

[SOLVED] Kid3 application removed in an update

#1

Post by alexjack » Thu Jan 10, 2019 6:31 pm

Hi all. I just applied some updates and saw in the list that a file for Kid3 (music metadata editor) was going to be removed. I though it might be an old file, something not used, so I let it apply. But it did actually remove the program. Reinstalled easily enough, but what gives?
Last edited by alexjack on Sun Mar 03, 2019 7:51 pm, edited 2 times in total.

User avatar
Eadwine Rose
Forum Veteran
Forum Veteran
Posts: 8352
Joined: Wed Jul 12, 2006 2:10 am

Re: Kid3 application removed in an update

#2

Post by Eadwine Rose » Fri Jan 11, 2019 3:47 am

Glad you were able to reinstall. Remember this IS still linux and not windows. If something happens that you think is not right, come here and ask.
MX-18.3_x64 May 26 2019 * 4.19.0-5-amd64 ext4 Xfce 4.12.3 * 8-core AMD Ryzen 7 2700
Asus TUF B450-Plus Gaming UEFI * Asus GTX 1050 Ti Nvidia 390.116 * 2x16Gb DDR4 2666 Kingston HyperX Predator
Samsung 860EVO * Samsung S24D330 & P2250 * HP Envy5030

User avatar
asqwerth
Forum Veteran
Forum Veteran
Posts: 4626
Joined: Sun May 27, 2007 5:37 am

Re: Kid3 application removed in an update

#3

Post by asqwerth » Fri Jan 11, 2019 3:58 am

alexjack wrote:
Thu Jan 10, 2019 6:31 pm
Hi all. I just applied some updates and saw in the list that a file for Kid3 (music metadata editor) was going to be removed. I though it might be an old file, something not used, so I let it apply. But it did actually remove the program. Reinstalled easily enough, but what gives?
Do you have 3rd party repos, PPA, MX Test Repo or Debian Backports enabled by default?

It might be useful to check the results of:

inxi -r

in terminal
Desktop: Intel i5-4460, 16GB RAM, Intel integrated graphics
Clevo N130WU-based Ultrabook: Intel i7-8550U (Kaby Lake R), 16GB RAM, Intel integrated graphics (UEFI)
ASUS X42D laptop: AMD Phenom II, 6GB RAM, Mobility Radeon HD 5400

User avatar
dphn
Forum Regular
Forum Regular
Posts: 165
Joined: Sun Nov 25, 2018 7:26 am

Re: Kid3 application removed in an update

#4

Post by dphn » Fri Jan 11, 2019 2:39 pm

Have kid3-qt installed and today I've done a dist-upgrade. All is fine. Can't confirm this.
for those with an eye for the finer details...

User avatar
baldyeti
Forum Regular
Forum Regular
Posts: 198
Joined: Sat Dec 05, 2009 4:37 pm

Re: Kid3 application removed in an update

#5

Post by baldyeti » Fri Jan 11, 2019 2:47 pm

dphn wrote:
Fri Jan 11, 2019 2:39 pm
Have kid3-qt installed and today I've done a dist-upgrade. All is fine. Can't confirm this.
Same here, but there are two versions: kid3 (with kde integration) and kid3-qt whose description says
"This package does not use KDE libraries, if you use KDE you should use kid3."
Shouldn't have been removed anyway, of course.

alexjack
Forum Novice
Forum  Novice
Posts: 93
Joined: Wed May 02, 2018 3:11 pm

Re: Kid3 application removed in an update

#6

Post by alexjack » Fri Jan 11, 2019 4:14 pm

Backports and testing, not enabled by default (I think that means I would have had to go into the files in /etc/apt/sources.list.d/ and change them, which I haven't). No 3rd party repos or PPAs. The Kid3 I am using is the KDE version.

System info:

Code: Select all

System:    Host: tip Kernel: 4.19.0-1-amd64 x86_64 bits: 64 compiler: gcc v: 6.3.0 
           Desktop: Xfce 4.12.3 Distro: MX-18_x64 Continuum December 15  2017 
           base: Debian GNU/Linux 9 (stretch) 
Machine:   Type: Desktop System: Dell product: Inspiron 3847 v: N/A serial: <filter> 
           Mobo: Dell model: 088DT1 v: A01 serial: <filter> UEFI: Dell v: A04 date: 04/03/2014 
CPU:       Topology: Dual Core model: Intel Pentium G3240 bits: 64 type: MCP arch: Haswell 
           rev: 3 L2 cache: 3072 KiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 12371 
           Speed: 1086 MHz min/max: 800/3100 MHz Core speeds (MHz): 1: 1086 2: 1260 
Graphics:  Device-1: NVIDIA GM107 [GeForce GTX 750 Ti] vendor: ASUSTeK driver: nvidia v: 390.87 
           bus ID: 01:00.0 
           Display: x11 server: X.Org 1.19.2 driver: nvidia resolution: 1920x1080~60Hz 
           OpenGL: renderer: GeForce GTX 750 Ti/PCIe/SSE2 v: 4.6.0 NVIDIA 390.87 
           direct render: Yes 
Audio:     Device-1: Intel 8 Series/C220 Series High Definition Audio vendor: Dell 
           driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
           Device-2: NVIDIA vendor: ASUSTeK driver: snd_hda_intel v: kernel bus ID: 01:00.1 
           Sound Server: ALSA v: k4.19.0-1-amd64 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Dell 
           driver: r8169 v: kernel port: d000 bus ID: 03:00.0 
           IF: eth0 state: down mac: <filter> 
           Device-2: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter vendor: Dell 
           driver: ath9k v: kernel port: d000 bus ID: 04:00.0 
           IF: wlan0 state: up mac: <filter> 
           Device-3: Atheros type: USB driver: btusb bus ID: 2-10:9 
Drives:    Local Storage: total: 465.76 GiB used: 298.53 GiB (64.1%) 
           ID-1: /dev/sda vendor: Samsung model: SSD 850 EVO 500GB size: 465.76 GiB 
Partition: ID-1: / size: 455.21 GiB used: 298.53 GiB (65.6%) fs: ext4 dev: /dev/sda2 
           ID-2: swap-1 size: 2.00 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda3 
Sensors:   System Temperatures: cpu: 30.0 C mobo: N/A gpu: nvidia temp: 28 C 
           Fan Speeds (RPM): cpu: 534 mobo: 832 gpu: nvidia fan: 24% 
Repos:     Active apt repos in: /etc/apt/sources.list.d/antix.list 
           1: deb http://nl.mxrepo.com/antix/stretch stretch main
           Active apt repos in: /etc/apt/sources.list.d/debian-stable-updates.list 
           1: deb http://ftp.uk.debian.org/debian/ stretch-updates main contrib non-free
           Active apt repos in: /etc/apt/sources.list.d/debian.list 
           1: deb http://ftp.us.debian.org/debian/ stretch main contrib non-free
           2: deb http://security.debian.org/ stretch/updates main contrib non-free
           3: deb-src http://ftp.us.debian.org/debian/ stretch main contrib non-free
           Active apt repos in: /etc/apt/sources.list.d/mx.list 
           1: deb http://nl.mxrepo.com/mx/repo/ stretch main non-free
           No active apt repos in: /etc/apt/sources.list.d/various.list 
Info:      Processes: 199 Uptime: 12h 35m Memory: 5.78 GiB used: 1.30 GiB (22.4%) Init: SysVinit 
           runlevel: 5 Compilers: gcc: 6.3.0 Shell: bash v: 4.4.12 inxi: 3.0.29 

User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 19355
Joined: Fri Dec 15, 2006 8:07 pm

Re: Kid3 application removed in an update

#7

Post by Stevo » Fri Jan 11, 2019 4:18 pm

Maybe it was that VLC 3.0.5 phonon package KDE problem that's since been fixed.

User avatar
baldyeti
Forum Regular
Forum Regular
Posts: 198
Joined: Sat Dec 05, 2009 4:37 pm

Re: Kid3 application removed in an update

#8

Post by baldyeti » Fri Jan 11, 2019 4:23 pm

alexjack wrote:
Fri Jan 11, 2019 4:14 pm
The Kid3 I am using is the KDE version.
No idea how to check, but perhaps this could be related to the vlc 3.0.5 upgrade, as kid3 might be using the phonon-backend-vlc to play audio ?
I had a suggestion to autoremove vlc-bin (and others which i do not remember), then had to re-install it, which i noticed pulled the phonon-backend...

User avatar
timkb4cq
Forum Veteran
Forum Veteran
Posts: 4986
Joined: Wed Jul 12, 2006 4:05 pm

Re: Kid3 application removed in an update

#9

Post by timkb4cq » Fri Jan 11, 2019 6:10 pm

It appears that was it.
phonon4qt5 depends on phonon4qt5-backend-vlc
libkf5notifications5 depends on phonon4qt5
libkf5codecs5 depends on libkf5notifications5
and finally
kid3 depends on libkf5codecs5.

So phonon-backend-vlc slipping through the cracks filtered down to kid3.
By the time you re-installed kid3 the repo had been updated so it installed OK.
MSI 970A-G43 MB, AMD FX-6300 (six core), 16GB RAM, GeForce 730, Samsung 850 EVO 250GB SSD, Seagate Barracuda XT 3TB

alexjack
Forum Novice
Forum  Novice
Posts: 93
Joined: Wed May 02, 2018 3:11 pm

Re: Kid3 application removed in an update

#10

Post by alexjack » Sat Jan 12, 2019 5:40 pm

Wow, thanks for checking into this.

Post Reply

Return to “MX Help”