Welcome!
Forum users

Current releases
--MX-21 release info here
--Migration information to MX-21 here
--antiX-21 (Grup Yorum) release info here

Important information
--If in starting your system it boots to an unwanted Desktop, right click desktop, then select leave and logout. At the
login screen there is a session chooser at the top of the screen.

News
-- MX Linux on social media: here
-- New Forum Features, Marking Solved and Referencing a User: here

MX Package Installer - two options of the same package ?  [Solved]

Message
Author
User avatar
~FLOW~
Posts: 203
Joined: Thu May 19, 2022 12:43 pm

MX Package Installer - two options of the same package ?

#1 Post by ~FLOW~ »

Hello my excelent friends,
From time to time I notice this thing in MXPI, two identical options of the same package, is this normal ?
Is it a bug, or I don't get it ?
Screenshot_20230111_114803.png
You do not have the required permissions to view the files attached to this post.
MX-21.3 / KDE Plasma 5.20.5
Kernel: 6.1.0-4mx-amd64

Be patient !!
What seams easy for you now, for a newbie might be a monumental helping hand.
An efficient pack will move as fast as the slowest member.

User avatar
Mauser
Posts: 2045
Joined: Mon Jun 27, 2016 7:32 pm

Re: MX Package Installer - two options of the same package ?

#2 Post by Mauser »

I just checked on my computer and see that also. Keep in mind that you are in the testing repo which may or may not cause issues when you install anything from it. Perhaps that's why it does that.
I am command line illiterate. :confused: I copy & paste to the terminal. Liars, Wiseguys, Trolls, and those without manners will be added to my ignore list. :mad:

User avatar
dolphin_oracle
Developer
Posts: 23297
Joined: Sun Dec 16, 2007 1:17 pm

Re: MX Package Installer - two options of the same package ?

#3 Post by dolphin_oracle »

Mauser wrote: Wed Jan 11, 2023 12:18 pm I just checked on my computer and see that also. Keep in mind that you are in the testing repo which may or may not cause issues when you install anything from it. Perhaps that's why it does that.
probably just some sort of text parsing issue
http://www.youtube.com/runwiththedolphin
lenovo ThinkPad X1 Extreme Gen 4 - MX-21
FYI: mx "test" repo is not the same thing as debian testing repo.

User avatar
timkb4cq
Developer
Posts: 6647
Joined: Wed Jul 12, 2006 4:05 pm

Re: MX Package Installer - two options of the same package ?

#4 Post by timkb4cq »

Something didn't update correctly since the version should be winehq-staging_8.0-0rc2-0mx21+1 - not rc1.
I would like to know which mirror you have selected for the MX testrepo
HP Pavillion TP01, AMD Ryzen 3 5300G (quad core), Crucial 500GB SSD, Toshiba 6GB 7200rpm

User avatar
~FLOW~
Posts: 203
Joined: Thu May 19, 2022 12:43 pm

Re: MX Package Installer - two options of the same package ?

#5 Post by ~FLOW~ »

timkb4cq wrote: Wed Jan 11, 2023 12:28 pm Something didn't update correctly since the version should be winehq-staging_8.0-0rc2-0mx21+1 - not rc1.
I would like to know which mirror you have selected for the MX testrepo

Code: Select all

System:    Kernel: 5.19.0-2mx-amd64 [5.19.11-1~mx21+1] x86_64 bits: 64 compiler: gcc v: 10.2.1 
           parameters: BOOT_IMAGE=/boot/vmlinuz-5.19.0-2mx-amd64 
           root=UUID=<filter> ro 
           Desktop: KDE Plasma 5.20.5 wm: kwin_x11 vt: 7 dm: SDDM 
           Distro: MX-21.2.1_KDE_x64 Wildflower April 9  2022 base: Debian GNU/Linux 11 (bullseye) 
Machine:   Type: Portable System: Dell product: Inspiron 3542 v: N/A serial: <filter> Chassis: 
           type: 8 serial: <filter> 
           Mobo: Dell model: 0926J6 v: A16 serial: <filter> UEFI: Dell v: A16 date: 09/02/2020 
Battery:   ID-1: BAT0 charge: 21.3 Wh (100.0%) condition: 21.3/41.4 Wh (51.4%) volts: 16.9 
           min: 14.8 model: SANYO DELL 4WY7C45 type: Li-ion serial: <filter> status: Full 
           Device-1: hidpp_battery_0 model: Logitech Wireless Mouse serial: <filter> 
           charge: 55% (should be ignored) rechargeable: yes status: Discharging 
           Device-2: hidpp_battery_1 model: Logitech K520 serial: <filter> 
           charge: 70% (should be ignored) rechargeable: yes status: Discharging 
CPU:       Info: Dual Core model: Intel Core i5-4210U bits: 64 type: MT MCP arch: Haswell 
           family: 6 model-id: 45 (69) stepping: 1 microcode: 26 cache: L2: 3 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 13569 
           Speed: 1172 MHz min/max: 800/2700 MHz Core speeds (MHz): 1: 1172 2: 1140 3: 1070 
           4: 1397 
           Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
           Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
           Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
           Type: meltdown mitigation: PTI 
           Type: mmio_stale_data status: Unknown: No mitigations 
           Type: retbleed status: Not affected 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW, STIBP: 
           conditional, RSB filling, PBRSB-eIBRS: Not affected 
           Type: srbds mitigation: Microcode 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: Intel Haswell-ULT Integrated Graphics vendor: Dell driver: i915 v: kernel 
           bus-ID: 00:02.0 chip-ID: 8086:0a16 class-ID: 0300 
           Device-2: NVIDIA GF117M [GeForce 610M/710M/810M/820M / GT 620M/625M/630M/720M] 
           vendor: Dell driver: N/A alternate: nouveau bus-ID: 08:00.0 chip-ID: 10de:1140 
           class-ID: 0302 
           Device-3: Suyin Integrated_Webcam_HD type: USB driver: uvcvideo bus-ID: 2-1.5:5 
           chip-ID: 064e:9205 class-ID: 0e02 serial: <filter> 
           Display: x11 server: X.Org 1.20.14 compositor: kwin_x11 driver: loaded: modesetting 
           unloaded: fbdev,vesa display-ID: :0 screens: 1 
           Screen-1: 0 s-res: 1280x720 s-dpi: 96 s-size: 337x190mm (13.3x7.5") 
           s-diag: 387mm (15.2") 
           Monitor-1: HDMI-1 res: 1280x720 dpi: 203 size: 160x90mm (6.3x3.5") diag: 184mm (7.2") 
           OpenGL: renderer: Mesa Intel HD Graphics 4400 (HSW GT2) v: 4.6 Mesa 22.0.5 
           compat-v: 3.1 direct render: Yes 
Audio:     Device-1: Intel Haswell-ULT HD Audio vendor: Dell driver: snd_hda_intel v: kernel 
           bus-ID: 00:03.0 chip-ID: 8086:0a0c class-ID: 0403 
           Device-2: Intel 8 Series HD Audio vendor: Dell driver: snd_hda_intel v: kernel 
           bus-ID: 00:1b.0 chip-ID: 8086:9c20 class-ID: 0403 
           Sound Server-1: ALSA v: k5.19.0-2mx-amd64 running: yes 
           Sound Server-2: PulseAudio v: 15.0 running: yes 
Network:   Device-1: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter vendor: Dell 
           driver: ath9k v: kernel modules: wl port: f040 bus-ID: 06:00.0 chip-ID: 168c:0036 
           class-ID: 0280 
           IF: wlan0 state: down mac: <filter> 
           Device-2: Realtek RTL810xE PCI Express Fast Ethernet vendor: Dell driver: r8169 
           v: kernel port: e000 bus-ID: 07:00.0 chip-ID: 10ec:8136 class-ID: 0200 
           IF: eth0 state: down mac: <filter> 
           Device-3: TP-Link UE300 10/100/1000 LAN (ethernet mode) [Realtek RTL8153] type: USB 
           driver: r8152 bus-ID: 3-1.4:4 chip-ID: 2357:0601 class-ID: 0000 serial: <filter> 
           IF: eth1 state: up speed: 1000 Mbps duplex: full mac: <filter> 
Bluetooth: Device-1: Qualcomm Atheros AR9462 Bluetooth type: USB driver: btusb v: 0.8 
           bus-ID: 2-1.6:8 chip-ID: 0cf3:0036 class-ID: e001 
           Report: hciconfig ID: hci0 rfk-id: 2 state: down bt-service: N/A rfk-block: 
           hardware: no software: no address: <filter> 
           Info: acl-mtu: 1022:8 sco-mtu: 183:5 link-policy: rswitch hold sniff 
           link-mode: slave accept 
Drives:    Local Storage: total: 2.49 TiB used: 1.57 TiB (63.0%) 
           SMART Message: Unable to run smartctl. Root privileges required. 
           ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital model: WD10JPVX-75JC3T0 
           size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s type: HDD 
           rpm: 5400 serial: <filter> rev: 1A01 scheme: MBR 
           ID-2: /dev/sdb maj-min: 8:16 vendor: Kingston model: SHSS37A240G size: 223.57 GiB 
           block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter> 
           rev: 001B scheme: GPT 
           ID-3: /dev/sdc maj-min: 8:32 type: USB vendor: Seagate model: Expansion size: 1.36 TiB 
           block-size: physical: 4096 B logical: 512 B type: N/A serial: <filter> rev: 0502 
           scheme: GPT 
Partition: ID-1: / raw-size: 215.31 GiB size: 210.87 GiB (97.94%) used: 114.99 GiB (54.5%) 
           fs: ext4 dev: /dev/sdb2 maj-min: 8:18 
           ID-2: /boot/efi raw-size: 256 MiB size: 252 MiB (98.46%) used: 277 KiB (0.1%) fs: vfat 
           dev: /dev/sdb1 maj-min: 8:17 
Swap:      Kernel: swappiness: 10 (default 60) cache-pressure: 100 (default) 
           ID-1: swap-1 type: partition size: 8 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/sdb3 
           maj-min: 8:19 
Sensors:   System Temperatures: cpu: 42.0 C mobo: 42.0 C 
           Fan Speeds (RPM): cpu: 0 
Repos:     Packages: note: see --pkg apt: 2687 lib: 1558 flatpak: 0 
           No active apt repos in: /etc/apt/sources.list 
           Active apt repos in: /etc/apt/sources.list.d/brave-browser-release.list 
           1: deb [signed-by=/usr/share/keyrings/brave-browser-archive-keyring.gpg arch=amd64] https://brave-browser-apt-release.s3.brave.com/ stable main
           Active apt repos in: /etc/apt/sources.list.d/debian-stable-updates.list 
           1: deb http://deb.debian.org/debian/ bullseye-updates main contrib non-free
           Active apt repos in: /etc/apt/sources.list.d/debian.list 
           1: deb http://deb.debian.org/debian/ bullseye main contrib non-free
           2: deb http://security.debian.org/debian-security/ bullseye-security main contrib non-free
           3: deb-src http://deb.debian.org/debian/ bullseye main contrib non-free
           4: deb http://deb.debian.org/debian/ bullseye-backports main contrib non-free
           Active apt repos in: /etc/apt/sources.list.d/dropbox.list 
           1: deb [arch=i386,amd64] http://linux.dropbox.com/debian/ sid main
           Active apt repos in: /etc/apt/sources.list.d/mx.list 
           1: deb http://it.mxrepo.com/mx/repo/ bullseye main non-free
           No active apt repos in: /etc/apt/sources.list.d/nala-sources.list 
           Active apt repos in: /etc/apt/sources.list.d/signal-xenial.list 
           1: deb [arch=amd64 signed-by=/usr/share/keyrings/signal-desktop-keyring.gpg] https://updates.signal.org/desktop/apt/ xenial main
           Active apt repos in: /etc/apt/sources.list.d/steam.list 
           1: deb [arch=amd64,i386] https://repo.steampowered.com/steam/ stable steam
           2: deb-src [arch=amd64,i386] https://repo.steampowered.com/steam/ stable steam
           Active apt repos in: /etc/apt/sources.list.d/volian-archive-scar-unstable.list 
           1: deb http://deb.volian.org/volian/ scar main
Info:      Processes: 223 Uptime: 6m wakeups: 11 Memory: 7.68 GiB used: 2.27 GiB (29.5%) 
           Init: SysVinit v: 2.96 runlevel: 5 default: 5 tool: systemctl Compilers: gcc: 10.2.1 
           alt: 10 Client: shell wrapper v: 5.1.4-release inxi: 3.3.06 
Boot Mode: UEFI
MX-21.3 / KDE Plasma 5.20.5
Kernel: 6.1.0-4mx-amd64

Be patient !!
What seams easy for you now, for a newbie might be a monumental helping hand.
An efficient pack will move as fast as the slowest member.

User avatar
fehlix
Developer
Posts: 12161
Joined: Wed Apr 11, 2018 5:09 pm

Re: MX Package Installer - two options of the same package ?

#6 Post by fehlix »

~FLOW~ wrote: Wed Jan 11, 2023 5:49 am Hello my excelent friends,
From time to time I notice this thing in MXPI, two identical options of the same package, is this normal ?
What other packages are those and are those only listed as dublicates within the Test-Repo tabe of MXPI?
To check what testrepo may be involved, please post QSI (Quick System Info), b/c testrepo would be taken from the first mx-repo in the list, if not have been kept manually enabled.
+++EDIT+++ OK. thanks for the QSI
Gigabyte Z77M-D3H, Intel Xeon E3-1240 V2 (Quad core), 32GB RAM,
GeForce GTX 770, Samsung SSD 850 EVO 500GB, Seagate Barracuda 4TB

User avatar
~FLOW~
Posts: 203
Joined: Thu May 19, 2022 12:43 pm

Re: MX Package Installer - two options of the same package ?

#7 Post by ~FLOW~ »

fehlix wrote: Wed Jan 11, 2023 2:23 pm What other packages are those and are those only listed as dublicates within the Test-Repo tabe of MXPI?
At the moment I can't remember, only that it wasn't wine...
MX-21.3 / KDE Plasma 5.20.5
Kernel: 6.1.0-4mx-amd64

Be patient !!
What seams easy for you now, for a newbie might be a monumental helping hand.
An efficient pack will move as fast as the slowest member.

User avatar
timkb4cq
Developer
Posts: 6647
Joined: Wed Jul 12, 2006 4:05 pm

Re: MX Package Installer - two options of the same package ?

#8 Post by timkb4cq »

Thank you. There is a problem with that mirror I had not noticed. Working on it.
HP Pavillion TP01, AMD Ryzen 3 5300G (quad core), Crucial 500GB SSD, Toshiba 6GB 7200rpm

User avatar
fehlix
Developer
Posts: 12161
Joined: Wed Apr 11, 2018 5:09 pm

Re: MX Package Installer - two options of the same package ?

#9 Post by fehlix »

OK, the it.mxrepo.con seems to be not updated since end of december:

Code: Select all

curl -I http://it.mxrepo.com/mx/repo/dists/bullseye/InRelease
HTTP/1.1 200 OK
Last-Modified: Fri, 30 Dec 2022 00:53:48 GMT
Content-Length: 19886
But even if I enable this repo, I do see two packages not one wine-staging and wine-staging-amd64:
wine-staging-it-repo.jpg
Suggest to switch mx-repo, and check whether you still see two identical packages listed.
May be to trying to reproduce post text out put of

Code: Select all

apt policy wine-staging wine-staging-amd64
+++ EDIT +++ Removed "-a" from apt policy ( that the one I use for apt show -a ...)
You do not have the required permissions to view the files attached to this post.
Gigabyte Z77M-D3H, Intel Xeon E3-1240 V2 (Quad core), 32GB RAM,
GeForce GTX 770, Samsung SSD 850 EVO 500GB, Seagate Barracuda 4TB

User avatar
~FLOW~
Posts: 203
Joined: Thu May 19, 2022 12:43 pm

Re: MX Package Installer - two options of the same package ?

#10 Post by ~FLOW~ »

Ok, something happened while I was taking the screenshot.
Screenshot_20230111_215942.png
After the screenshot, I had 3 identical packages
So I restart MX Package Installer and now it shows only one !

Code: Select all

~
$ apt policy wine-staging wine-staging-amd64
wine-staging:
  Installed: 7.15-1mx21+1
  Candidate: 7.15-1mx21+1
  Version table:
 *** 7.15-1mx21+1 100
        100 /var/lib/dpkg/status
     6.22-1mx21+2 500
        500 http://it.mxrepo.com/mx/repo bullseye/main amd64 Packages
wine-staging-amd64:
  Installed: 7.15-1mx21+1
  Candidate: 7.15-1mx21+1
  Version table:
 *** 7.15-1mx21+1 100
        100 /var/lib/dpkg/status
     6.22-1mx21+2 500
        500 http://it.mxrepo.com/mx/repo bullseye/main amd64 Packages
You do not have the required permissions to view the files attached to this post.
MX-21.3 / KDE Plasma 5.20.5
Kernel: 6.1.0-4mx-amd64

Be patient !!
What seams easy for you now, for a newbie might be a monumental helping hand.
An efficient pack will move as fast as the slowest member.

Post Reply

Return to “General”