Welcome!

The kernel problem with recent updates has been solved. Find the solution here

Important information
-- Required MX 15/16 Repository Changes
-- Information on torrent hosting changes
-- Information on MX15/16 GPG Keys
-- Spectre and Meltdown vulnerabilities

News
-- Introducing our new Website
-- MX Linux on social media: here

Current releases
-- MX-18.3 Point Release release info here
-- Migration Information to MX-18 here
-- antiX-17.4.1 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

cant install mono

Help for Current Versions of MX
Post Reply
ruflowerian
Forum Novice
Forum  Novice
Posts: 6
Joined: Thu Aug 15, 2019 3:44 am

cant install mono

#1

Post by ruflowerian » Fri Aug 16, 2019 2:25 am

sudo apt install mono-devel
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
mono-devel : Depends: mono-runtime (>= 3.0~) but it is not going to be installed
Depends: libc6 (>= 2.28) but 2.24-11+deb9u4 is to be installed or
libc6.1 (>= 2.28) but it is not installable or
libc0.1 (>= 2.28) but it is not installable
Depends: libglib2.0-0 (>= 2.58.3) but 2.56.1-2~mx17+1 is to be installed
Depends: libmono-cecil-private-cil (>= 6.0.0.319) but it is not going to be installed
Depends: libmono-cecil-private-cil (< 6.0.0.320) but it is not going to be installed
Depends: libmono-codecontracts4.0-cil (>= 1.0) but it is not going to be installed
Depends: libmono-compilerservices-symbolwriter4.0-cil (>= 3.6.0) but it is not going to be installed
Depends: libmono-corlib4.5-cil (>= 4.0.0~alpha1) but it is not going to be installed
Depends: libmono-peapi4.0a-cil (>= 3.2.8) but it is not going to be installed
Depends: libmono-relaxng4.0-cil (>= 2.10.1) but it is not going to be installed
Depends: libmono-security4.0-cil (>= 3.0.6) but it is not going to be installed
Depends: libmono-system-configuration-install4.0-cil (>= 1.0) but it is not going to be installed
Depends: libmono-system-configuration4.0-cil (>= 4.0.0~alpha1) but it is not going to be installed
Depends: libmono-system-core4.0-cil (>= 4.0.0~alpha1) but it is not going to be installed
Depends: libmono-system-data-linq4.0-cil (>= 1.0) but it is not going to be installed
Depends: libmono-system-data4.0-cil (>= 4.0.0~alpha1) but it is not going to be installed
Depends: libmono-system-drawing4.0-cil (>= 3.0.6) but it is not going to be installed
Depends: libmono-system-io-compression-filesystem4.0-cil (>= 3.2.1) but it is not going to be installed
Depends: libmono-system-runtime-serialization4.0-cil (>= 4.0.0~alpha1) but it is not going to be installed
Depends: libmono-system-runtime4.0-cil (>= 2.10.1) but it is not going to be installed
Depends: libmono-system-security4.0-cil (>= 1.0) but it is not going to be installed
Depends: libmono-system-servicemodel4.0a-cil (>= 3.2.3) but it is not going to be installed
Depends: libmono-system-web-services4.0-cil (>= 1.0) but it is not going to be installed
Depends: libmono-system-xml-linq4.0-cil (>= 3.0.6) but it is not going to be installed
Depends: libmono-system-xml4.0-cil (>= 3.12.0) but it is not going to be installed
Depends: libmono-system4.0-cil (>= 4.0.0~alpha1) but it is not going to be installed
Depends: mono-mcs (= 6.0.0.319-0xamarin4+debian10b1) but it is not going to be installed
Depends: mono-roslyn (= 6.0.0.319-0xamarin4+debian10b1) but it is not going to be installed
Depends: mono-gac (= 6.0.0.319-0xamarin4+debian10b1) but it is not going to be installed
Depends: mono-xbuild (= 6.0.0.319-0xamarin4+debian10b1) but it is not going to be installed
Depends: libmono-cil-dev (= 6.0.0.319-0xamarin4+debian10b1) but it is not going to be installed
Depends: libmono-2.0-dev (>= 6.0.0.319-0xamarin4+debian10b1) but it is not going to be installed
Depends: libmono-2.0-dev (< 6.0.0.319-0xamarin4+debian10b1.1~) but it is not going to be installed
Depends: ca-certificates-mono (= 6.0.0.319-0xamarin4+debian10b1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

User avatar
JayM
Forum Guide
Forum Guide
Posts: 1828
Joined: Tue Jan 08, 2019 4:47 am

Re: cant install mono

#2

Post by JayM » Fri Aug 16, 2019 3:44 am

Please edit your post with the pencil icon, select the entire contents, then click the </> icon. This will make it much easier to read. Thanks.
Please read How To Ask For Help and How to Break Your System.
MX User Manual: hold down ALT and press F1. Further information may be found in the MX Wiki.

User avatar
JayM
Forum Guide
Forum Guide
Posts: 1828
Joined: Tue Jan 08, 2019 4:47 am

Re: cant install mono

#3

Post by JayM » Fri Aug 16, 2019 3:47 am

For everyone else, here's his system info copied and pasted from his other post about the brightness control not working:

Code: Select all

System:    Host: mx Kernel: 4.19.0-5-amd64 x86_64 bits: 64 compiler: gcc v: 6.3.0 
           Desktop: Xfce 4.12.3 Distro: MX-18.3_x64 Continuum May 26  2019 
           base: Debian GNU/Linux 9 (stretch) 
Machine:   Type: Laptop System: SAMSUNG product: 870Z5E/880Z5E/680Z5E v: P05ADH serial: <filter> 
           Mobo: SAMSUNG model: NP880Z5E-X01RU v: SEC_SW_REVISION_1234567890ABCD 
           serial: <filter> UEFI: American Megatrends v: P05ADH.017.140421.SH date: 04/21/2014 
Battery:   ID-1: BAT1 charge: 71.5 Wh condition: 77.5/92.0 Wh (84%) 
           model: SAMSUNG Electronics SR Real Battery status: Discharging 
CPU:       Topology: Quad Core model: Intel Core i7-3635QM bits: 64 type: MT MCP 
           arch: Ivy Bridge rev: 9 L2 cache: 6144 KiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 38312 
           Speed: 3316 MHz min/max: 1200/3400 MHz Core speeds (MHz): 1: 3117 2: 2785 3: 2658 
           4: 3012 5: 2958 6: 2956 7: 2972 8: 2817 
Graphics:  Device-1: Intel 3rd Gen Core processor Graphics vendor: Samsung Co driver: i915 
           v: kernel bus ID: 00:02.0 
           Device-2: AMD Venus XT [Radeon HD 8870M / R9 M270X/M370X] driver: radeon v: kernel 
           bus ID: 01:00.0 
           Display: x11 server: X.Org 1.19.2 driver: ati,modesetting,radeon unloaded: fbdev,vesa 
           resolution: 1920x1080~60Hz 
           OpenGL: renderer: Mesa DRI Intel Ivybridge Mobile v: 4.2 Mesa 18.2.6 
           direct render: Yes 
Audio:     Device-1: Intel 7 Series/C216 Family High Definition Audio vendor: Samsung Co 
           driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
           Sound Server: ALSA v: k4.19.0-5-amd64 
Network:   Device-1: Intel Centrino Advanced-N 6235 driver: iwlwifi v: kernel port: e000 
           bus ID: 02:00.0 
           IF: wlan0 state: up mac: <filter> 
           Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Samsung Co 
           driver: r8169 v: kernel port: d000 bus ID: 03:00.0 
           IF: eth0 state: down mac: <filter> 
Drives:    Local Storage: total: 28.64 GiB used: 6.11 GiB (21.3%) 
           ID-1: /dev/sda type: USB vendor: SanDisk model: Ultra Fit size: 28.64 GiB 
Partition: ID-1: / size: 25.82 GiB used: 6.11 GiB (23.7%) fs: ext4 dev: /dev/sda2 
           ID-2: swap-1 size: 2.00 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda3 
Sensors:   System Temperatures: cpu: 42.0 C mobo: N/A gpu: radeon temp: 42 C 
           Fan Speeds (RPM): N/A 
Repos:     Active apt repos in: /etc/apt/sources.list.d/antix.list 
           1: deb http://iso.mxrepo.com/antix/stretch stretch main
           Active apt repos in: /etc/apt/sources.list.d/debian-stable-updates.list 
           1: deb http://ftp.au.debian.org/debian/ stretch-updates main contrib non-free
           Active apt repos in: /etc/apt/sources.list.d/debian.list 
           1: deb http://ftp.au.debian.org/debian/ stretch main contrib non-free
           2: deb http://security.debian.org/ stretch/updates main contrib non-free
           Active apt repos in: /etc/apt/sources.list.d/google-chrome.list 
           1: deb [arch=amd64] http://dl.google.com/linux/chrome/deb/ stable main
           Active apt repos in: /etc/apt/sources.list.d/mx.list 
           1: deb http://mx.mirror.ausnetservers.net.au/packages/repo/ stretch main non-free
           No active apt repos in: /etc/apt/sources.list.d/various.list 
Info:      Processes: 271 Uptime: 1d 20h 52m Memory: 15.56 GiB used: 2.73 GiB (17.6%) 
           Init: SysVinit runlevel: 5 Compilers: gcc: 6.3.0 Shell: bash v: 4.4.12 inxi: 3.0.33 
Please read How To Ask For Help and How to Break Your System.
MX User Manual: hold down ALT and press F1. Further information may be found in the MX Wiki.

User avatar
aledie
Forum Regular
Forum Regular
Posts: 208
Joined: Thu Sep 13, 2018 2:06 pm

Re: cant install mono

#4

Post by aledie » Fri Aug 16, 2019 7:24 am

@ruflowerian:
Can you switch to another mirror and try again?

It seems mx.mirror.ausnetservers.net.au fell out of sync some time ago, which might be the reason. I will contact them to check their update setup.
MX-18 (x64): HP 8460p, i5-2540M, 8GB RAM, 256GB SSD, HD3000

User avatar
fehlix
Forum Veteran
Forum Veteran
Posts: 4619
Joined: Wed Apr 11, 2018 5:09 pm

Re: cant install mono

#5

Post by fehlix » Fri Aug 16, 2019 1:11 pm

ruflowerian wrote:
Fri Aug 16, 2019 2:25 am
sudo apt install mono-devel
Depends: libmono-cecil-private-cil (>= 6.0.0.319) but it is not going to be installed
Depends: libmono-cecil-private-cil (< 6.0.0.320) but it is not going to be installed
That's a probaly a 3rd party enabled repo puzzle. OP might have enabled mono's debian repo and get now conflicts.
If I've searched properly, none of those mono version's 6.0.0.319 are available in MX or in debian's official repo.
Gigabyte Z77M-D3H, Intel Xeon E3-1240 V2 (Quad core), 32GB RAM,
GeForce GTX 770, Samsung SSD 850 EVO 500GB, Seagate Barracuda 4TB

User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 19862
Joined: Fri Dec 15, 2006 8:07 pm

Re: cant install mono

#6

Post by Stevo » Sat Aug 17, 2019 4:20 pm

From answers on his Reddit post, he may have activated that third-party mono repo's Buster repo instead of their Stretch one, too.

Post Reply

Return to “MX Help”