Welcome!
Important information
-- Required MX 15/16 Repository Changes
-- Information on torrent hosting changes
-- Information on MX15/16 GPG Keys
-- Spectre and Meltdown vulnerabilities

News
-- Introducing our new Website
-- MX Linux on social media: here

Current releases
-- MX-18.3 Point Release release info here
-- Migration Information to MX-18 here
-- antiX-17.4.1 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

Generic Icon Displaying for Eclipse

Help for Current Versions of MX
Post Reply
User avatar
McSlappy
Forum Novice
Forum  Novice
Posts: 5
Joined: Fri Jun 14, 2019 2:37 pm

Generic Icon Displaying for Eclipse

#1

Post by McSlappy » Fri Jun 14, 2019 2:48 pm

Hello MX Forums. This is my first time posting, but I have heard phenomenal things about the community here.

So basically, I downloaded Eclipse for Linux and everything works fine other than this one problem. I have tried to create a desktop / launch bar icon for Eclipse, and though it does work it's not displaying the original icon. I looked in the folder where I installed it, and the file for the icon is there. I'm not quite sure where the problem is but I can tell you I am very inexperienced with Linux. I've messed around with Ubuntu years ago, and a distro of Debian for my raspberry Pi, however I'm still learning my way around the terminal, and am an all around Linux novice. Whatever help I could get I would be grateful for, although this is not causing any issues with functionality and is strictly an aesthetic problem.
“A good act does not wash out the bad, nor a bad act the good. Each should have its own reward.” - George R.R. Martin

User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 19299
Joined: Fri Dec 15, 2006 8:07 pm

Re: Generic Icon Displaying for Eclipse

#2

Post by Stevo » Fri Jun 14, 2019 3:48 pm

Do you know where the .desktop file you created ended up? If for your local user, it might be in your home folder in the hidden .local/share/applications folder.

If you find it, open it with a text editor and tell us what the "Icon=" line says.

User avatar
McSlappy
Forum Novice
Forum  Novice
Posts: 5
Joined: Fri Jun 14, 2019 2:37 pm

Re: Generic Icon Displaying for Eclipse

#3

Post by McSlappy » Fri Jun 14, 2019 3:55 pm

Ok, so just to go into a little more depth- the icon exists in the folder, as you can see here.
Image

The actual executable is visible with the generic (gear?) icon, though once it boots up and is in the launch bar it displays with the correct icon.

When I send a shortcut to my desktop it maintains the gear (emblem/icon)
Image

Under properties I do have the option to change the emblem to another generic one, but not the correct one located in the eclipse folder (Icon.xpm)

My goal here is to have the Eclipse shortcut on my desktop or launch bar with the correct icon. Seems like it should be possible. Again thanks for your time.
“A good act does not wash out the bad, nor a bad act the good. Each should have its own reward.” - George R.R. Martin

User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 19299
Joined: Fri Dec 15, 2006 8:07 pm

Re: Generic Icon Displaying for Eclipse

#4

Post by Stevo » Fri Jun 14, 2019 3:57 pm

A shortcut is actually a .desktop file. Have you created one?

User avatar
McSlappy
Forum Novice
Forum  Novice
Posts: 5
Joined: Fri Jun 14, 2019 2:37 pm

Re: Generic Icon Displaying for Eclipse

#5

Post by McSlappy » Fri Jun 14, 2019 3:57 pm

Stevo wrote:
Fri Jun 14, 2019 3:48 pm
Do you know where the .desktop file you created ended up? If for your local user, it might be in your home folder in the hidden .local/share/applications folder.

If you find it, open it with a text editor and tell us what the "Icon=" line says.
I dont believe I created a .desktop file. I'll go ahead and assume this is the issue. I installed twice and was not prompted to do so, and I read on a forum post somewhere how to find them but not how to create them
“A good act does not wash out the bad, nor a bad act the good. Each should have its own reward.” - George R.R. Martin

User avatar
McSlappy
Forum Novice
Forum  Novice
Posts: 5
Joined: Fri Jun 14, 2019 2:37 pm

Re: Generic Icon Displaying for Eclipse

#6

Post by McSlappy » Fri Jun 14, 2019 3:59 pm

So to get it onto my desktop I right clicked the executable and sent to -> desktop (create link)
“A good act does not wash out the bad, nor a bad act the good. Each should have its own reward.” - George R.R. Martin

User avatar
McSlappy
Forum Novice
Forum  Novice
Posts: 5
Joined: Fri Jun 14, 2019 2:37 pm

Re: Generic Icon Displaying for Eclipse

#7

Post by McSlappy » Fri Jun 14, 2019 4:08 pm

Ok so I solved this by right clicking on the desktop, creating a launcher, and then selecting the command and icon. I did not input a working directory (hopefully this doesnt cause problems) but I now have a functional Eclipse Icon! I appreciate the help. As you can tell I'm use to windows..
“A good act does not wash out the bad, nor a bad act the good. Each should have its own reward.” - George R.R. Martin

Post Reply

Return to “MX Help”