Welcome!

The kernel problem with recent updates has been solved. Find the solution here

Important information
-- Required MX 15/16 Repository Changes
-- Information on torrent hosting changes
-- Information on MX15/16 GPG Keys
-- Spectre and Meltdown vulnerabilities

News
-- Introducing our new Website
-- MX Linux on social media: here

Current releases
-- MX-18.3 Point Release release info here
-- Migration Information to MX-18 here
-- antiX-17.4.1 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

Audacious Media Player - outdated package (3 years old)

User avatar
seaken64
Forum Regular
Forum Regular
Posts: 214
Joined: Wed Jan 02, 2019 2:43 pm

Re: Audacious Media Player - outdated package (3 years old)

#11

Post by seaken64 » Mon Aug 12, 2019 7:54 pm

I have used Audacious. But I never noticed if it was the latest version or not. Seems I didn't care. And this is often the case for me. I often prefer not to upgrade, unless I have a particular need. I use a lot of software older than 2016! If it does what I want I don't notice what year it was released.

Now, a question on the flip side. I'm fine with the Main repo having an updated version. But what if the updated version doesn't work as well for me as the old version? There is no repo named "archive" or "legacy" for older versions of software (or is there?) How do I keep an old version? Is this supported in the MX Package Installer somewhere? I can't see how that would work.

Seaken64
MX-18 on Thinkpad R61i Core2 Laptop. MX-18 on HP Core2 Desktop
MX-18-64/MX-18-32/antiX-17-32 Frugal on Gateway Core2 Laptop
antiX-17 on Compaq PIII 1000 Mhz Desktop, Multi-boot Slackware, Debian, MX, W2K
antiX-17/16 on Dell PIII 450 Mhz Laptop

User avatar
Stevo
Developer
Posts: 20110
Joined: Fri Dec 15, 2006 8:07 pm

Re: Audacious Media Player - outdated package (3 years old)

#12

Post by Stevo » Mon Aug 12, 2019 10:56 pm

seaken64 wrote:
Mon Aug 12, 2019 7:54 pm
I have used Audacious. But I never noticed if it was the latest version or not. Seems I didn't care. And this is often the case for me. I often prefer not to upgrade, unless I have a particular need. I use a lot of software older than 2016! If it does what I want I don't notice what year it was released.

Now, a question on the flip side. I'm fine with the Main repo having an updated version. But what if the updated version doesn't work as well for me as the old version? There is no repo named "archive" or "legacy" for older versions of software (or is there?) How do I keep an old version? Is this supported in the MX Package Installer somewhere? I can't see how that would work.

Seaken64
apt, aptitude, or Synaptic support installing the specific older version in Stretch.

User avatar
malspa
Forum Regular
Forum Regular
Posts: 2034
Joined: Thu Jul 13, 2006 7:21 am

Re: Audacious Media Player - outdated package (3 years old)

#13

Post by malspa » Mon Aug 12, 2019 11:13 pm

colin_b wrote:
Mon Aug 12, 2019 7:09 pm
Audacious 3.3 released
Uh, check the date on that, I think.

User avatar
asqwerth
Developer
Posts: 5161
Joined: Sun May 27, 2007 5:37 am

Re: Audacious Media Player - outdated package (3 years old)

#14

Post by asqwerth » Mon Aug 12, 2019 11:16 pm

LOL
Desktop: Intel i5-4460, 16GB RAM, Intel integrated graphics
Clevo N130WU-based Ultrabook: Intel i7-8550U (Kaby Lake R), 16GB RAM, Intel integrated graphics (UEFI)
ASUS X42D laptop: AMD Phenom II, 6GB RAM, Mobility Radeon HD 5400

User avatar
colin_b
Forum Regular
Forum Regular
Posts: 561
Joined: Sun Mar 19, 2017 7:21 pm

Re: Audacious Media Player - outdated package (3 years old)

#15

Post by colin_b » Tue Aug 13, 2019 6:26 pm

malspa wrote:
Mon Aug 12, 2019 11:13 pm
Uh, check the date on that, I think.
You're right :eek:

I assumed that release 3.3 would be more recent than 3.10.1 - numbering schemes generally do a simple increment, and this would result in v3.9 moving on to v4. Audacious confused things by going from v3.9 to v3.10 - I didn't realise this.

I'll look at the date articles are posted next time to avoid wasted posts here.

:embarrassed:

User avatar
Eadwine Rose
Administrator
Posts: 9329
Joined: Wed Jul 12, 2006 2:10 am

Re: Audacious Media Player - outdated package (3 years old)

#16

Post by Eadwine Rose » Wed Aug 14, 2019 3:42 am

I see this in other places too.. I believe the kernels do this. Mighty confusing so you're not alone ;)
MX-18.3_x64 May 26 2019 * 4.19.0-5-amd64 ext4 Xfce 4.12.3 * 8-core AMD Ryzen 7 2700
Asus TUF B450-Plus Gaming UEFI * Asus GTX 1050 Ti Nvidia 390.116 * 2x16Gb DDR4 2666 Kingston HyperX Predator
Samsung 860EVO * Samsung S24D330 & P2250 * HP Envy5030

User avatar
JayM
Qualified MX Guide
Posts: 2112
Joined: Tue Jan 08, 2019 4:47 am

Re: Audacious Media Player - outdated package (3 years old)

#17

Post by JayM » Wed Aug 14, 2019 3:53 am

That's thrown me off too, especially when (in the instance of kernels in the stable repo) 4.14 through 4.20 are displayed before 4.9. I think that's the standard Unix sorting order. To get around that the 4.9 series of kernels would need a leading zero before the nine, but the kernel naming (numbering) convention doesn't do that.

Code: Select all

linux-image-4.13.0-1-686/mx 4.13.13-1mx17 i386
linux-image-4.13.0-1-686-pae/mx 4.13.13-1mx17 i386
linux-image-4.13.0-1-amd64/mx 4.13.13-1mx17 amd64
linux-image-4.14.0-0.bpo.3-686/mx 4.14.13-1~bpo9+1mx17+1 i386
linux-image-4.14.0-0.bpo.3-686-pae/mx 4.14.13-1~bpo9+1mx17+1 i386
linux-image-4.14.0-0.bpo.3-amd64/mx 4.14.13-1~bpo9+1mx17+1 amd64
linux-image-4.14.0-0.bpo.3-rt-686-pae/mx 4.14.13-1~bpo9+1mx17+1 i386
linux-image-4.14.0-0.bpo.3-rt-amd64/mx 4.14.13-1~bpo9+1mx17+1 amd64
linux-image-4.14.0-3-686/mx 4.14.13-1~bpo9+1mx17+2 i386
linux-image-4.14.0-3-686-pae/mx 4.14.13-1~bpo9+1mx17+2 i386
linux-image-4.14.0-3-amd64/mx 4.14.13-1~bpo9+1mx17+2 amd64
linux-image-4.14.0-3-rt-686-pae/mx 4.14.13-1~bpo9+1mx17+2 i386
linux-image-4.14.0-3-rt-amd64/mx 4.14.13-1~bpo9+1mx17+2 amd64
linux-image-4.14.12-antix.1-686-smp-pae/stretch 4.14.12-antix.1-686-smp-pae-1 i386
linux-image-4.14.12-antix.1-amd64-smp/stretch 4.14.12-antix.1-amd64-smp-1 amd64
linux-image-4.14.12-gnu-antix.1-686-smp-pae/stretch 4.14.12-gnu-antix.1-686-smp-pae-1 i386
linux-image-4.14.12-gnu-antix.1-amd64-smp/stretch 4.14.12-gnu-antix.1-amd64-smp-1 amd64
linux-image-4.14.14-antix.1-686-smp-pae/stretch 4.14.14-antix.1-686-smp-pae-1 i386
linux-image-4.14.14-antix.1-amd64-smp/stretch 4.14.14-antix.1-amd64-smp-1 amd64
linux-image-4.15.0-1-686/mx 4.15.4-1~mx17+1 i386
linux-image-4.15.0-1-686-pae/mx 4.15.4-1~mx17+1 i386
linux-image-4.15.0-1-amd64/mx 4.15.4-1~mx17+1 amd64
linux-image-4.15.0-1-cloud-amd64/mx 4.15.4-1~mx17+1 amd64
linux-image-4.18.0-2-686/mx 4.18.10-1~mx17+1 i386
linux-image-4.18.0-2-686-pae/mx 4.18.10-1~mx17+1 i386
linux-image-4.18.0-2-amd64/mx 4.18.10-1~mx17+1 amd64
linux-image-4.18.0-2-cloud-amd64/mx 4.18.10-1~mx17+1 amd64
linux-image-4.18.0-2-rt-686-pae/mx 4.18.10-1~mx17+1 i386
linux-image-4.18.0-2-rt-amd64/mx 4.18.10-1~mx17+1 amd64
linux-image-4.19.0-1-686-pae-unsigned/mx 4.19.5-2~mx17+1 i386
linux-image-4.19.0-1-686-unsigned/mx 4.19.5-2~mx17+1 i386
linux-image-4.19.0-1-amd64-unsigned/mx 4.19.5-2~mx17+1 amd64
linux-image-4.19.0-1-cloud-amd64-unsigned/mx 4.19.5-2~mx17+1 amd64
linux-image-4.19.0-1-rt-686-pae-unsigned/mx 4.19.5-2~mx17+1 i386
linux-image-4.19.0-1-rt-amd64-unsigned/mx 4.19.5-2~mx17+1 amd64
linux-image-4.19.0-5-686-pae-unsigned/mx 4.19.37-2~mx17+1 i386
linux-image-4.19.0-5-686-unsigned/mx 4.19.37-2~mx17+1 i386
linux-image-4.19.0-5-amd64-unsigned/mx,now 4.19.37-2~mx17+1 amd64 [installed]
linux-image-4.19.0-5-cloud-amd64-unsigned/mx 4.19.37-2~mx17+1 amd64
linux-image-4.19.0-5-rt-686-pae-unsigned/mx 4.19.37-2~mx17+1 i386
linux-image-4.19.0-5-rt-amd64-unsigned/mx 4.19.37-2~mx17+1 amd64
linux-image-4.19.25-antix.1-486-smp/stretch 4.19.25-antix.1-486-smp-1 i386
linux-image-4.19.25-antix.1-686-smp-pae/stretch 4.19.25-antix.1-686-smp-pae-1 i386
linux-image-4.19.25-antix.1-amd64-smp/stretch 4.19.25-antix.1-amd64-smp-1 amd64
linux-image-4.19.36-antix.1-486-smp/stretch 4.19.36-antix.1-486-smp-1 i386
linux-image-4.19.36-antix.1-686-smp-pae/stretch 4.19.36-antix.1-686-smp-pae-1 i386
linux-image-4.19.36-antix.1-amd64-smp/stretch 4.19.36-antix.1-amd64-smp-1 amd64
linux-image-4.19.43-antix.1-486-smp/stretch 4.19.43-antix.1-486-smp-1 i386
linux-image-4.19.43-antix.1-686-smp-pae/stretch 4.19.43-antix.1-686-smp-pae-1 i386
linux-image-4.19.43-antix.1-amd64-smp/stretch 4.19.43-antix.1-amd64-smp-1 amd64
linux-image-4.19.52-antix.1-486-smp/stretch 4.19.52-antix.1-486-smp-1 i386
linux-image-4.19.52-antix.1-686-smp-pae/stretch 4.19.52-antix.1-686-smp-pae-1 i386
linux-image-4.19.52-antix.1-amd64-smp/stretch 4.19.52-antix.1-amd64-smp-1 amd64
linux-image-4.19.61-antix.1-486-smp/stretch 4.19.61-antix.1-486-smp-1 i386
linux-image-4.19.61-antix.1-686-smp-pae/stretch 4.19.61-antix.1-686-smp-pae-1 i386
linux-image-4.19.61-antix.1-amd64-smp/stretch 4.19.61-antix.1-amd64-smp-1 amd64
linux-image-4.20.12-antix.1-486-smp/stretch 4.20.12-antix.1-486-smp-1 i386
linux-image-4.20.12-antix.1-686-smp-pae/stretch 4.20.12-antix.1-686-smp-pae-1 i386
linux-image-4.20.12-antix.1-amd64-smp/stretch 4.20.12-antix.1-amd64-smp-1 amd64
linux-image-4.9.0-3-686/oldstable 4.9.30-2+deb9u5 i386
linux-image-4.9.0-3-686-dbg/oldstable 4.9.30-2+deb9u5 i386
linux-image-4.9.0-3-686-pae/oldstable 4.9.30-2+deb9u5 i386
linux-image-4.9.0-3-686-pae-dbg/oldstable 4.9.30-2+deb9u5 i386
linux-image-4.9.0-3-amd64/oldstable 4.9.30-2+deb9u5 amd64
linux-image-4.9.0-3-amd64-dbg/oldstable 4.9.30-2+deb9u5 amd64
linux-image-4.9.0-3-rt-686-pae/oldstable 4.9.30-2+deb9u5 i386
linux-image-4.9.0-3-rt-686-pae-dbg/oldstable 4.9.30-2+deb9u5 i386
linux-image-4.9.0-3-rt-amd64/oldstable 4.9.30-2+deb9u5 amd64
linux-image-4.9.0-3-rt-amd64-dbg/oldstable 4.9.30-2+deb9u5 amd64
linux-image-4.9.0-4-686/oldstable 4.9.65-3+deb9u1 i386
linux-image-4.9.0-4-686-dbg/oldstable 4.9.65-3+deb9u1 i386
linux-image-4.9.0-4-686-pae/oldstable 4.9.65-3+deb9u1 i386
linux-image-4.9.0-4-686-pae-dbg/oldstable 4.9.65-3+deb9u1 i386
linux-image-4.9.0-4-amd64/oldstable 4.9.65-3+deb9u1 amd64
linux-image-4.9.0-4-amd64-dbg/oldstable 4.9.65-3+deb9u1 amd64
linux-image-4.9.0-4-rt-686-pae/oldstable 4.9.65-3+deb9u1 i386
linux-image-4.9.0-4-rt-686-pae-dbg/oldstable 4.9.65-3+deb9u1 i386
linux-image-4.9.0-4-rt-amd64/oldstable 4.9.65-3+deb9u1 amd64
linux-image-4.9.0-4-rt-amd64-dbg/oldstable 4.9.65-3+deb9u1 amd64
linux-image-4.9.0-5-686/oldstable 4.9.65-3+deb9u2 i386
linux-image-4.9.0-5-686-dbg/oldstable 4.9.65-3+deb9u2 i386
linux-image-4.9.0-5-686-pae/oldstable 4.9.65-3+deb9u2 i386
linux-image-4.9.0-5-686-pae-dbg/oldstable 4.9.65-3+deb9u2 i386
linux-image-4.9.0-5-amd64/oldstable 4.9.65-3+deb9u2 amd64
linux-image-4.9.0-5-amd64-dbg/oldstable 4.9.65-3+deb9u2 amd64
linux-image-4.9.0-5-rt-686-pae/oldstable 4.9.65-3+deb9u2 i386
linux-image-4.9.0-5-rt-686-pae-dbg/oldstable 4.9.65-3+deb9u2 i386
linux-image-4.9.0-5-rt-amd64/oldstable 4.9.65-3+deb9u2 amd64
linux-image-4.9.0-5-rt-amd64-dbg/oldstable 4.9.65-3+deb9u2 amd64
linux-image-4.9.0-6-686/oldstable 4.9.88-1+deb9u1 i386
linux-image-4.9.0-6-686-dbg/oldstable 4.9.88-1+deb9u1 i386
linux-image-4.9.0-6-686-pae/oldstable 4.9.88-1+deb9u1 i386
linux-image-4.9.0-6-686-pae-dbg/oldstable 4.9.88-1+deb9u1 i386
linux-image-4.9.0-6-amd64/oldstable 4.9.88-1+deb9u1 amd64
linux-image-4.9.0-6-amd64-dbg/oldstable 4.9.88-1+deb9u1 amd64
linux-image-4.9.0-6-rt-686-pae/oldstable 4.9.88-1+deb9u1 i386
linux-image-4.9.0-6-rt-686-pae-dbg/oldstable 4.9.88-1+deb9u1 i386
linux-image-4.9.0-6-rt-amd64/oldstable 4.9.88-1+deb9u1 amd64
linux-image-4.9.0-6-rt-amd64-dbg/oldstable 4.9.88-1+deb9u1 amd64
linux-image-4.9.0-7-686/oldstable 4.9.110-3+deb9u2 i386
linux-image-4.9.0-7-686-dbg/oldstable 4.9.110-3+deb9u2 i386
linux-image-4.9.0-7-686-pae/oldstable 4.9.110-3+deb9u2 i386
linux-image-4.9.0-7-686-pae-dbg/oldstable 4.9.110-3+deb9u2 i386
linux-image-4.9.0-7-amd64/oldstable 4.9.110-3+deb9u2 amd64
linux-image-4.9.0-7-amd64-dbg/oldstable 4.9.110-3+deb9u2 amd64
linux-image-4.9.0-7-rt-686-pae/oldstable 4.9.110-3+deb9u2 i386
linux-image-4.9.0-7-rt-686-pae-dbg/oldstable 4.9.110-3+deb9u2 i386
linux-image-4.9.0-7-rt-amd64/oldstable 4.9.110-3+deb9u2 amd64
linux-image-4.9.0-7-rt-amd64-dbg/oldstable 4.9.110-3+deb9u2 amd64
linux-image-4.9.0-8-686/oldstable 4.9.110-3+deb9u6 i386
linux-image-4.9.0-8-686-dbg/oldstable 4.9.110-3+deb9u6 i386
linux-image-4.9.0-8-686-pae/oldstable 4.9.110-3+deb9u6 i386
linux-image-4.9.0-8-686-pae-dbg/oldstable 4.9.110-3+deb9u6 i386
linux-image-4.9.0-8-amd64/oldstable 4.9.110-3+deb9u6 amd64
linux-image-4.9.0-8-amd64-dbg/oldstable 4.9.110-3+deb9u6 amd64
linux-image-4.9.0-8-rt-686-pae/oldstable 4.9.110-3+deb9u6 i386
linux-image-4.9.0-8-rt-686-pae-dbg/oldstable 4.9.110-3+deb9u6 i386
linux-image-4.9.0-8-rt-amd64/oldstable 4.9.110-3+deb9u6 amd64
linux-image-4.9.0-8-rt-amd64-dbg/oldstable 4.9.110-3+deb9u6 amd64
linux-image-4.9.0-9-686/oldstable 4.9.168-1+deb9u5 i386
linux-image-4.9.0-9-686-dbg/oldstable 4.9.168-1+deb9u5 i386
linux-image-4.9.0-9-686-pae/oldstable 4.9.168-1+deb9u5 i386
linux-image-4.9.0-9-686-pae-dbg/oldstable 4.9.168-1+deb9u5 i386
linux-image-4.9.0-9-amd64/oldstable 4.9.168-1+deb9u5 amd64
linux-image-4.9.0-9-amd64-dbg/oldstable 4.9.168-1+deb9u5 amd64
linux-image-4.9.0-9-rt-686-pae/oldstable 4.9.168-1+deb9u5 i386
linux-image-4.9.0-9-rt-686-pae-dbg/oldstable 4.9.168-1+deb9u5 i386
linux-image-4.9.0-9-rt-amd64/oldstable 4.9.168-1+deb9u5 amd64
linux-image-4.9.0-9-rt-amd64-dbg/oldstable 4.9.168-1+deb9u5 amd64
linux-image-4.9.160-antix.1-486-smp/stretch 4.9.160-antix.1-486-smp-2 i386
linux-image-4.9.160-antix.1-686-smp-pae/stretch 4.9.160-antix.1-686-smp-pae-1 i386
linux-image-4.9.160-antix.1-amd64-smp/stretch 4.9.160-antix.1-amd64-smp-1 amd64
linux-image-4.9.160-antix.2-486-smp/stretch 4.9.160-antix.2-486-smp-1 i386
linux-image-4.9.170-antix.1-486-smp/stretch 4.9.170-antix.1-486-smp-2 i386
linux-image-4.9.170-antix.1-686-smp-pae/stretch 4.9.170-antix.1-686-smp-pae-1 i386
linux-image-4.9.170-antix.1-amd64-smp/stretch 4.9.170-antix.1-amd64-smp-1 amd64
linux-image-4.9.176-antix.1-486-smp/stretch 4.9.176-antix.1-486-smp-1 i386
linux-image-4.9.176-antix.1-686-smp-pae/stretch 4.9.176-antix.1-686-smp-pae-2 i386
linux-image-4.9.176-antix.1-amd64-smp/stretch 4.9.176-antix.1-amd64-smp-1 amd64
linux-image-4.9.182-antix.1-486-smp/stretch 4.9.182-antix.1-486-smp-1 i386
linux-image-4.9.182-antix.1-686-smp-pae/stretch 4.9.182-antix.1-686-smp-pae-1 i386
linux-image-4.9.182-antix.1-amd64-smp/stretch,now 4.9.182-antix.1-amd64-smp-1 amd64 [installed]
linux-image-4.9.186-antix.1-486-smp/stretch 4.9.186-antix.1-486-smp-1 i386
linux-image-4.9.186-antix.1-686-smp-pae/stretch 4.9.186-antix.1-686-smp-pae-1 i386
linux-image-4.9.186-antix.1-amd64-smp/stretch 4.9.186-antix.1-amd64-smp-1 amd64
linux-image-5.0.9-antix.1-486-smp/stretch 5.0.9-antix.1-486-smp-1 i386
linux-image-5.0.9-antix.1-686-smp-pae/stretch 5.0.9-antix.1-686-smp-pae-1 i386
linux-image-5.0.9-antix.1-amd64-smp/stretch 5.0.9-antix.1-amd64-smp-1 amd64
linux-image-5.1.11-antix.1-486-smp/stretch 5.1.11-antix.1-486-smp-1 i386
linux-image-5.1.11-antix.1-686-smp-pae/stretch 5.1.11-antix.1-686-smp-pae-1 i386
linux-image-5.1.11-antix.1-amd64-smp/stretch 5.1.11-antix.1-amd64-smp-1 amd64
linux-image-5.1.2-antix.1-486-smp/stretch 5.1.2-antix.1-486-smp-1 i386
linux-image-5.1.2-antix.1-686-smp-pae/stretch 5.1.2-antix.1-686-smp-pae-1 i386
linux-image-5.1.2-antix.1-amd64-smp/stretch 5.1.2-antix.1-amd64-smp-1 amd64
linux-image-5.1.5-antix.1-486-smp/stretch 5.1.5-antix.1-486-smp-1 i386
linux-image-5.1.5-antix.1-686-smp-pae/stretch 5.1.5-antix.1-686-smp-pae-1 i386
linux-image-5.1.5-antix.1-amd64-smp/stretch 5.1.5-antix.1-amd64-smp-1 amd64
linux-image-5.2.3-antix.1-486-smp/stretch 5.2.3-antix.1-486-smp-1 i386
linux-image-5.2.3-antix.1-686-smp-pae/stretch 5.2.3-antix.1-686-smp-pae-1 i386
linux-image-5.2.3-antix.1-amd64-smp/stretch 5.2.3-antix.1-amd64-smp-1 amd64
Please read How To Ask For Help and How to Break Your System.
MX User Manual: hold down ALT and press F1. Further information may be found in the MX Wiki.

Post Reply

Return to “Package Requests/Status - MX 17/18”