Welcome!

The kernel problem with recent updates has been solved. Find the solution here

Important information
-- Required MX 15/16 Repository Changes
-- Information on torrent hosting changes
-- Information on MX15/16 GPG Keys
-- Spectre and Meltdown vulnerabilities

News
-- Introducing our new Website
-- MX Linux on social media: here

Current releases
-- MX-18.3 Point Release release info here
-- Migration Information to MX-18 here
-- antiX-17.4.1 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

[solved] MX nvidia driver tool fails to build & configure 340

Report Bugs, Issues and non- package Requests
Post Reply
User avatar
galen
Forum Regular
Forum Regular
Posts: 114
Joined: Thu Dec 15, 2016 1:37 pm

[solved] MX nvidia driver tool fails to build & configure 340

#1

Post by galen » Tue Jun 11, 2019 9:59 pm

It creates the proper xorg.conf
but not the proper drivers
did not create an error

System on reboot will not startx lightdm

/etc/X11/xorg.conf
must be then removed & rebooted in order to have X fallback to failsafe mode

driver package nvidia 340.107 current
Last edited by galen on Wed Jun 12, 2019 12:19 am, edited 1 time in total.
Linux user since 1999, on-line 1993
MX :number1: over Xubuntu, Sparky, Linux Lite
Dtop#1: Xubuntu 18.04, AMD-FX6300, GT730
Dtop#2: MX, AMD FX4300, GT218-8400
Ltop#1: XU16.04 T500
Ltop#2: XU18.04 HP T440
Ltop#3: MX NC4400
Ltop#4: Zorin32b IBM T30 :turtle:

User avatar
dolphin_oracle
Forum Veteran
Forum Veteran
Posts: 11902
Joined: Sun Dec 16, 2007 1:17 pm

Re: MX nvidia driver tool fails to build & configure 340

#2

Post by dolphin_oracle » Tue Jun 11, 2019 10:50 pm

please post the /var/log/ddm.log file.
http://www.youtube.com/runwiththedolphin
lenovo ThinkPad T530 - MX-18.3
lenovo s21e - antiX-19 beta 2 (live-USB)
FYI: mx "test" repo is not the same thing as debian testing repo.

User avatar
galen
Forum Regular
Forum Regular
Posts: 114
Joined: Thu Dec 15, 2016 1:37 pm

Re: MX nvidia driver tool fails to build & configure 340

#3

Post by galen » Wed Jun 12, 2019 12:14 am

modprobe: FATAL: Module nvidia-legacy-340xx not found in directory /lib/modules/4.20.12-antix.1-amd64-smp
modprobe: ERROR: ../libkmod/libkmod-module.c:977 command_do() Error running install command for nvidia
modprobe: ERROR: could not insert 'nvidia': Operation not permitted


/var/log/ddm/log is large
Linux user since 1999, on-line 1993
MX :number1: over Xubuntu, Sparky, Linux Lite
Dtop#1: Xubuntu 18.04, AMD-FX6300, GT730
Dtop#2: MX, AMD FX4300, GT218-8400
Ltop#1: XU16.04 T500
Ltop#2: XU18.04 HP T440
Ltop#3: MX NC4400
Ltop#4: Zorin32b IBM T30 :turtle:

User avatar
galen
Forum Regular
Forum Regular
Posts: 114
Joined: Thu Dec 15, 2016 1:37 pm

Re: MX nvidia driver tool fails to build & configure 340

#4

Post by galen » Wed Jun 12, 2019 12:18 am

3rd time was the charm
Linux user since 1999, on-line 1993
MX :number1: over Xubuntu, Sparky, Linux Lite
Dtop#1: Xubuntu 18.04, AMD-FX6300, GT730
Dtop#2: MX, AMD FX4300, GT218-8400
Ltop#1: XU16.04 T500
Ltop#2: XU18.04 HP T440
Ltop#3: MX NC4400
Ltop#4: Zorin32b IBM T30 :turtle:

Post Reply

Return to “Bugs and Non-Package Requests Forum”