Welcome!
Important information
-- Required MX 15/16 Repository Changes
-- Information on torrent hosting changes
-- Information on MX15/16 GPG Keys
-- Spectre and Meltdown vulnerabilities

News
-- Introducing our new Website
-- MX Linux on social media: here

Current releases
-- MX-18.2 Point Release release info here
-- Migration Information to MX-18 here
-- antiX-17.4.1 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

Not booting on External HDD

Help for Current Versions of MX
skidoo
Forum Guide
Forum Guide
Posts: 1262
Joined: Tue Sep 22, 2015 6:56 pm

Re: Not booting on External HDD

#11

Post by skidoo » Sat Apr 13, 2019 7:24 pm

The information given by @grelos is very valuable, as we can be sure that's not related to any BIOS-specific issues
Yes, I agree. My earlier comment was sincere, not sarcastic.

grelos
Forum Novice
Forum  Novice
Posts: 69
Joined: Wed Mar 28, 2018 3:12 pm

Re: Not booting on External HDD

#12

Post by grelos » Sun Apr 14, 2019 4:05 am

Guys, thanks you all for your support and troubleshooting help. However I have decided to give up on this. No worth the hassle as this is going to be a system seldom used.
My production machines stay with my beloved MX but I can afford using Manjaro on this external.
I have made my mind up also because I ran another test with other two external disks and the results were even more confusing.

SSD 240GB: same problem as Toshiba HDD.
HDD 320GB: Installed Mx18.2 (disk formatted GPT and Grub on MBR, so no UEFI) and booted perfectly.
MX-17 on Asus FX753VD and Lenovo 520-15IKB

grelos
Forum Novice
Forum  Novice
Posts: 69
Joined: Wed Mar 28, 2018 3:12 pm

Re: Not booting on External HDD

#13

Post by grelos » Wed Apr 17, 2019 10:00 am

Some spare time, so a new test. Got a spare 1TB HDD. Formatted msdos, not GPT.
I have installed Mx on this external HDD it through Virtualbox (safest way to install on external HDD when you want to avoid messing up the laptop bootloader). GRUB is installed on MBR.
Then I have connected it to the Dell laptop and...it boots! Well, I get first an Invalid Partition Table warning before GRUB bit hitting any key lets me go to GRUB and then MX starts up nicely.

The only thing that I changed compared to the last installations which failed was that the boot partition is FAT32 fs instead of Ext4.


EDIT: it seems Invalid Partition Table is a common warning in Dells. Still, it's just a warning. No big issue.
MX-17 on Asus FX753VD and Lenovo 520-15IKB

User avatar
fehlix
Forum Veteran
Forum Veteran
Posts: 3462
Joined: Wed Apr 11, 2018 5:09 pm

Re: Not booting on External HDD

#14

Post by fehlix » Wed Apr 17, 2019 11:33 am

grelos wrote:
Wed Apr 17, 2019 10:00 am
it seems Invalid Partition Table is a common warning in Dells. Still, it's just a warning. No big issue.
IIUC, Dell's recommended way to get rid of this issue is to do an BIOS-firmware upgrade.
Gigabyte Z77M-D3H, Intel Xeon E3-1240 V2 (Quad core), 32GB RAM,
GeForce GTX 770, Samsung SSD 850 EVO 500GB, Seagate Barracuda 4TB

Post Reply

Return to “MX Help”