Welcome!
Important information
-- Information on torrent hosting changes
-- Information on MX15/16 GPG Keys
-- Spectre and Meltdown vulnerabilities

News
-- Introducing our new Website
-- MX Linux on social media: here

Current releases
-- MX-18.1 Point Release release info here
-- Migration Information to MX-18 here
-- antiX-17.4 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

No Wifi Post-install Possible Fix

Just as the name says, here is where you can post tips and tricks to share with other users of MEPIS.
Post Reply
User avatar
j2mcgreg
Forum Regular
Forum Regular
Posts: 484
Joined: Tue Oct 23, 2007 12:04 pm

No Wifi Post-install Possible Fix

#1

Post by j2mcgreg » Mon Jan 14, 2019 3:51 pm

I have been doing some research on why wifi failed in my latest attempt to install MX18 on this Acer Aspire 3. I searched "no wifi post-install" on google which first took me to a Win 10 forum and that led me to an Acer and then Lenovo forum. Apparently, on newer Acers and Lenovos that use the InsydeH20 Set-up Utility, there is a glitch that causes Gnome to activate Airplane Mode during the install. I then searched for 'Airplane Mode Debian Stretch' which led me to this page from the Debian forums :

http://forums.debian.net/viewtopic.php?f=5&t=134115

The gist of which is:
First, as root, run:

Code: Select all

rfkill list all
then, if it shows that wireless is software blocked, as root run:

Code: Select all

rfkill unblock all
followed by:

Code: Select all

ifup wlan0
Note that it appears that setup utilities other than InsydeH2O provide the utility to disable Air Plane mode. There was talk in the lenovo forums on how to disable Air Plane mode by disabling a module in the bios.

I haven't tried this yet, but will tonight or tomorrow morning.
Acer Aspire 3 A315-41-R2W5, AMD Ryzen 5 2500U, Radeon Vega Mobile Graphics, 8 GB ram, 1000 TB hdd

User avatar
dolphin_oracle
Forum Veteran
Forum Veteran
Posts: 10889
Joined: Sun Dec 16, 2007 1:17 pm

Re: No Wifi Post-install Possible Fix

#2

Post by dolphin_oracle » Mon Jan 14, 2019 5:37 pm

reminds me of my old EEEPC904ha. when you flip the wifi off under windows, it actually changed a bios switch that survived reboots into linux. took a while to find that one.
http://www.youtube.com/runwiththedolphin
lenovo ThinkPad T530 - MX-18
lenovo s21e - MX-18, antiX-17.3.1 (live-USB)
FYI: mx "test" repo is not the same thing as debian testing repo.

Post Reply

Return to “Tips&Tricks”