Welcome!
Important information
-- Spectre and Meltdown vulnerabilities
-- Change in MX sources

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-17.1 Final release info here
-- antiX-17 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

Package request: Midori 6

Message
Author
User avatar
zorzi
Forum Regular
Forum Regular
Posts: 118
Joined: Fri Apr 20, 2018 7:41 pm

Package request: Midori 6

#1 Post by zorzi » Sat Nov 10, 2018 5:09 am

Hello,

A new Midori browser was recently released.

https://www.midori-browser.org/2018/10/ ... e-for-all/

Would it be possible to have it in MX test repo ?

Thanks

User avatar
manyroads
Forum Regular
Forum Regular
Posts: 120
Joined: Sat Jun 30, 2018 6:33 pm

Re: Package request: Midori 6

#2 Post by manyroads » Sat Nov 10, 2018 11:01 am

In the meantime have you tried getting it here?
https://pkgs.org/download/midori
Pax vobiscum,
ManyRoads (Mark Rabideau)
http://many-roads.com
Manjaro & MX Linux user
Platform: Dell Latitude E5470
CPU: Dual Core Intel i5-6300U (-MT MCP-)
Speed/min/max: 2906/400/3000 MHz
Mem: 8GB SSD: 978.09 GiB
Reg. Linux User #449130

User avatar
Jerry3904
Forum Veteran
Forum Veteran
Posts: 22637
Joined: Wed Jul 19, 2006 6:13 am

Re: Package request: Midori 6

#3 Post by Jerry3904 » Sat Nov 10, 2018 12:01 pm

I looked at that earlier, but I only see 5.11 in there.
Production: 4.15.0-1-amd64, MX-17.1, AMD FX-4130 Quad-Core, GeForce GT 630/PCIe/SSE2, 8 GB, Kingston SSD 120 GB and WesternDigital 1TB
Testing: AAO 722: 4.15.0-1-386. MX-17.1, AMD C-60 APU, 4 GB

User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 16525
Joined: Fri Dec 15, 2006 8:07 pm

Re: Package request: Midori 6

#4 Post by Stevo » Sun Nov 11, 2018 4:28 pm

I'm trying to build it--OK, got it built, installed, and running against standard Stretch packages, but...

Midori used to be not highly recommended because it used the no longer updated libwebkitgtk (security holes!), but now with the switch to libwebkit2gtk, that browser engine can be updated for security reasons. I'd like to build it against the latest libwebkit2 version that's in Debian, 2.22.2 vs 2.18.6, which also is in stretch-backports, so I'll have to do that rather heavy build first.

It's also GTK 3 now, so might look different from the older GTK 2 version, depending on how your themes are set up.

User avatar
oops
Forum Regular
Forum Regular
Posts: 406
Joined: Tue Apr 10, 2018 5:07 pm

Re: Package request: Midori 6

#5 Post by oops » Sun Nov 11, 2018 4:47 pm

Stevo wrote:
Sun Nov 11, 2018 4:28 pm
I'm trying to build it--OK, got it built, installed, and running against standard Stretch packages, but...

Midori used to be not highly recommended because it used the no longer updated libwebkitgtk (security holes!), but now with the switch to libwebkit2gtk, that browser engine can be updated for security reasons. I'd like to build it against the latest libwebkit2 version that's in Debian, 2.22.2 vs 2.18.6, which also is in stretch-backports, so I'll have to do that rather heavy build first.

It's also GTK 3 now, so might look different from the older GTK 2 version, depending on how your themes are set up.
Thank you Stevo, that's interesting ... The old Midori web browser was very light and fast, I 'm waiting to try this one now , the new v6 without the holes.
$ inxi -Fxxxz : System: Host:XEON ... Distro: MX-17.1_x64 Horizon

User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 16525
Joined: Fri Dec 15, 2006 8:07 pm

Re: Package request: Midori 6

#6 Post by Stevo » Sun Nov 11, 2018 5:46 pm

Yes, it's very fast. I'm sure we'll get a lot of discussion about it from those that like lightweight browsers once I get the packages for it and the new libwebkit2gkt up in the repo.

Building the new webkit for 64-bit with twelve threads on my six-core 12-thread laptop ended up using up all my 16 GB of RAM and about 5 GB of swap at times. I'll have to see if I can limit the number of threads used next time to prevent using swap, maybe by turning off hyperthreading.

User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 16525
Joined: Fri Dec 15, 2006 8:07 pm

Re: Package request: Midori 6

#7 Post by Stevo » Sun Nov 11, 2018 7:04 pm

Just sent it and the newer libwebkit2gtk up to the repo: https://drive.google.com/open?id=1nG8NM ... 5HC045y1fq

Since webkit has a bunch of interdependent packages, the easiest way to do a manual upgrade of that would probably be to use local-apt-repository, or just wait for them in the test repo.

User avatar
oops
Forum Regular
Forum Regular
Posts: 406
Joined: Tue Apr 10, 2018 5:07 pm

Re: Package request: Midori 6

#8 Post by oops » Mon Nov 12, 2018 4:25 am

Stevo wrote:
Sun Nov 11, 2018 7:04 pm
Just sent it and the newer libwebkit2gtk up to the repo: https://drive.google.com/open?id=1nG8NM ... 5HC045y1fq

Since webkit has a bunch of interdependent packages, the easiest way to do a manual upgrade of that would probably be to use local-apt-repository, or just wait for them in the test repo.
Great, Midori V6, still fast and my locale LANG=fr_FR.UTF-8 was set automatically.
The only issue I have, is to keep the size of the Midori windows if I reopen Midori.

Code: Select all

(midori:9780): Gtk-WARNING **: Allocating size to GtkBox 0x557dcc2529e0 without calling gtk_widget_get_preferred_width/height(). How does the code know the size to allocate?
$ inxi -Fxxxz : System: Host:XEON ... Distro: MX-17.1_x64 Horizon

User avatar
chrispop99
Forum Guide
Forum Guide
Posts: 2426
Joined: Tue Jan 27, 2009 3:07 pm

Re: Package request: Midori 6

#9 Post by chrispop99 » Mon Nov 12, 2018 6:12 am

Am I right in thinking Flash won't work with Midori?

Chris
Test machines:
32-bit non-PAE - Thinkpad T41, 1.6GHz Pentium M, 1GB RAM.
32-bit PAE - DELL Latitude D610, 1.73GHz Pentium M, 2GB RAM.
64-bit - Lenovo T61, 2GHz Core 2 Duo, 2GB RAM
64-bit - Gigabyte Z77P-D3, Intel i3-3220, GeForce 8400 GS, 4GB PC3-12800.

User avatar
oops
Forum Regular
Forum Regular
Posts: 406
Joined: Tue Apr 10, 2018 5:07 pm

Re: Package request: Midori 6

#10 Post by oops » Mon Nov 12, 2018 6:34 am

@chrispop99 ... Right, the test is KO:
https://www.adobe.com/fr/shockwave/welcome/
$ inxi -Fxxxz : System: Host:XEON ... Distro: MX-17.1_x64 Horizon

Post Reply

Return to “Package Requests/Status - MX 17”