Welcome!
Important information
-- Spectre and Meltdown vulnerabilities
-- Change in MX sources

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-17.1 Final release info here
-- antiX-17 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

Suspend after close lid not locking screen on wakeup

Help for Current Versions of MX
Post Reply
Message
Author
User avatar
forliberty
Forum Novice
Forum  Novice
Posts: 3
Joined: Fri Sep 14, 2018 8:05 am

Suspend after close lid not locking screen on wakeup

#1 Post by forliberty » Sun Sep 16, 2018 10:20 am

Longtime Linux user, noob to MX. System is not locking screen after resume from suspend due to lid close. System DOES lock screen if (1) the suspend is initiated manually by pressing the Suspend button or (2) suspend due to inactivity. This is a critical security issue for me. I have set the system to lock the screen when the system goes into suspend. Tried the fix suggested in this post, as I too have Intel graphics, but no improvement: http://forum.mxlinux.org/viewtopic.php?t=44692

Here is the output of inxi -Fxz:

Code: Select all

System:    Host: espada Kernel: 4.15.0-1-amd64 x86_64 bits: 64 compiler: gcc v: 6.3.0 
           Desktop: Xfce 4.12.3 tk: Gtk 2.24.31 Distro: MX-17.1_x64 Horizon March 14, 2018 
Machine:   Type: Laptop System: Acer product: Aspire A515-51 v: V1.02 serial: <filter> 
           Mobo: KBL model: Charmander_KL v: V1.02 serial: <filter> UEFI: Insyde v: 1.02 
           date: 04/14/2017 
Battery:   ID-1: BAT1 charge: 46.8 Wh condition: 49.0/48.9 Wh (100%) model: COMPAL PABAS0241231 
           status: Charging 
CPU:       Topology: Dual Core model: Intel Core i3-7100U bits: 64 type: MT MCP arch: Kaby Lake 
           rev: 9 L2 cache: 3072 KiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 19200 
           Speed: 852 MHz min/max: 400/2400 MHz Core speeds (MHz): 1: 788 2: 795 3: 807 4: 822 
Graphics:  Card-1: Intel driver: i915 v: kernel bus ID: 00:02.0 
           Display: x11 server: X.Org 1.19.2 driver: intel resolution: 1920x1080~60Hz 
           OpenGL: renderer: Mesa DRI Intel HD Graphics 620 (Kabylake GT2) v: 4.5 Mesa 13.0.6 
           direct render: Yes 
Audio:     Card-1: Intel driver: snd_hda_intel v: kernel bus ID: 00:1f.3 
           Sound Server: ALSA v: k4.15.0-1-amd64 
Network:   Card-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8169 
           v: 2.3LK-NAPI port: 3000 bus ID: 01:00.1 
           IF: eth0 state: down mac: <filter> 
           Card-2: Intel driver: iwlwifi v: kernel port: N/A bus ID: 02:00.0 
           IF: wlan0 state: up mac: <filter> 
Drives:    HDD Total Size: 931.51 GiB used: 5.21 GiB (0.6%) 
           ID-1: /dev/sda vendor: Western Digital model: WD10SPZX-21Z10T0 size: 931.51 GiB 
Partition: ID-1: / size: 575.74 GiB used: 5.16 GiB (0.9%) fs: ext4 dev: /dev/sda5 
           ID-2: swap-1 size: 17.58 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/dm-0 
Sensors:   System Temperatures: cpu: 29.8 C mobo: 27.8 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 270 Uptime: 4m Memory: 7.68 GiB used: 1.20 GiB (15.6%) Init: SysVinit 
           runlevel: 5 Compilers: gcc: 6.3.0 Shell: bash v: 4.4.12 inxi: 3.0.10 
Just for ease of reference, so folks don't have to dig through other threads, here is the fix that I tried:

Make this text file
/etc/X11/xorg.conf.d/20-intel.conf
with this content:

Code: Select all

Section "Device"
   Identifier  "Intel Graphics"
   Driver      "intel"
   Option      "TearFree"     "true"
EndSection
Interestingly, this DID fix a screen tearing problem that I had.

Thanks!

Post Reply

Return to “MX Help”