The kernel problem with recent updates has been solved. Find the solution here

Important information
-- Required MX 15/16 Repository Changes
-- Information on torrent hosting changes
-- Information on MX15/16 GPG Keys
-- Spectre and Meltdown vulnerabilities

-- Introducing our new Website
-- MX Linux on social media: here

Current releases
-- MX-18.3 Point Release release info here
-- Migration Information to MX-18 here
-- antiX-17.4.1 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

dpkg: error processing archive ?(SOLVED)

Help for Current Versions of MX
Post Reply
Forum Novice
Forum  Novice
Posts: 15
Joined: Mon Aug 14, 2017 9:58 pm

dpkg: error processing archive ?(SOLVED)


Post by tbuser48 » Thu Sep 13, 2018 9:58 pm

This has been going on for a week??? Tried to give it time to go away from another upgrade/update. The "(" is a typo possibly?

Trying to clean it up so I can sync both drives.


Jeff (I'll work on compressing the data) :bagoverhead:
System: Host: mx54 Kernel: 4.15.0-1-amd64 x86_64 bits: 64 Desktop: Xfce 4.12.3
Distro: MX-17.1_x64 Horizon December 15 2017
Machine: Type: Laptop System: Panasonic product: CF-54-2 v: 002 serial: <root required>
Mobo: Panasonic model: CF54-2 v: 1 serial: <root required>
UEFI [Legacy]: American Megatrends v: 2.00L18 date: 05/11/2017
Battery: ID-1: BAT1 charge: 15.0 Wh condition: 43.1/45.3 Wh (95%)
CPU: Topology: Dual Core model: Intel Core i5-6300U bits: 64 type: MT MCP
L2 cache: 3072 KiB
Speed: 725 MHz min/max: 400/3000 MHz Core speeds (MHz): 1: 500 2: 500 3: 500 4: 501
Graphics: Device-1: Intel HD Graphics 520 driver: i915 v: kernel
Display: x11 server: X.Org 1.19.2 driver: modesetting unloaded: fbdev,vesa
resolution: 1360x768~60Hz
OpenGL: renderer: Mesa DRI Intel HD Graphics 520 (Skylake GT2) v: 4.5 Mesa 13.0.6
Audio: Device-1: Intel Sunrise Point-LP HD Audio driver: snd_hda_intel
Sound Server: ALSA v: k4.15.0-1-amd64
Network: Device-1: Intel Ethernet I219-LM driver: e1000e
IF: eth0 state: down mac: bc:c3:42:8d:c3:e1
Device-2: Intel Wireless 8260 driver: iwlwifi
IF: wlan0 state: up mac: e4:a7:a0:07:3e:f6
Drives: Local Storage: total: 357.72 GiB used: 11.90 GiB (3.3%)
ID-1: /dev/sda vendor: Samsung model: SSD PM830 2.5 7mm 128GB size: 119.24 GiB
ID-2: /dev/sdb vendor: Intel model: SSDSCKKF256H6L size: 238.47 GiB
Partition: ID-1: / size: 114.87 GiB used: 11.90 GiB (10.4%) fs: ext4 dev: /dev/sda1
ID-2: swap-1 size: 2.00 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda2
Sensors: System Temperatures: cpu: 39.5 C mobo: 39.5 C
Fan Speeds (RPM): N/A
Repos: Active apt repos in: /etc/apt/sources.list.d/antix.list
1: deb http://iso.mxrepo.com/antix/stretch stretch main
Active apt repos in: /etc/apt/sources.list.d/debian-stable-updates.list
1: deb http://ftp.us.debian.org/debian/ stretch-updates main contrib non-free
Active apt repos in: /etc/apt/sources.list.d/debian.list
1: deb http://ftp.us.debian.org/debian/ stretch main contrib non-free
2: deb http://security.debian.org/ stretch/updates main contrib non-free
Active apt repos in: /etc/apt/sources.list.d/google-chrome.list
1: deb [arch=amd64] http://dl.google.com/linux/chrome/deb/ stable main
Active apt repos in: /etc/apt/sources.list.d/mx.list
1: deb http://iso.mxrepo.com/mx/repo/ stretch main non-free
No active apt repos in: /etc/apt/sources.list.d/various.list
Info: Processes: 208 Uptime: 15m Memory: 7.69 GiB used: 833.0 MiB (10.6%) Shell: init
inxi: 3.0.24

Error is here. :confused:
full upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
The following packages will be upgraded:
mx-live-usb-maker (18.7 => 18.8.3)
1 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
24 not fully installed or removed.
Need to get 0 B/65.6 kB of archives.
After this operation, 34.8 kB of additional disk space will be used.
(Reading database ... 426051 files and directories currently installed.)
Preparing to unpack .../mx-live-usb-maker_18.8.3_amd64.deb ...
Unpacking mx-live-usb-maker (18.8.3) over (18.7) ...
dpkg: error processing archive /var/cache/apt/archives/mx-live-usb-maker_18.8.3_amd64.deb (--unpack):
trying to overwrite '/usr/share/pixmaps/drive-removable-media-usb.svg', which is also in package mx-live-usb-gui 0.2.9mx150+5
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

full upgrade complete (or was canceled)

this terminal window can now be closed (press any key to close)
Last edited by tbuser48 on Thu Sep 13, 2018 10:25 pm, edited 1 time in total.

User avatar
Forum Veteran
Forum Veteran
Posts: 11826
Joined: Sun Dec 16, 2007 1:17 pm

Re: dpkg: error processing archive ?


Post by dolphin_oracle » Thu Sep 13, 2018 10:08 pm

remove mx-live-usb-gui.

its been deprecated for some time now, and shouldn't be installed.
lenovo ThinkPad T530 - MX-18.3
lenovo s21e - antiX-19 beta 2 (live-USB)
FYI: mx "test" repo is not the same thing as debian testing repo.

Forum Novice
Forum  Novice
Posts: 15
Joined: Mon Aug 14, 2017 9:58 pm

Re: dpkg: error processing archive ?


Post by tbuser48 » Thu Sep 13, 2018 10:24 pm

Thanks for the rapid response and Hey! Presto! it is fixed. :number1:

Let me see if I remember how to mark it solved.

Post Reply

Return to “MX Help”