Welcome!
Important information
-- Spectre and Meltdown vulnerabilities
-- Change in MX sources

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-17.1 Final release info here
-- antiX-17 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

Login password Problem with "é" letters

Post Reply
Message
Author
zorzi
Forum Novice
Forum  Novice
Posts: 54
Joined: Fri Apr 20, 2018 7:41 pm

Login password Problem with "é" letters

#1 Post by zorzi » Fri Jul 06, 2018 6:46 am

Hello,

I have some trouble with Antix 17.1.

Installation is going well. But, though I can create my password (it contains two "é" letters) without problem during installation, I can't login after reboot, I can't insert/type "é" letters. So I can't reach my session.

If someone can help.

Thanks.

User avatar
anticapitalista
Forum Veteran
Forum Veteran
Posts: 5651
Joined: Sat Jul 15, 2006 10:40 am

Re: Login password Problem with "é" letters

#2 Post by anticapitalista » Fri Jul 06, 2018 6:58 am

antiX uses slim login manager that doesn't do such characters. Best bet is to change the password to one using 'regular' letters.
At boot screen, type 3, login at the console as root the type

Code: Select all

passwd user
(where user is the username for the password you are changing). The system will prompt you to enter a password. Passwords do not echo to the screen when you enter them.
anticapitalista
Reg. linux user #395339.

Philosophers have interpreted the world in many ways; the point is to change it.

antiX-17 "Heather Heyer" - lean and mean.
https://antixlinux.com

User avatar
cyrilus31
Forum Regular
Forum Regular
Posts: 546
Joined: Thu Nov 03, 2016 3:24 pm

Re: Login password Problem with "é" letters

#3 Post by cyrilus31 » Fri Jul 06, 2018 7:50 am

I found that on Archlinux Wiki
Problème d'identification
Si votre mot de passe comprend des caractères non-ascii (é, è, ç, à, etc.) et que la locale de votre système est en unicode (fr_FR.UTF-8 par exemple), vous ne pourrez pas vous connecter à votre session avec le SLiM du dépôt officiel (bugs relevés sur Debian, bug#532060 et sur Arch, bug#18338 et bug#18339 ).

Mais une version corrigée disponible sur AUR apporte le support de l'unicode et résout ce problème: slim-unicode.
Don't know if it's relevant for antiX, but just in case.

And whenever it is possible I avoid é, in files names, passwords and so on.

zorzi
Forum Novice
Forum  Novice
Posts: 54
Joined: Fri Apr 20, 2018 7:41 pm

Re: Login password Problem with "é" letters

#4 Post by zorzi » Fri Jul 06, 2018 1:15 pm

Thanks for answering. I see two options now.

- Use regular letters in my password
- Replace SLim with Lightdm

User avatar
Richard
Posts: 1839
Joined: Fri Dec 12, 2008 10:31 am

Re: Login password Problem with "é" letters

#5 Post by Richard » Fri Jul 06, 2018 11:55 pm

Check on LightDM before you replace Slim.
I think the problem is that only US keyboard characters are recognized
before the local keyboard table is loaded.

This may help: https://unix.stackexchange.com/question ... in-lightdm
The easy way is to use chars in the US keyboard for passwords.
MX17.1____: T430-2017, 8 GB RAM, 4.17.0-1-amd64 x86_64, 119 SSD
antiX-/MX-171: AA1/Eee, 1 GB RAM, 4.15.0-1-686-pae, 149 HDD
DC9, LibO605, Dropbox, FF61, FFesr, mPDFed, Py3, CherryT, Vbox
linux counter #288562

zorzi
Forum Novice
Forum  Novice
Posts: 54
Joined: Fri Apr 20, 2018 7:41 pm

Re: Login password Problem with "é" letters

#6 Post by zorzi » Sat Jul 07, 2018 4:50 am

Richard wrote:
Fri Jul 06, 2018 11:55 pm
Check on LightDM before you replace Slim.
I think the problem is that only US keyboard characters are recognized
before the local keyboard table is loaded.

This may help: https://unix.stackexchange.com/question ... in-lightdm
The easy way is to use chars in the US keyboard for passwords.
After trying with lightdm, I can type my usual password with "é" letters. But desktop background does not appear. Well, I guess it's wiser to keep Slim and forget about password with special letters.

Thanks to everyone

skidoo
Forum Regular
Forum Regular
Posts: 828
Joined: Tue Sep 22, 2015 6:56 pm

Re: Login password Problem with "é" letters

#7 Post by skidoo » Sat Jul 07, 2018 2:21 pm

An updated version of SLiM available from https://gitlab.com/skidoo/slim-antix supports UTF8 strings in the onscreen welcome messages (tested) and it might support (zero tester feedback to date) UTF8 characters in the username / password input fields.

If you care to test & have a 64-bit system, can download slim_1.4.4_amd64.deb and
sudo dpkg -i slim_1.4.4_amd64.deb
note: After installing, a shutdown/restart is required to invoke the newly-installed SLiM version.

User avatar
cyrilus31
Forum Regular
Forum Regular
Posts: 546
Joined: Thu Nov 03, 2016 3:24 pm

Re: Login password Problem with "é" letters

#8 Post by cyrilus31 » Sun Jul 08, 2018 4:33 am

Skidoo to the rescue :number1:
Worth a try.

Post Reply

Return to “antiX”