Important information
-- Required MX 15/16 Repository Changes
-- Information on torrent hosting changes
-- Information on MX15/16 GPG Keys
-- Spectre and Meltdown vulnerabilities

-- Introducing our new Website
-- MX Linux on social media: here

Current releases
-- MX-18.2 Point Release release info here
-- Migration Information to MX-18 here
-- antiX-17.4.1 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

Swap Partiton not matching RAM size after install

Report Bugs, Issues and non- pacakage Requests
Post Reply
Forum Novice
Forum  Novice
Posts: 20
Joined: Sun Nov 26, 2017 9:51 pm

Swap Partiton not matching RAM size after install


Post by kb50 » Sat Jan 13, 2018 4:14 pm

I noticed that the Installer of MX-17 Horizon when told to use entire disk, for installation, is not setting the swap partition to match RAM size.
It seems to want to format it to 2.0 GB in size. My system, however, has 12 GB of Ram out of a possible 24, (Triple Channel Memory 6 slots, Core I7 HP) Pegatron motherboard).

So I know I can use Gparted to shrink the main partition, and then delete swap and create a new one, but shouldn't Installer have done that for you?

While this may not present a problem unless you Hibernate, it is a potential problem, that should be addressed, or corrected.
It would also perhaps be a bottleneck if you were running a lot of applications at once.

User avatar
Forum Veteran
Forum Veteran
Posts: 18784
Joined: Fri Dec 15, 2006 8:07 pm

Re: Swap Partiton not matching RAM size after install


Post by Stevo » Sat Jan 13, 2018 4:21 pm

It does not have to match the swap size. I get by fine with a 3 GB swap on a 8 GB system, but I make sure I'm not using more than 3 GB memory before hibernation. Ram is compressed before it swapped to a hibernation file, too, but I think you would be cramped with a 2 GB partition, myself...have you had any hibernation failures yet?

Post Reply

Return to “Bugs and Non-Package Requests Forum”