Welcome!
Important information
-- Spectre and Meltdown vulnerabilities
-- Change in MX sources

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-17.1 Final release info here
-- antiX-17 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

MX Printer Setup Excellent

Here is where users who have been using MEPIS awhile and know the basics of linux and MEPIS can ask questions.
Post Reply
Message
Author
User avatar
KBD
Forum Regular
Forum Regular
Posts: 861
Joined: Sun Jul 03, 2011 7:52 pm

MX Printer Setup Excellent

#1 Post by KBD » Thu Apr 20, 2017 3:55 pm

Trying to setup my HP printer in Debian is a pain. In Ubuntu it automatically detects it. It was a pleasure setting it up in MX 16 taking maybe 2 minutes from start to printing a test page.
Great job guys. I continue to be impressed with your fine work!

User avatar
ptlivestock
Forum Novice
Forum  Novice
Posts: 83
Joined: Sat Jul 06, 2013 6:28 pm

Re: MX Printer Setup Excellent

#2 Post by ptlivestock » Thu Apr 20, 2017 4:58 pm

In my case of moving from Mepis 11 to MX-16 all I did as install the MX-16 and press print on various spreadsheets, text files etc previously compiled on Mepis11. They printed straight off without any printer setup. I guess the OS picked up the printer when being installed.

Regards

User avatar
KBD
Forum Regular
Forum Regular
Posts: 861
Joined: Sun Jul 03, 2011 7:52 pm

Re: MX Printer Setup Excellent

#3 Post by KBD » Thu Apr 20, 2017 5:15 pm

ptlivestock wrote:In my case of moving from Mepis 11 to MX-16 all I did as install the MX-16 and press print on various spreadsheets, text files etc previously compiled on Mepis11. They printed straight off without any printer setup. I guess the OS picked up the printer when being installed.

Regards
That's great!

Toastrack
Forum Regular
Forum Regular
Posts: 194
Joined: Thu Jan 13, 2011 1:09 pm

Re: MX Printer Setup Excellent

#4 Post by Toastrack » Wed May 17, 2017 11:59 am

I have found just the opposite! Installed MX16 64 bit in place of 32 bit, and cannot get any printers to print at all. I keep getting the message "Unable to ocate printer", even though the systm has found it.
Now I am totally at a loss.

User avatar
asqwerth
Forum Guide
Forum Guide
Posts: 2779
Joined: Sun May 27, 2007 5:37 am

Re: MX Printer Setup Excellent

#5 Post by asqwerth » Wed May 17, 2017 12:20 pm

Toastrack wrote:I have found just the opposite! Installed MX16 64 bit in place of 32 bit, and cannot get any printers to print at all. I keep getting the message "Unable to ocate printer", even though the systm has found it.
Now I am totally at a loss.
If yours is a network printer, have you tried in the Printer Settings to change "Device URI" to the IP address rather than whatever was autodetected? I found that sometime between MX14 and MX15, something changed .
Screenshot from 2017-05-18 00-16-57.png
You do not have the required permissions to view the files attached to this post.
Desktop: Intel i5-4460, 16GB RAM, Intel integrated graphics
Clevo N130WU-based Ultrabook: Intel i7-8550U (Kaby Lake R), 16GB RAM, Intel integrated graphics (UEFI)
ASUS X42D laptop: AMD Phenom II, 6GB RAM, Mobility Radeon HD 5400

Toastrack
Forum Regular
Forum Regular
Posts: 194
Joined: Thu Jan 13, 2011 1:09 pm

Re: MX Printer Setup Excellent

#6 Post by Toastrack » Fri May 19, 2017 12:33 pm

I'm inclined to leave this post for now, with thanks to all who offered help.

I suspect the fact of the other printers being switched off during the installation might be relevant, and since there are other oddities which might be related I have decided to do a complete clean re-install before I spend too much time on personalisation.
That way I have a good chance that I'm starting with a good OS.

Post Reply

Return to “Regulars”