Welcome!
Important information
-- Spectre and Meltdown vulnerabilities
-- Change in MX sources

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-17.1 Final release info here
-- antiX-17 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

gpsbabel request

For Community Repository Package Requests and Status for MX-14
Message
Author
tom13
Forum Novice
Forum  Novice
Posts: 24
Joined: Thu Apr 28, 2016 11:08 am

Re: gpsbabel request

#11 Post by tom13 » Wed Feb 14, 2018 2:10 pm

yes Tim,I have gpsbabel package installed,only it doesn't seem to recognize my Garmin...I'm sure that I'm missing something in settings,because when I do this

Code: Select all

$ lsmod | grep garmin
garmin_gps             17253  0 
usbserial              31597  1 garmin_gps
usbcore               171098  8 uhci_hcd,rt2x00usb,usbserial,rt2800usb,ehci_hcd,ehci_pci,usbhid,garmin_gps
it seems that gps device has been properly connected?

tom13
Forum Novice
Forum  Novice
Posts: 24
Joined: Thu Apr 28, 2016 11:08 am

Re: gpsbabel request

#12 Post by tom13 » Fri Feb 16, 2018 8:25 am

This time I only wish to thank you Tim and Stevo for your time and your wish to help me.I still don't have gpsbabel working,I've tried all of terminal commands that I found on internet though.Pc does recognize my Garmin,but all I have from gpsbabel is

Code: Select all

gpsbabel -w -i garmin -f /dev/ttyS0 -o garmin_poi -F /home/tom/Desktop/garmin output
[ERROR] GPS_Packet_Read: Timeout.  No data received.
GARMIN:Can't init /dev/ttyS0

Error running gpsbabel: Process exited unsucessfully with code 1
At this point I will have to stop,and wait for some better time :-)

User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 16582
Joined: Fri Dec 15, 2006 8:07 pm

Re: gpsbabel request

#13 Post by Stevo » Fri Feb 16, 2018 3:40 pm

Shoot...does the standard Debian version manage to recognize your Garmin?

tom13
Forum Novice
Forum  Novice
Posts: 24
Joined: Thu Apr 28, 2016 11:08 am

Re: gpsbabel request

#14 Post by tom13 » Sat Feb 17, 2018 8:21 am

Thanks Stevo,I'm not quite sure if I understand what it means "standard Debian version",but commands that I run such as lsusb and dmesg,I can see my Garmin as recognized.I also fixed permissions in accordance to Gpsbabel's site info.But I've noticed that gpsbabel doesn't create any file,it seems that it tries to read device,but there's no file created afterwards.This is what I get every time:

Code: Select all

gpsbabel -w -i garmin -f usb: -o garmin_poi -F /home/tom/Desktop/garminout
Found no Garmin USB devices.

Error running gpsbabel: Process exited unsucessfully with code 1
I also blacklisted garmin_gps in the file etc/modprobe.d/fbdev-blacklist.conf

Code: Select all

# prevent garmin_gps from being loaded
blacklist garmin_gps
Should I create blacklist.conf file instead?Is fbdev-blacklist.conf the right place to do it?

tom13
Forum Novice
Forum  Novice
Posts: 24
Joined: Thu Apr 28, 2016 11:08 am

Re: gpsbabel request

#15 Post by tom13 » Sat Feb 17, 2018 9:04 am

ok,the output file has been created,this is what I get:00.00000,00.00000,Position,Position

tom13
Forum Novice
Forum  Novice
Posts: 24
Joined: Thu Apr 28, 2016 11:08 am

Re: gpsbabel request

#16 Post by tom13 » Mon Feb 19, 2018 3:31 pm

Now I get .gpi file and gpsbabel message

Code: Select all

gpsbabel -w -i garmin,snlen=1,snwhite=1,deficon=,get_posn=1,power_off=1,erase_t=1,resettime=1,category=1,bitscategory=1 -f /dev/ttyS0 -o garmin_gpi,unique=1 -F /home/tom/Desktop/garminout.gpi
[ERROR] GPS_Packet_Read: Timeout.  No data received.

Translation successful
I do have one track saved for testing,but still something's not right.And what to do with this .gpi file,how to open it in case of successful transfer?

User avatar
asqwerth
Forum Veteran
Forum Veteran
Posts: 3459
Joined: Sun May 27, 2007 5:37 am

Re: gpsbabel request

#17 Post by asqwerth » Wed Feb 21, 2018 10:27 am

He posted this in the MX14 package request thread.

Stevo, you've been referring to MX15/16?
Desktop: Intel i5-4460, 16GB RAM, Intel integrated graphics
Clevo N130WU-based Ultrabook: Intel i7-8550U (Kaby Lake R), 16GB RAM, Intel integrated graphics (UEFI)
ASUS X42D laptop: AMD Phenom II, 6GB RAM, Mobility Radeon HD 5400

tom13
Forum Novice
Forum  Novice
Posts: 24
Joined: Thu Apr 28, 2016 11:08 am

Re: gpsbabel request

#18 Post by tom13 » Wed Feb 28, 2018 3:01 pm

I'm still trying to get gpsbabel working with my garmin,but all I get as output are zeros for both,longitude and latitude.Any output I choose,same thing.Any idea?It could be that I'm on the wrong forum too?Please direct me,thanks.

Post Reply

Return to “Package Requests/Status - MX-14”