Welcome!

The kernel problem with recent updates has been solved. Find the solution here

Important information
-- Required MX 15/16 Repository Changes
-- Information on torrent hosting changes
-- Information on MX15/16 GPG Keys
-- Spectre and Meltdown vulnerabilities

News
-- Introducing our new Website
-- MX Linux on social media: here

Current releases
-- MX-18.3 Point Release release info here
-- Migration Information to MX-18 here
-- antiX-17.4.1 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

I need more partitions!

Mich-C
Forum Novice
Forum  Novice
Posts: 78
Joined: Tue Nov 21, 2017 1:11 pm

UPDATE: just read this post

#11

Post by Mich-C » Fri Jan 11, 2019 9:44 am

QUICK RECAP:
timkb4cq wrote:
Thu Oct 18, 2018 2:07 pm
There is no way to convert an extended partition to a primary partition or vice versa without losing all the data. You have to remove the partition and remake it.
Hi Tim! Actually it's possible to do this without losing data. You just need a tool like Mini Tool Partition Wizard (you can use it on Windows or you can use the bootable version). I've converted a partion from extended to primary using Minitool even on Windows and it worked perfectly! :happy:
wrote: Do you know if 7 is able to boot on GPT and UEFI
I've finally undertood that Win7 32 bits just support mbr disks+ bios, while Win7 x64 support also gpt disk + uefi.
The problem is that Win7 always "force" itself to boot in bios uefi. To be sure to boot it in uefi mode you have to "start" the "bootx64.efi" file that it's present in the iso. (Very often it's "hidden" in some sub-directory of the iso or you have to extract it from the .wim file)

So, finally I reinstalled MX18 in pure uefi mode alongside win7 on my GPT disk.
I created a fat32 Efi partition with the "boot" and "esp" flags and I used the MX installer to install grub on this partition.
Booting MX manually selecting "bootx64.efi" works, but when I try to boot the computer "normally" I get this :confused:
No bootable image found, notebook will be shutdown

Post Reply

Return to “Installation”