Welcome!

The kernel problem with recent updates has been solved. Find the solution here

Important information
-- Required MX 15/16 Repository Changes
-- Information on torrent hosting changes
-- Information on MX15/16 GPG Keys
-- Spectre and Meltdown vulnerabilities

News
-- Introducing our new Website
-- MX Linux on social media: here

Current releases
-- MX-18.3 Point Release release info here
-- Migration Information to MX-18 here
-- antiX-17.4.1 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

CPU speed problem

User avatar
sanlav
Forum Novice
Forum  Novice
Posts: 89
Joined: Sun Feb 03, 2008 10:03 pm

Re: CPU speed problem

#11

Post by sanlav » Sun Jan 06, 2019 8:18 am

Or you can try my solution in rc.local . At the end add :

echo 0 > /sys/devices/system/cpu/intel_pstate/no_turbo
echo performance > /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor
echo performance > /sys/devices/system/cpu/cpu1/cpufreq/scaling_governor
# echo performance > /sys/devices/system/cpu/cpu2/cpufreq/scaling_governor
# echo performance > /sys/devices/system/cpu/cpu3/cpufreq/scaling_governor

It seems you have only 2 CPU's.

User avatar
Richard
Posts: 2804
Joined: Fri Dec 12, 2008 10:31 am

Re: CPU speed problem

#12

Post by Richard » Sun Jan 06, 2019 8:30 am

Just to clarify, I read over the thread but not sure if you have enabled intel_pstate.
My /etc/default/grub looks like this at the top of the file:

Code: Select all

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_TIMEOUT=2
GRUB_DISTRIBUTOR=`lsb_release -s -d 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet intel_pstate=enable"
GRUB_CMDLINE_LINUX=""
Change to "intel_pstate=disable" to turn it off. Remember to run "update-grub" if you modify /etc/default/grub.
Enabled slows down to help control overheating when snapshooting --my problem.
LT: MX18.3: Thinkpad T430: DualCore, Intel i5-3320M, Ivy Bridge; 8GB RAM; 4.19.0-5-amd64; 119GB SSD 840PRO, Intel Graphics-Audio-Network

NB: antiX19b2full-xfce; MX18.3: AsusTek EeePC 1005HA: Intel DualCore Atom N270, 1GB RAM, 4.19.0-1-686, 150GB HDD

User avatar
Stevo
Developer
Posts: 19875
Joined: Fri Dec 15, 2006 8:07 pm

Re: CPU speed problem

#13

Post by Stevo » Sun Jan 06, 2019 6:28 pm

The 4.15 MX kernel runs p_state for default for recent Intel processors, but yours seems to be too old to support that...

Maybe you could uninstall tlp and reboot to see if that makes any difference.

Your BIOS also may have a setting to enable or disable turbo mode on the CPU, so that would would be worth a look.

lalix
Forum Novice
Forum  Novice
Posts: 9
Joined: Fri Jan 04, 2019 7:04 am

Re: CPU speed problem

#14

Post by lalix » Mon Jan 07, 2019 11:55 am

There must be some kind of general failure. I tried all your suggestions, without success. Then I got angry, so I installed several other distros to see how they handle the cpu. Well, recent Fedora, Manjaro, Vector, openSuse, BunsenLabs shows the same cpu freq of 997Mz whatever I do. However I did'nt tried any Ubuntu based distro, I suppose the same result.
Lenovo T60 - Intel Core 2 T5500, Intel Mobile 945GM, 2.5GB RAM, 60GB HDD
MX 17.1 -> MX-18 Continuum March

User avatar
baldyeti
Forum Regular
Forum Regular
Posts: 214
Joined: Sat Dec 05, 2009 4:37 pm

Re: CPU speed problem

#15

Post by baldyeti » Mon Jan 07, 2019 12:07 pm

I would check the BIOS for fixed frequency multiplier (10 i/o 16), "Enable Turbo Mode" as suggested by Stevo and perhaps "Enable EIST" (intel SpeedStep)

lalix
Forum Novice
Forum  Novice
Posts: 9
Joined: Fri Jan 04, 2019 7:04 am

Re: CPU speed problem

#16

Post by lalix » Mon Jan 07, 2019 3:18 pm

As an absolute GUI user, the BIOS was my first step, belive me :) There is everything okay.
Actually I don't know if the problem was also there before, because that time there was only 512MB RAM inside and I didn't try to wach films. The only time I can remember when it was really running 1,66GHz, was in the time of Windows XP.
Lenovo T60 - Intel Core 2 T5500, Intel Mobile 945GM, 2.5GB RAM, 60GB HDD
MX 17.1 -> MX-18 Continuum March

linuxsociety
Forum Novice
Forum  Novice
Posts: 6
Joined: Wed Jan 16, 2019 5:23 am

Re: CPU speed problem

#17

Post by linuxsociety » Wed Jan 16, 2019 5:49 am

I'm new to the forum and just recently picked up MX myself. Don't let that fool you as I have been an experienced Linux User for over 25 years now. I noticed your post and just wanted to try to provide a little support since the Thinkpad T60 is still one of my favorite laptops ever.

You should be using cpufrequtils pkg which provides cpufreq-info and cpufreq-set. Set your bios back to stock settings first if you haven't already done so. Disabling speedstep /dynamic cpu frequency settings in the bios will either get you a stuck minimum Mhz or a stuck Maximum.

cpufreq-info will tell you the current cpufreq and the active cpufreq governor in use. Take note if it is ondemand, performance, or powersave.

If you are unable to use cpufreq-info or it doesn't spit out any useful information, then I will ask have you tinkered with a custom kernel?

If cpufreq-info does in fact spit out the governor in use and the scaling frequencies, then be sure you remember what governor it specifies for each cpu/core. You probably want it to be ondemand, but you may also desire the performance governor as well. Not too many people opt for the powersave governor due to its default settings being quite lazy at increasing the freq while under heavy load.

Manually change the governor by issuing the following command:

Code: Select all

sudo cpufreq-set -c0 -g performance;sudo cpufreq-set -c1 -g performance
Be sure you issue the command for both cores (-c switch in the above command indicates the core for which you are setting)

Verify that you have the maximum frequency by running the following two commands:

Code: Select all

cat /proc/cpuinfo
and

Code: Select all

cpufreq-info
Reboot if this makes it show the desired frequency. Run the above two commands again and see if you are back to square 1. You should be as you didn't make anything permanent yet. If you get this far with success, I'll be glad to help you make this change permanent :)

Post Reply

Return to “Hardware /Configuration”