Welcome!
Important information
-- Spectre and Meltdown vulnerabilities
-- Change in MX sources

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-17.1 Final release info here
-- antiX-17 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

Solved - updated 12july2018 - laptop wont boot - again

Message
Author
gonzo01
Forum Novice
Forum  Novice
Posts: 28
Joined: Tue Jul 11, 2017 11:27 pm

Solved - updated 12july2018 - laptop wont boot - again

#1 Post by gonzo01 » Tue Jun 05, 2018 11:02 pm

$ inxi -N
Network: Card-1: Intel Device 24fb driver: iwlwifi
Card-2: Qualcomm Atheros Killer E2400 Gigabit Ethernet Controller driver: alx
bill@laptop:~

have tried rebooting laptop/modem-router - my network still is not autodiscovered though neighbours wifi are listed.

laptop info from carton

msi Gaming Notebook
GF62 7RD - 1806AU
CPU INTEL CORE i7-7700HQ
NVIDIA GeForce GTX10504gb GDDR5
WLAN+BT COMBO MODULE

more problems with this laptop since latest updates (yesterday)

boots to login screen but after entering password nothing further.

Booting from Live distro (17.3 - without latest updates) same except I can boot via FAILSAFE from boot menu - cant get this option from SSD install

Apart from re-install, how can I get SSD boot option for FAILSAFe mode?

Also, where is boot log located on SSD install?

Thanks
Last edited by gonzo01 on Thu Jul 12, 2018 1:09 am, edited 3 times in total.

User avatar
rich
Forum Regular
Forum Regular
Posts: 287
Joined: Sat Mar 31, 2018 6:39 pm

Re: laptop wont boot - again

#2 Post by rich » Wed Jun 06, 2018 1:01 am

Hi, sorry to hear you're having a bit of trouble!
gonzo01 wrote:
Tue Jun 05, 2018 11:02 pm
Apart from re-install, how can I get SSD boot option for FAILSAFe mode?
At grub menu, press e to edit entry and append " xorg=safe load=all" to kernel parameters. Press Ctrl+x to continue
pic.jpg
https://mxlinux.org/wiki/system/boot-pa ... %20Modules
gonzo01 wrote:
Tue Jun 05, 2018 11:02 pm
Also, where is boot log located on SSD install?
/var/log/dmesg, usually viewed as root with the command

Code: Select all

dmesg
You do not have the required permissions to view the files attached to this post.
MX 17.1 Dell Inspiron N5110

User avatar
Jerry3904
Forum Veteran
Forum Veteran
Posts: 21915
Joined: Wed Jul 19, 2006 6:13 am

Re: laptop wont boot - again

#3 Post by Jerry3904 » Wed Jun 06, 2018 4:47 am

What kernel are you using?

Code: Select all

inxi -S
Stevo will be on later and I think he is using the same (or a similar) laptop and has gone to a kernel that works pretty well.
Production: 4.15.0-1-amd64, MX-17.1, AMD FX-4130 Quad-Core, GeForce GT 630/PCIe/SSE2, 8 GB, Kingston SSD 120 GB and WesternDigital 1TB
Testing: AAO 722: 4.15.0-1-386. MX-17.1, AMD C-60 APU, 4 GB

User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 15774
Joined: Fri Dec 15, 2006 8:07 pm

Re: laptop wont boot - again

#4 Post by Stevo » Wed Jun 06, 2018 1:55 pm

Yes, but that's the previous generation laptop, and I would have thought that the 4.15 kernel is doing good enough.

Have you checked to see if there are any BIOS updates available on the MSI support page? You can just extract the zip, put on a flash drive, and update from within the BIOS setup. "inxi -M" will tell you the UEFI (BIOS) version if you can get it booted with a kernel cheat.

If the BIOS has the drives set to RAID, see if you can change them to AHCI. I assume you have already disabled Secure Boot in the setup.

There are a lot of Ubuntu threads with MSI magic kernel cheats mentioned, also; here's a start: https://ubuntuforums.org/showthread.php?t=2365997

Possibly you just need the "nomodeset" boot cheat...

User avatar
Adrian
Forum Veteran
Forum Veteran
Posts: 8449
Joined: Wed Jul 12, 2006 1:42 am

Re: laptop wont boot - again

#5 Post by Adrian » Wed Jun 06, 2018 2:17 pm

boots to login screen but after entering password nothing further.
Can you press CTRL - ALT - F1 to get a terminal? Can you log in there to root, examine if /home partition is mount (is it a separate partition?) and if you have enough space on it. Many times when people cannot log is that they ran out space for some reason. Not sure about the other issues...

gonzo01
Forum Novice
Forum  Novice
Posts: 28
Joined: Tue Jul 11, 2017 11:27 pm

Re: laptop wont boot - again

#6 Post by gonzo01 » Thu Jun 07, 2018 12:41 am

Thanks for the replies and advice.

1) Don't get GRUB menu - possibly because SSD boots to quickly

2)BIOS is set to Legacy mode

3)BIOS is set to AHCI

4) can't press CTRL - ALT - F1 - also probably due to SSD fast boot.

5) F3 gives MAC address then hangs on DHCP

6) Possibly you just need the "nomodeset" boot cheat... - need to get GRUB menu for that - see1) above

7) Tried reinstalling MX 17-x64 - failed at GRUB

8) Tried installing PUPPY to 1TB HDD - installed OK but wouldn't boot.

9) SysRescue and live distros wont let me access SSD /dev/sda1 - wont accept root or user password setup in MX original install

10) cleared and reinstalled MBR - still get message re wrong format of MBR "partition"


ie Boot the machine using the Live USB/CD.
Install lilo sudo apt-get install lilo.
Fix the MBR using lilo using the command: sudo lilo -M /dev/sda mbr

11) as I cant access /dev/sda1 I cant use dmsg to view boot log

rasat
Forum Novice
Forum  Novice
Posts: 59
Joined: Tue Dec 19, 2017 1:19 pm

Re: laptop wont boot - again

#7 Post by rasat » Thu Jun 07, 2018 4:32 am

Last update did something to the grub and all options freeze the screen.

I managed to solve last time this problem by changing the kernel to antix-4.9-64bit, but now nothing works.
viewtopic.php?f=107&t=44502

I am blaming grub because the first boot after the update, the screen was blue instead of the standard black wall paper image. On second boot, the screen was ok. Unfortunately, this time I cannot login to fix the problem. All kernel and systemd options gives lot of errors and freeze in a black screen with the blinking cursor in the top left corner. Luckily, always have another distro in my machine when things goes bad.

I don't blame MX Linux. For some reasons it doesn't like Dell 5567 and similar series. Hopefully this problem still can be solved.

gonzo01
Forum Novice
Forum  Novice
Posts: 28
Joined: Tue Jul 11, 2017 11:27 pm

Re: laptop wont boot - again

#8 Post by gonzo01 » Thu Jun 07, 2018 5:19 am

rasat,

I think that my problem is with the kernel, or more likely with the video drivers/Xorg, as the latest problem only occurred after latest updates which did not include the kernel. I was using 4.13.0-1-amd64.

I've just tried recovering the mbr using a Win 10 install DVD ( from when it was first available for free) and am now trying a reinstall of MX 17-x64 but retaining my /home partition.

gonzo01
Forum Novice
Forum  Novice
Posts: 28
Joined: Tue Jul 11, 2017 11:27 pm

Re: laptop wont boot - again

#9 Post by gonzo01 » Thu Jun 07, 2018 5:23 am

gonzo01 wrote:
Thu Jun 07, 2018 5:19 am
rasat,

I think that my problem is with the kernel, or more likely with the video drivers/Xorg, as the latest problem only occurred after latest updates which did not include the kernel. I was using 4.13.0-1-amd64.

I've just tried recovering the mbr using a Win 10 install DVD ( from when it was first available for free) and am now trying a reinstall of MX 17-x64 but retaining my /home partition.
------------------
update - install failed again at installation of Grub to MBR.

Message is:--

Sorry, installing GRUB failed. This may be due to a change in the disk formatting.You can uncheck GRUB and finish installing MX Linux then reboot to theLiveDVD or LiveUSB and repair the installation with the reinstall GRUB function"

Tried MX Boot Repair from LiveDVD

"Could not set up chroot environment. Please double-check the selected location."
Last edited by gonzo01 on Thu Jun 07, 2018 5:34 am, edited 1 time in total.

User avatar
rich
Forum Regular
Forum Regular
Posts: 287
Joined: Sat Mar 31, 2018 6:39 pm

Re: laptop wont boot - again

#10 Post by rich » Thu Jun 07, 2018 5:27 am

Are you updating the live system before install?
MX 17.1 Dell Inspiron N5110

Post Reply

Return to “Hardware /Configuration”