Welcome!
Important information
-- Spectre and Meltdown vulnerabilities
-- Change in MX sources

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-17.1 Final release info here
-- antiX-17 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

Uhr in Windows verstellt sich nicht.

Post Reply
Message
Author
User avatar
Fritzinger
Forum Novice
Forum  Novice
Posts: 2
Joined: Thu May 24, 2018 11:18 pm

Uhr in Windows verstellt sich nicht.

#1 Post by Fritzinger » Thu May 24, 2018 11:27 pm

Nach Rückkehr in Windows wird die Uhrzeit richtig angezeigt! Bei meinenn bisherigen Tests mit Linux Mint und Lubuntu wurde die Uhr in Windows immer um 2 Stunden zurückgedreht. Hier mit MX 17.1 passierte das nicht. Warum auch immer. Find' ich jedenfalls prima!

User avatar
rich
Forum Regular
Forum Regular
Posts: 314
Joined: Sat Mar 31, 2018 6:39 pm

Re: Uhr in Windows verstellt sich nicht.

#2 Post by rich » Thu May 24, 2018 11:31 pm

:celebrate: :number1: Gut! : )
I read a book about Narcissism
And I loved it cuz
It was all about me.

linwinux

Re: Uhr in Windows verstellt sich nicht.

#3 Post by linwinux » Fri May 25, 2018 1:48 am

Na, das ist doch prima ... :happy:

User avatar
fehlix
Forum Guide
Forum Guide
Posts: 2353
Joined: Wed Apr 11, 2018 5:09 pm

Re: Uhr in Windows verstellt sich nicht.

#4 Post by fehlix » Fri May 25, 2018 5:57 pm

Fritzinger wrote:
Thu May 24, 2018 11:27 pm
... wurde die Uhr in Windows immer um 2 Stunden zurückgedreht.
Hier mit MX 17.1 passierte das nicht. Warum auch immer.
...
Kannst Du hiermit umstellen:
Hiermit tickt die interne BIOS-Uhr immer richtg in UTC ( = GMT ):

Code: Select all

sudo  timedatectl set-local-rtc 0  # set BIOS clock to UTC
wird aber leider in Windows oft falsch interpretiert!

Hiermit tickt die interne BIOS-Uhr zwar für Windows besser:

Code: Select all

sudo  timedatectl set-local-rtc 1  # set BIOS clock to LOCAL
und Linux kann damit auch umgehen, aber das kann in Linux zu Problemen führen,
z.B. während der Zeitumstellung, wenn Du Dein Zeitzone auf Reisen änderst
oder wenn Du Pakete aus der "Zukunft" installieren möchtest!

Aktuelle Einstellung kannst Du anzeigen mit

Code: Select all

timedatectl
oder die aktuellen Einstellung und letzte Zeitkorrektur hier anzeigen

Code: Select all

cat /etc/adjtime
:snail:
Gigabyte Z77M-D3H, Intel Xeon E3-1240 V2 (Quad core), 32GB RAM,
GeForce GTX 770, Samsung SSD 850 EVO 500GB, Seagate Barracuda 4TB

User avatar
Fritzinger
Forum Novice
Forum  Novice
Posts: 2
Joined: Thu May 24, 2018 11:18 pm

Re: Uhr in Windows verstellt sich nicht.

#5 Post by Fritzinger » Fri May 25, 2018 8:05 pm

Danke für die Hinweise.
Wie schon von mir gesagt muß ich an der Uhr im Moment (Sommerzeit) bei MX 17.1 nicht rumschrauben, wenn ich nach der Live Version wieder Windows starte. Die Uhrzeit stimmt. Es hat mich ja nach Tests mit Mint und Lubuntu überrascht, dass das in MX einfach funktioniert. Das wollte ich eigentlich nur zum Ausdruck bringen.
Aber mal schauen, wie das mit Umstellung auf Winterzeit wird. Bei MX habe ich jedenfalls im Moment bei Zeiteinstellung keinen Schrauberbedarf. Sie stimmt einfach. Im Gegensatz zu den anderen Live Versionen, die ich gerade teste. Es kursieren da auch "Registry Hacks" für Windows im Internet. Na ja.
By the way: Was sind denn Pakete aus der "Zukunft"?

User avatar
fehlix
Forum Guide
Forum Guide
Posts: 2353
Joined: Wed Apr 11, 2018 5:09 pm

Re: Uhr in Windows verstellt sich nicht.

#6 Post by fehlix » Fri May 25, 2018 8:44 pm

Fritzinger wrote:
Fri May 25, 2018 8:05 pm
By the way: Was sind denn Pakete aus der "Zukunft"?
Naja, bei dem zeit hinher gefummel mit loakler zeit passiert das schon mal, dass ein programm paket eintrudelt, das neuer "erscheint" als die lokale Zeit angibt ist, wenn die lokale Uhrzeit verschoben worden ist, z.b bei zeitumstellung, oder weil man mal UTC Zeit eingestellt hatte oder , oder.... Da gibt es denn so seltsame Meldungen, wie diese Signature des signierten Programm-Paketes wurde in der Zukunft erstellt. Linux vermeidet, sowas durch konesquente Benutzung der Universalzeit UTC. Das andere OS ist da etwas störischer. In Linux gibt das schon mal so'ne extrem Meldung wie die hier,
Warning: The system is configured to read the RTC time in the local time zone.
This mode can not be fully supported. It will create various problems
with time zone changes and daylight saving time adjustments. The RTC
time is never updated, it relies on external facilities to maintain it.
If at all possible, use RTC in UTC by calling
'timedatectl set-local-rtc 0'.
Naja vielleicht etwas übertrieben. Und MX-Linux stellt mittlerweile auch die PC-Uhr korrekt beim Runterfahren in lokaler Zeit ein, da sofern internet-verbindung besteht, immer mit einem ZEIT-server auf hunderstel Sekunde genau synschronsiert wird. :puppy:
Gigabyte Z77M-D3H, Intel Xeon E3-1240 V2 (Quad core), 32GB RAM,
GeForce GTX 770, Samsung SSD 850 EVO 500GB, Seagate Barracuda 4TB

Post Reply

Return to “Deutsches Forum”