Welcome!

Please read this important information about MX sources lists.
News
  • MX Linux on social media: here
  • Mepis support still here
Current releases
  • MX-17 beta 2 release info here
  • MX-16.1 release info here
  • antiX-17 release info here
    New users
    • Please read this first, and don't forget to add system and hardware information to posts!
    • Read Forum Rules

MEPIS 12/MX 14 Community Repository: The Firefox Thread

For Community Repository Package Requests and Status for MX-14
Message
Author
User avatar
dolphin_oracle
Forum Veteran
Forum Veteran
Posts: 6681
Joined: Sun Dec 16, 2007 1:17 pm

Re: MX 14 Community Repository: The Firefox Thread

#51 Postby dolphin_oracle » Sun Dec 20, 2015 2:03 pm

mmikeinsantarosa wrote:Here's 32 & 64 bit firefox-43.0.1 debs for M12/MX-14 (only) that has media.fragmented-mp4.gmp.enabled set to false. I installed this one on top of an existing broken 43.0 and youtube video seems to work now.

NEW Firefox debs

If anybody has time to check this and confirm the problem is gone, I'll send a full fixed set up.

mike


looks good here on mx15 64bit.
http://www.youtube.com/runwiththedolphin
eeepc 904ha antix 15 32 bit (streaming media player)
acer c720p chromebook - chromeos / MX15-64 (custom snapshot) live USB.
lenovo s21e - antiX-16 MX16(live-usb)

User avatar
mmikeinsantarosa
Forum Guide
Forum Guide
Posts: 2004
Joined: Thu May 01, 2014 10:12 am

Re: MX 14 Community Repository: The Firefox Thread

#52 Postby mmikeinsantarosa » Sun Dec 20, 2015 11:13 pm

OK, a fixed firefox-43.0.1 is now in the main repo. I've tested it a fair amount @ youtube and everything seems to work OK. Give this one a spin and it should behave for you too. This is for Mepis 11, 12, MX-14 & MX-15.

Thanks D.O. for the setting!

Mike
LT: Intel Core i7-6820HQ Kernel: 4.12.0-8.3-liquorix-amd64 x86_64 (64 bit)
DT: Intel(R) Core i5-3.1GHz Kernel~3.9-1-mepis64 x86_64

User avatar
mmikeinsantarosa
Forum Guide
Forum Guide
Posts: 2004
Joined: Thu May 01, 2014 10:12 am

Re: MX 14 Community Repository: The Firefox Thread

#53 Postby mmikeinsantarosa » Wed Jan 27, 2016 10:34 pm

firefox-44.0.0 is now available to update to from the main repo.

What's new:
Improved warning pages for certificate errors and untrusted connections
Enable H.264 if system decoder is available
Enable WebM/VP9 video support on systems that don't support MP4/H.264
In the animation-inspector timeline, lightning bolt icon next to animations running on the compositor thread
Support the brotli compression format via HTTPS content-encoding
Screenshot commands allow user choice of pixel ratio in Developer Tools
What's fixed:
Windows XP and Vista screensaver doesn't disable when watching videos (Bug 1193610)
Various security fixes
What's changed:
To support unicode-range descriptor for webfonts, font matching under Linux now uses the same font matching code as other platforms
Use a SHA-256 signing certificate for Windows builds, to meet new signing requirements
Firefox has removed support for the RC4 decipher
Firefox will no longer trust the Equifax Secure Certificate Authority 1024-bit root certificate or the UTN - DATACorp SGC to validate secure website certificates
Stricter validation of web fonts
On-screen keyboard support temporarily turned off for Windows 8 and Windows 8.1
LT: Intel Core i7-6820HQ Kernel: 4.12.0-8.3-liquorix-amd64 x86_64 (64 bit)
DT: Intel(R) Core i5-3.1GHz Kernel~3.9-1-mepis64 x86_64

User avatar
mmikeinsantarosa
Forum Guide
Forum Guide
Posts: 2004
Joined: Thu May 01, 2014 10:12 am

Re: MX 14 Community Repository: The Firefox Thread

#54 Postby mmikeinsantarosa » Sat Feb 13, 2016 6:49 pm

firefox_44.0.2 is now available to upgrade to from the main repo.

What's fixed
Firefox hangs or crashes on startup (1243098)
Same-origin-policy violation using Service Workers with plugins


Mike
LT: Intel Core i7-6820HQ Kernel: 4.12.0-8.3-liquorix-amd64 x86_64 (64 bit)
DT: Intel(R) Core i5-3.1GHz Kernel~3.9-1-mepis64 x86_64

User avatar
mmikeinsantarosa
Forum Guide
Forum Guide
Posts: 2004
Joined: Thu May 01, 2014 10:12 am

Re: MEPIS 12/MX 14 Community Repository: The Firefox Thread

#55 Postby mmikeinsantarosa » Mon Aug 29, 2016 10:07 pm

firefox_48.0.2 is available for download from the MAIN repo. This version required an upgrade of gtk2 to libgtk-3-0 (>= 3.4). Check out the release notes for more info. - Mike
LT: Intel Core i7-6820HQ Kernel: 4.12.0-8.3-liquorix-amd64 x86_64 (64 bit)
DT: Intel(R) Core i5-3.1GHz Kernel~3.9-1-mepis64 x86_64

User avatar
v3g4n
Forum Guide
Forum Guide
Posts: 1750
Joined: Sat Jan 16, 2016 8:20 pm

Re: MEPIS 12/MX 14 Community Repository: The Firefox Thread

#56 Postby v3g4n » Wed Sep 21, 2016 5:00 pm

firefox_49.0 is now available for download/upgrade from main. This is available for MX15/14 and M12.
Release notes: https://www.mozilla.org/en-US/firefox/49.0/releasenotes/

In this release MX15 user should be allowed to watch Netflix. In order to get this to work a user-agent switcher will still need to be used. I set it to Google Chrome and Linux and Netflix now plays. I used the following addon
http://mybrowseraddon.com/useragent-switcher.html Also when once you enter Netflix a small dialogue box will drop down underneath your address bar/bookmarks bar and will want confirmation that you do want to install the components needed to watch Netflix.

I was unable to get it to work on either M12/MX14. In M12 Netflix seemed to just load and load, but on MX14 the widevine plugin would crash. These tests were done in a VM so maybe you can get it to work on a real hardware install. If so please post how so that other users are able to benefit.

User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 13682
Age: 59
Joined: Fri Dec 15, 2006 8:07 pm

Re: MEPIS 12/MX 14 Community Repository: The Firefox Thread

#57 Postby Stevo » Wed Sep 21, 2016 5:17 pm

v3g4n wrote:firefox_49.0 is now available for download/upgrade from main. This is available for MX15/14 and M12.
Release notes: https://www.mozilla.org/en-US/firefox/49.0/releasenotes/

In this release MX15 user should be allowed to watch Netflix. In order to get this to work a user-agent switcher will still need to be used. I set it to Google Chrome and Linux and Netflix now plays. I used the following addon
http://mybrowseraddon.com/useragent-switcher.html Also when once you enter Netflix a small dialogue box will drop down underneath your address bar/bookmarks bar and will want confirmation that you do want to install the components needed to watch Netflix.

I was unable to get it to work on either M12/MX14. In M12 Netflix seemed to just load and load, but on MX14 the widevine plugin would crash. These tests were done in a VM so maybe you can get it to work on a real hardware install. If so please post how so that other users are able to benefit.


For Chrome on MX 14, the plugin required an updated libc6 which we had in that Experimental repo. You could run an "objdump -x" on the widevine.so files once Firefox downloads them and see if the same is true for that plugin.

User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 13682
Age: 59
Joined: Fri Dec 15, 2006 8:07 pm

Re: MEPIS 12/MX 14 Community Repository: The Firefox Thread

#58 Postby Stevo » Sat Sep 24, 2016 3:17 pm

I did a test, and the downloaded plugin seems to be the exact same one that Chrome uses--both require libc6 >= 2.14. So the same solution should work.

User avatar
whell
Forum Regular
Forum Regular
Posts: 289
Joined: Sat Sep 26, 2009 1:03 pm

Re: MEPIS 12/MX 14 Community Repository: The Firefox Thread

#59 Postby whell » Sat Sep 24, 2016 4:00 pm

I got it working to watch Amazon Prime videos, but only if Firefox is set to emulate I.E. 8.

User avatar
soundtech
Forum Novice
Forum  Novice
Posts: 51
Joined: Thu Jul 13, 2006 5:52 pm

Re: MEPIS 12/MX 14 Community Repository: The Firefox Thread

#60 Postby soundtech » Sat Sep 24, 2016 4:16 pm

I might be missing something here. Wouldn't be the first time.....

I'm running Firefox 49.0 on MX 14.4 PAE, user agent switcher as Chrome on Linux, lib6c version 2.17-97, Widevine plugin 1.4.8.903
When I attempt to launch a video on Netflix, I get a message from Firefox telling me that "The WidevineCdm plugin has crashed". And of course no video playing.

Has this been solved, or still an issue? Thanks.


Return to “Package Requests/Status - MX-14”

Who is online

Users browsing this forum: No registered users and 1 guest