Welcome!

The kernel problem with recent updates has been solved. Find the solution here

Important information
-- Required MX 15/16 Repository Changes
-- Information on torrent hosting changes
-- Information on MX15/16 GPG Keys
-- Spectre and Meltdown vulnerabilities

News
-- Introducing our new Website
-- MX Linux on social media: here

Current releases
-- MX-18.3 Point Release release info here
-- Migration Information to MX-18 here
-- antiX-17.4.1 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

Virtualbox 5&6 - MX/antiX kernel conflicts [SOLVED]

Report Bugs, Issues and non- pacakage Requests
User avatar
manyroads
Forum Guide
Forum Guide
Posts: 1533
Joined: Sat Jun 30, 2018 6:33 pm

Virtualbox 5&6 - MX/antiX kernel conflicts [SOLVED]

#1

Post by manyroads » Fri May 10, 2019 1:22 pm

For those who use VirtualBox, I'd be interested to see if you have similar experiences. I tried to upgrade my Linux kernels. I found that three of them do not function, for me, with VBox 5.24 because of errors updating virtualbox-dkms. btw. the same is true with version 6 of Virtualbox. :eek:

--- 5.0.9 antiX kernel -- removed due to VBox problems
--- 5.0.0-12 liquorix -- removed due to VBox problems
--- 4.20.12 antiX -- removed due to VBox problems
--- 4.19.0 amd64 -- works for me with VBox

Throw the following errors in virtualbox update attempts (I neglected to copy the one for 5.0.9 antiX kernel (which was identical):

Code: Select all

Unpacking virtualbox-dkms (5.2.24-dfsg-4~mx17+1) over (5.2.24-dfsg-4~mx17+1) ...
Setting up virtualbox-dkms (5.2.24-dfsg-4~mx17+1) ...
Loading new virtualbox-5.2.24 DKMS files...
Building for 5.0.0-12.1-liquorix-amd64
Building initial module for 5.0.0-12.1-liquorix-amd64
Error! Bad return status for module build on kernel: 5.0.0-12.1-liquorix-amd64 (x86_64)
Consult /var/lib/dkms/virtualbox/5.2.24/build/make.log for more information.

Code: Select all

Unpacking virtualbox-dkms (5.2.24-dfsg-4~mx17+1) over (5.2.24-dfsg-4~mx17+1) ...
Setting up virtualbox-dkms (5.2.24-dfsg-4~mx17+1) ...
Loading new virtualbox-5.2.24 DKMS files...
Building for 4.20.12-antix.1-amd64-smp 5.0.0-12.1-liquorix-amd64
Building initial module for 4.20.12-antix.1-amd64-smp
Error! Bad return status for module build on kernel: 4.20.12-antix.1-amd64-smp (x86_64)
Consult /var/lib/dkms/virtualbox/5.2.24/build/make.log for more information.
And by way of 'full disclosure'... Yes, I tried all the relevant help I could find on Virtualbox, ubuntu, debian, arch, forums/ wikis. :bagoverhead:
Last edited by manyroads on Tue May 14, 2019 10:12 am, edited 1 time in total.
"Don't believe everything you think."
Pax vobiscum,
Mark Rabideau - http://many-roads.com - Reg. Linux User #449130
MX-18.3 kernel: 5.1.11-antix.1-amd64-smp
Dell Latitude E5470
Intel i5-6300U~ 24GB RAM ~ SSD: 1TB
Coding since 1974

User avatar
timkb4cq
Forum Veteran
Forum Veteran
Posts: 4986
Joined: Wed Jul 12, 2006 4:05 pm

Re: Virtualbox 5&6 - MX/antiX kernel conflicts

#2

Post by timkb4cq » Fri May 10, 2019 2:23 pm

On the Oracle website, the changelog reveals that this is a known bug that was fixed in Vbox 5.26 and 6.0.6
We currently have 6.0.6 in the MX Test repo if you're running an older 6.0 version.

We probably should update the version in main to 5.28
MSI 970A-G43 MB, AMD FX-6300 (six core), 16GB RAM, GeForce 730, Samsung 850 EVO 250GB SSD, Seagate Barracuda XT 3TB

User avatar
manyroads
Forum Guide
Forum Guide
Posts: 1533
Joined: Sat Jun 30, 2018 6:33 pm

Re: Virtualbox 5&6 - MX/antiX kernel conflicts

#3

Post by manyroads » Fri May 10, 2019 3:27 pm

timkb4cq wrote:
Fri May 10, 2019 2:23 pm
On the Oracle website, the changelog reveals that this is a known bug that was fixed in Vbox 5.26 and 6.0.6
We currently have 6.0.6 in the MX Test repo if you're running an older 6.0 version.

We probably should update the version in main to 5.28
Tim, I even tried the v 6 & 5 Virtualbox install deb files from the Oracle site and obtained the above problem(s)....
"Don't believe everything you think."
Pax vobiscum,
Mark Rabideau - http://many-roads.com - Reg. Linux User #449130
MX-18.3 kernel: 5.1.11-antix.1-amd64-smp
Dell Latitude E5470
Intel i5-6300U~ 24GB RAM ~ SSD: 1TB
Coding since 1974

User avatar
dolphin_oracle
Forum Veteran
Forum Veteran
Posts: 11560
Joined: Sun Dec 16, 2007 1:17 pm

Re: Virtualbox 5&6 - MX/antiX kernel conflicts

#4

Post by dolphin_oracle » Fri May 10, 2019 3:35 pm

did you install the headers with the new kernels? dkms modules won't compile without them.
http://www.youtube.com/runwiththedolphin
lenovo ThinkPad T530 - MX-18
lenovo s21e - MX-18, antiX-17.3.1 (live-USB)
FYI: mx "test" repo is not the same thing as debian testing repo.

User avatar
timkb4cq
Forum Veteran
Forum Veteran
Posts: 4986
Joined: Wed Jul 12, 2006 4:05 pm

Re: Virtualbox 5&6 - MX/antiX kernel conflicts

#5

Post by timkb4cq » Fri May 10, 2019 3:36 pm

Did you install the matching Extension pack as well? the bug report discussions indicated that was necessary
MSI 970A-G43 MB, AMD FX-6300 (six core), 16GB RAM, GeForce 730, Samsung 850 EVO 250GB SSD, Seagate Barracuda XT 3TB

User avatar
manyroads
Forum Guide
Forum Guide
Posts: 1533
Joined: Sat Jun 30, 2018 6:33 pm

Re: Virtualbox 5&6 - MX/antiX kernel conflicts

#6

Post by manyroads » Fri May 10, 2019 3:50 pm

Yes to both D-O & Tim. I installed every VirtualBox package below:
virtualbox
virtualbox-dkms
virtualbox-ext-pack
virtualbox-guest-additions
virtualbox-guest-utils
virtualbox-guest-x11
virtualbox-qt

I did that after my first fail just to make certain I wasn't missing anything. I obtained and installed the entire set (such as they are available from the following locations):
mxpi (v 5)
mxpi (v6- testrepo)
synaptic (v5)
oracle download (debs) 5 & 6.
and apt CLI

I did all of the above for all the kernels mentioned in my OP.

I am back where I started yesterday after some 6 hours of installation and testing fun! :rolleyes: No real progress but a LOT of learning. :crossfingers: :eek:
"Don't believe everything you think."
Pax vobiscum,
Mark Rabideau - http://many-roads.com - Reg. Linux User #449130
MX-18.3 kernel: 5.1.11-antix.1-amd64-smp
Dell Latitude E5470
Intel i5-6300U~ 24GB RAM ~ SSD: 1TB
Coding since 1974

User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 19355
Joined: Fri Dec 15, 2006 8:07 pm

Re: Virtualbox 5&6 - MX/antiX kernel conflicts

#7

Post by Stevo » Fri May 10, 2019 3:52 pm

The 6.0.6 in the test repo works for me on the 5.0.14 Liquorix kernel (and all others).
The last I looked, Debian was still at 5.2.24 on the 5.2 series.

User avatar
manyroads
Forum Guide
Forum Guide
Posts: 1533
Joined: Sat Jun 30, 2018 6:33 pm

Re: Virtualbox 5&6 - MX/antiX kernel conflicts

#8

Post by manyroads » Fri May 10, 2019 3:53 pm

Stevo wrote:
Fri May 10, 2019 3:52 pm
The 6.0.6 in the test repo works for me on the 5.0.14 Liquorix kernel (and all others).
Okay @stevo I'll give it a go... what's two/three more installs among friends! :hug:
"Don't believe everything you think."
Pax vobiscum,
Mark Rabideau - http://many-roads.com - Reg. Linux User #449130
MX-18.3 kernel: 5.1.11-antix.1-amd64-smp
Dell Latitude E5470
Intel i5-6300U~ 24GB RAM ~ SSD: 1TB
Coding since 1974

User avatar
manyroads
Forum Guide
Forum Guide
Posts: 1533
Joined: Sat Jun 30, 2018 6:33 pm

Re: Virtualbox 5&6 - MX/antiX kernel conflicts

#9

Post by manyroads » Fri May 10, 2019 4:17 pm

@stevo the results are not so very good at my end with the 5.0.0.14 kernel...

VBox 6.0.6 works fine with kernel: 4.19.0-1 on my machine.
However.... Liquorix 5.0.0-14.1 is not so good....

I have an attached screen shot and here's the error when I try to install
Screenshot_2019-05-10_14-06-04.jpg

Code: Select all

sudo modprobe vboxdrv
[sudo] password for mark: 
modprobe: FATAL: Module vboxdrv not found in directory /lib/modules/5.0.0-14.1-liquorix-amd64
Failed to open a session for the virtual machine antiX.

The virtual machine 'antiX' has terminated unexpectedly during startup with exit code 1 (0x1).

Result Code: NS_ERROR_FAILURE (0x80004005)
Component: MachineWrap
Interface: IMachine {5047460a-265d-4538-b23e-ddba5fb84976}


Code: Select all

======5.0.0.14 Install Log ==========
Hit:1 http://ftp.us.debian.org/debian stretch-updates InRelease
Ign:2 http://ftp.us.debian.org/debian stretch InRelease
Hit:3 http://ftp.us.debian.org/debian stretch Release
Hit:4 https://repo.skype.com/deb stable InRelease
Get:5 http://security.debian.org stretch/updates InRelease [94.3 kB]
Hit:7 https://mirror.us.oneandone.net/linux/distributions/mx/packages/antix/stretch stretch InRelease
Hit:8 https://mirror.us.oneandone.net/linux/distributions/mx/packages/mx/repo stretch InRelease
Get:9 https://mirror.us.oneandone.net/linux/distributions/mx/packages/mx/testrepo stretch InRelease [4,979 B]
Get:10 https://mirror.us.oneandone.net/linux/distributions/mx/packages/mx/testrepo stretch/test amd64 Packages [934 kB]
Get:11 https://mega.nz/linux/MEGAsync/Debian_9.0 ./ InRelease [1,480 B]
Get:12 https://mirror.us.oneandone.net/linux/distributions/mx/packages/mx/testrepo stretch/test i386 Packages [928 kB]
Fetched 1,963 kB in 2s (701 kB/s)
Reading package lists...
Reading package lists...
Building dependency tree...
Reading state information...
Suggested packages:
  linux-doc-5.0 crda
The following NEW packages will be installed:
  linux-headers-5.0.0-14.1-liquorix-amd64
  linux-image-5.0.0-14.1-liquorix-amd64
0 upgraded, 2 newly installed, 0 to remove and 196 not upgraded.
Need to get 63.4 MB of archives.
After this operation, 358 MB of additional disk space will be used.
Get:1 https://mirror.us.oneandone.net/linux/distributions/mx/packages/mx/testrepo stretch/test amd64 linux-image-5.0.0-14.1-liquorix-amd64 amd64 5.0-14~mx17+1 [54.8 MB]
Get:2 https://mirror.us.oneandone.net/linux/distributions/mx/packages/mx/testrepo stretch/test amd64 linux-headers-5.0.0-14.1-liquorix-amd64 amd64 5.0-14~mx17+1 [8,665 kB]
Preconfiguring packages ...
Fetched 63.4 MB in 47s (1,342 kB/s)
Selecting previously unselected package linux-image-5.0.0-14.1-liquorix-amd64.
(Reading database ... 
(Reading database ... 5%
(Reading database ... 10%
(Reading database ... 15%
(Reading database ... 20%
(Reading database ... 25%
(Reading database ... 30%
(Reading database ... 35%
(Reading database ... 40%
(Reading database ... 45%
(Reading database ... 50%
(Reading database ... 55%
(Reading database ... 60%
(Reading database ... 65%
(Reading database ... 70%
(Reading database ... 75%
(Reading database ... 80%
(Reading database ... 85%
(Reading database ... 90%
(Reading database ... 95%
(Reading database ... 100%
(Reading database ... 337038 files and directories currently installed.)
Preparing to unpack .../linux-image-5.0.0-14.1-liquorix-amd64_5.0-14~mx17+1_amd64.deb ...
Unpacking linux-image-5.0.0-14.1-liquorix-amd64 (5.0-14~mx17+1) ...
Selecting previously unselected package linux-headers-5.0.0-14.1-liquorix-amd64.
Preparing to unpack .../linux-headers-5.0.0-14.1-liquorix-amd64_5.0-14~mx17+1_amd64.deb ...
Unpacking linux-headers-5.0.0-14.1-liquorix-amd64 (5.0-14~mx17+1) ...
Setting up linux-image-5.0.0-14.1-liquorix-amd64 (5.0-14~mx17+1) ...
/etc/kernel/postinst.d/dkms:
Error! Bad return status for module build on kernel: 5.0.0-14.1-liquorix-amd64 (x86_64)
Consult /var/lib/dkms/broadcom-sta/6.30.223.271/build/make.log for more information.
Error! Bad return status for module build on kernel: 5.0.0-14.1-liquorix-amd64 (x86_64)
Consult /var/lib/dkms/ndiswrapper/1.61/build/make.log for more information.
Error! Bad return status for module build on kernel: 5.0.0-14.1-liquorix-amd64 (x86_64)
Consult /var/lib/dkms/virtualbox/5.2.24/build/make.log for more information.
/etc/kernel/postinst.d/initramfs-tools:
update-initramfs: Generating /boot/initrd.img-5.0.0-14.1-liquorix-amd64
W: Possible missing firmware /lib/firmware/i915/icl_dmc_ver1_07.bin for module i915
I: The initramfs will attempt to resume from /dev/sda2
I: (UUID=b047ad4c-f364-4fba-a209-0a10a92aa872)
I: Set the RESUME variable to override this.
/etc/kernel/postinst.d/zz-update-grub:
Generating grub configuration file ...
using custom appearance settings
Found background image: /usr/share/backgrounds/MXLinux/grub/nature-3082832.jpg
Found linux image: /boot/vmlinuz-5.0.0-14.1-liquorix-amd64
Found initrd image: /boot/initrd.img-5.0.0-14.1-liquorix-amd64
Found linux image: /boot/vmlinuz-4.19.0-1-amd64
Found initrd image: /boot/initrd.img-4.19.0-1-amd64
Found memtest86+ image: /boot/memtest86+.bin
done
Setting up linux-headers-5.0.0-14.1-liquorix-amd64 (5.0-14~mx17+1) ...
Examining /etc/kernel/header_postinst.d.
run-parts: executing /etc/kernel/header_postinst.d/dkms 5.0.0-14.1-liquorix-amd64
Error! Bad return status for module build on kernel: 5.0.0-14.1-liquorix-amd64 (x86_64)
Consult /var/lib/dkms/broadcom-sta/6.30.223.271/build/make.log for more information.
Error! Bad return status for module build on kernel: 5.0.0-14.1-liquorix-amd64 (x86_64)
Consult /var/lib/dkms/ndiswrapper/1.61/build/make.log for more information.
Error! Bad return status for module build on kernel: 5.0.0-14.1-liquorix-amd64 (x86_64)
Consult /var/lib/dkms/virtualbox/5.2.24/build/make.log for more information.
Hit:1 http://security.debian.org stretch/updates InRelease
Hit:2 http://ftp.us.debian.org/debian stretch-updates InRelease
Ign:3 http://ftp.us.debian.org/debian stretch InRelease
Hit:4 http://ftp.us.debian.org/debian stretch Release
Hit:5 https://repo.skype.com/deb stable InRelease
Hit:6 https://mirror.us.oneandone.net/linux/distributions/mx/packages/antix/stretch stretch InRelease
Hit:8 https://mirror.us.oneandone.net/linux/distributions/mx/packages/mx/repo stretch InRelease
Get:9 https://mega.nz/linux/MEGAsync/Debian_9.0 ./ InRelease [1,480 B]
Fetched 1,480 B in 1s (1,070 B/s)
Reading package lists...

Code: Select all

================= VBox Install =========

Hit:1 http://security.debian.org stretch/updates InRelease
Hit:2 http://ftp.us.debian.org/debian stretch-updates InRelease
Ign:3 http://ftp.us.debian.org/debian stretch InRelease
Hit:4 https://repo.skype.com/deb stable InRelease
Hit:5 http://ftp.us.debian.org/debian stretch Release
Hit:6 https://mirror.us.oneandone.net/linux/distributions/mx/packages/antix/stretch stretch InRelease
Hit:7 https://mirror.us.oneandone.net/linux/distributions/mx/packages/mx/repo stretch InRelease
Get:9 https://mirror.us.oneandone.net/linux/distributions/mx/packages/mx/testrepo stretch InRelease [4,979 B]
Get:10 https://mirror.us.oneandone.net/linux/distributions/mx/packages/mx/testrepo stretch/test i386 Packages [928 kB]
Get:11 https://mega.nz/linux/MEGAsync/Debian_9.0 ./ InRelease [1,480 B]
Get:12 https://mirror.us.oneandone.net/linux/distributions/mx/packages/mx/testrepo stretch/test amd64 Packages [934 kB]
Fetched 1,868 kB in 2s (691 kB/s)
Reading package lists...
Reading package lists...
Building dependency tree...
Reading state information...
Suggested packages:
  vde2 virtualbox-guest-x11
The following NEW packages will be installed:
  virtualbox-guest-dkms virtualbox-guest-utils
The following packages will be upgraded:
  virtualbox virtualbox-dkms virtualbox-ext-pack
  virtualbox-guest-additions-iso virtualbox-qt
Preconfiguring packages ...
5 upgraded, 2 newly installed, 0 to remove and 191 not upgraded.
Need to get 0 B/108 MB of archives.
After this operation, 85.3 MB of additional disk space will be used.
(Reading database ... 
(Reading database ... 5%
(Reading database ... 10%
(Reading database ... 15%
(Reading database ... 20%
(Reading database ... 25%
(Reading database ... 30%
(Reading database ... 35%
(Reading database ... 40%
(Reading database ... 45%
(Reading database ... 50%
(Reading database ... 55%
(Reading database ... 60%
(Reading database ... 65%
(Reading database ... 70%
(Reading database ... 75%
(Reading database ... 80%
(Reading database ... 85%
(Reading database ... 90%
(Reading database ... 95%
(Reading database ... 100%
(Reading database ... 365028 files and directories currently installed.)
Preparing to unpack .../0-virtualbox-ext-pack_6.0.6-1~mx17+1_all.deb ...
0%...10%...20%...30%...40%...50%...60%...70%...80%...90%...100%
Successfully uninstalled "Oracle VM VirtualBox Extension Pack".
Successfully performed extension pack cleanup
License has already been accepted.
Unpacking virtualbox-ext-pack (6.0.6-1~mx17+1) over (5.2.24-1~mx17+1) ...
Preparing to unpack .../1-virtualbox_6.0.6-dfsg-1~mx17+1_amd64.deb ...
Unpacking virtualbox (6.0.6-dfsg-1~mx17+1) over (5.2.24-dfsg-4~mx17+1) ...
Preparing to unpack .../2-virtualbox-qt_6.0.6-dfsg-1~mx17+1_amd64.deb ...
Unpacking virtualbox-qt (6.0.6-dfsg-1~mx17+1) over (5.2.24-dfsg-4~mx17+1) ...
Preparing to unpack .../3-virtualbox-dkms_6.0.6-dfsg-1~mx17+1_all.deb ...

-------- Uninstall Beginning --------
Module:  virtualbox
Version: 5.2.24
Kernel:  4.19.0-1-amd64 (x86_64)
-------------------------------------

Status: Before uninstall, this module version was ACTIVE on this kernel.

vboxdrv.ko:
 - Uninstallation
   - Deleting from: /lib/modules/4.19.0-1-amd64/updates/
 - Original module
   - No original module was found for this module on this kernel.
   - Use the dkms install command to reinstall any previous module version.


vboxnetadp.ko:
 - Uninstallation
   - Deleting from: /lib/modules/4.19.0-1-amd64/updates/
 - Original module
   - No original module was found for this module on this kernel.
   - Use the dkms install command to reinstall any previous module version.


vboxnetflt.ko:
 - Uninstallation
   - Deleting from: /lib/modules/4.19.0-1-amd64/updates/
 - Original module
   - No original module was found for this module on this kernel.
   - Use the dkms install command to reinstall any previous module version.


vboxpci.ko:
 - Uninstallation
   - Deleting from: /lib/modules/4.19.0-1-amd64/updates/
 - Original module
   - No original module was found for this module on this kernel.
   - Use the dkms install command to reinstall any previous module version.

depmod...

DKMS: uninstall completed.

------------------------------
Deleting module version: 5.2.24
completely from the DKMS tree.
------------------------------
Done.
Unpacking virtualbox-dkms (6.0.6-dfsg-1~mx17+1) over (5.2.24-dfsg-4~mx17+1) ...
Preparing to unpack .../4-virtualbox-guest-additions-iso_6.0.6-1~mx17+1_all.deb ...
Unpacking virtualbox-guest-additions-iso (6.0.6-1~mx17+1) over (5.2.24-1~mx17+1) ...
Selecting previously unselected package virtualbox-guest-dkms.
Preparing to unpack .../5-virtualbox-guest-dkms_6.0.6-dfsg-1~mx17+1_all.deb ...
Unpacking virtualbox-guest-dkms (6.0.6-dfsg-1~mx17+1) ...
Selecting previously unselected package virtualbox-guest-utils.
Preparing to unpack .../6-virtualbox-guest-utils_6.0.6-dfsg-1~mx17+1_amd64.deb ...
Unpacking virtualbox-guest-utils (6.0.6-dfsg-1~mx17+1) ...
Processing triggers for mime-support (3.60) ...
Processing triggers for desktop-file-utils (0.23-1) ...
Setting up virtualbox-dkms (6.0.6-dfsg-1~mx17+1) ...
Loading new virtualbox-6.0.6 DKMS files...
Building for 4.19.0-1-amd64 5.0.0-14.1-liquorix-amd64
Building initial module for 4.19.0-1-amd64
Done.

vboxdrv:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/4.19.0-1-amd64/updates/

vboxnetadp.ko:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/4.19.0-1-amd64/updates/

vboxnetflt.ko:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/4.19.0-1-amd64/updates/

vboxpci.ko:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/4.19.0-1-amd64/updates/

depmod...

DKMS: install completed.
Building initial module for 5.0.0-14.1-liquorix-amd64
Error! Bad return status for module build on kernel: 5.0.0-14.1-liquorix-amd64 (x86_64)
Consult /var/lib/dkms/virtualbox/6.0.6/build/make.log for more information.
Unloading VirtualBox kernel modules... vboxnetadp vboxnetflt vboxpci vboxdrv.
Loading VirtualBox kernel modules... vboxdrv vboxnetflt vboxnetadp vboxpci.
Setting up virtualbox-guest-dkms (6.0.6-dfsg-1~mx17+1) ...
Loading new virtualbox-guest-6.0.6 DKMS files...
Building for 4.19.0-1-amd64 5.0.0-14.1-liquorix-amd64
Building initial module for 4.19.0-1-amd64
Done.

vboxguest:
Running module version sanity check.
 - Original module
   - Found /lib/modules/4.19.0-1-amd64/updates/vboxguest.ko
   - Storing in /var/lib/dkms/virtualbox-guest/original_module/4.19.0-1-amd64/x86_64/
   - Archiving for uninstallation purposes
 - Installation
   - Installing to /lib/modules/4.19.0-1-amd64/updates/

vboxsf.ko:
Running module version sanity check.
 - Original module
 - Installation
   - Installing to /lib/modules/4.19.0-1-amd64/updates/

vboxvideo.ko:
Running module version sanity check.
Error! Module version 6.0.6_Debian for vboxvideo.ko
is not newer than what is already found in kernel 4.19.0-1-amd64 (6.0.6_Debian).
You may override by specifying --force.

depmod...

DKMS: install completed.
Building initial module for 5.0.0-14.1-liquorix-amd64
Error! Bad return status for module build on kernel: 5.0.0-14.1-liquorix-amd64 (x86_64)
Consult /var/lib/dkms/virtualbox-guest/6.0.6/build/make.log for more information.
Setting up virtualbox-guest-additions-iso (6.0.6-1~mx17+1) ...
Processing triggers for menu (2.1.47+b1) ...
Processing triggers for bamfdaemon (0.5.3-2) ...
Rebuilding /usr/share/applications/bamf-2.index...
Processing triggers for systemd (232-25+deb9u11) ...
Setting up virtualbox-guest-utils (6.0.6-dfsg-1~mx17+1) ...
Created symlink /etc/systemd/system/multi-user.target.wants/virtualbox-guest-utils.service → /lib/systemd/system/virtualbox-guest-utils.service.
Processing triggers for man-db (2.7.6.1-2) ...
Processing triggers for shared-mime-info (1.8-1+deb9u1) ...
Processing triggers for gnome-menus (3.13.3-9) ...
Processing triggers for hicolor-icon-theme (0.15-1) ...
Setting up virtualbox-qt (6.0.6-dfsg-1~mx17+1) ...
Setting up virtualbox (6.0.6-dfsg-1~mx17+1) ...
Unloading VirtualBox kernel modules... vboxnetadp vboxnetflt vboxpci vboxdrv.
Loading VirtualBox kernel modules... vboxdrv vboxnetflt vboxnetadp vboxpci.
Setting up virtualbox-ext-pack (6.0.6-1~mx17+1) ...
removing old virtualbox extension packs
virtualbox-ext-pack: downloading: https://download.virtualbox.org/virtualbox/6.0.6/Oracle_VM_VirtualBox_Extension_Pack-6.0.6.vbox-extpack
The file will be downloaded into /usr/share/virtualbox-ext-pack
License accepted.
0%...10%...20%...30%...40%...50%...60%...70%...80%...90%...100%
Successfully installed "Oracle VM VirtualBox Extension Pack".
Processing triggers for systemd (232-25+deb9u11) ...
Processing triggers for menu (2.1.47+b1) ...
Hit:1 http://ftp.us.debian.org/debian stretch-updates InRelease
Ign:2 http://ftp.us.debian.org/debian stretch InRelease
Hit:3 https://repo.skype.com/deb stable InRelease
Hit:4 http://ftp.us.debian.org/debian stretch Release
Hit:5 https://mirror.us.oneandone.net/linux/distributions/mx/packages/antix/stretch stretch InRelease
Hit:6 http://security.debian.org stretch/updates InRelease
Hit:7 https://mirror.us.oneandone.net/linux/distributions/mx/packages/mx/repo stretch InRelease
Get:9 https://mega.nz/linux/MEGAsync/Debian_9.0 ./ InRelease [1,480 B]
Fetched 1,480 B in 1s (1,215 B/s)
Reading package lists...
Here are my machine specs:

Code: Select all

System:
  Host: mark-dell Kernel: 5.0.0-14.1-liquorix-amd64 x86_64 bits: 64 
  compiler: gcc v: 6.3.0 Desktop: Xfce 4.12.3 
  Distro: MX-18.2_x64 Continuum Feb 9  2019 
  base: Debian GNU/Linux 9 (stretch) 
Machine:
  Type: Laptop System: Dell product: Latitude E5470 v: N/A serial: <filter> 
  Mobo: Dell model: N/A serial: <filter> UEFI [Legacy]: Dell v: 1.18.6 
  date: 12/08/2017 
Battery:
  ID-1: BAT0 charge: 49.6 Wh condition: 49.6/62.0 Wh (80%) 
  model: LGC-LGC4.20 DELL HK6DV status: Full 
CPU:
  Topology: Dual Core model: Intel Core i5-6300U bits: 64 type: MT MCP 
  arch: Skylake rev: 3 L2 cache: 3072 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 19968 
  Speed: 2207 MHz min/max: 400/3000 MHz Core speeds (MHz): 1: 500 2: 500 
  3: 500 4: 500 
Graphics:
  Device-1: Intel HD Graphics 520 vendor: Dell driver: i915 v: kernel 
  bus ID: 00:02.0 
  Display: x11 server: X.Org 1.19.2 driver: modesetting unloaded: fbdev,vesa 
  resolution: 1920x1080~60Hz 
  OpenGL: renderer: Mesa DRI Intel HD Graphics 520 (Skylake GT2) 
  v: 4.5 Mesa 18.2.6 direct render: Yes 
Audio:
  Device-1: Intel Sunrise Point-LP HD Audio vendor: Dell 
  driver: snd_hda_intel v: kernel bus ID: 00:1f.3 
  Sound Server: ALSA v: k5.0.0-14.1-liquorix-amd64 
Network:
  Device-1: Intel Ethernet I219-LM vendor: Dell driver: e1000e v: 3.2.6-k 
  port: f040 bus ID: 00:1f.6 
  IF: eth0 state: down mac: <filter> 
  Device-2: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter 
  vendor: Dell driver: ath10k_pci v: kernel port: f040 bus ID: 01:00.0 
  IF: wlan0 state: up mac: <filter> 
  Device-3: Atheros type: USB driver: btusb bus ID: 1-8:5 
Drives:
  Local Storage: total: 1008.18 GiB used: 573.57 GiB (56.9%) 
  ID-1: /dev/mmcblk0 model: SD32G size: 30.09 GiB 
  ID-2: /dev/sda vendor: Crucial model: CT1050MX300SSD4 size: 978.09 GiB 
  temp: 32 C 
RAID:
  Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci 
  v: 3.0 bus ID: 00:17.0 
Partition:
  ID-1: / size: 952.05 GiB used: 573.57 GiB (60.2%) fs: ext4 dev: /dev/sda1 
  ID-2: swap-1 size: 9.81 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda2 
Sensors:
  System Temperatures: cpu: 47.0 C mobo: 42.0 C sodimm: 37.0 C 
  Fan Speeds (RPM): cpu: 0 
Repos:
  Active apt repos in: /etc/apt/sources.list.d/antix.list 
  1: deb https://mirror.us.oneandone.net/linux/distributions/mx/packages/antix/stretch/ stretch main
  Active apt repos in: /etc/apt/sources.list.d/debian-stable-updates.list 
  1: deb http://ftp.us.debian.org/debian/ stretch-updates main contrib non-free
  Active apt repos in: /etc/apt/sources.list.d/debian.list 
  1: deb http://ftp.us.debian.org/debian/ stretch main contrib non-free
  2: deb http://security.debian.org/ stretch/updates main contrib non-free
  Active apt repos in: /etc/apt/sources.list.d/megasync.list 
  1: deb https://mega.nz/linux/MEGAsync/Debian_9.0/ ./
  Active apt repos in: /etc/apt/sources.list.d/mx.list 
  1: deb https://mirror.us.oneandone.net/linux/distributions/mx/packages/mx/repo/ stretch main non-free
  Active apt repos in: /etc/apt/sources.list.d/skype-stable.list 
  1: deb [arch=amd64] https://repo.skype.com/deb stable main
  No active apt repos in: /etc/apt/sources.list.d/various.list 
Info:
  Processes: 235 Uptime: 7m Memory: 23.22 GiB used: 1.31 GiB (5.7%) 
  Init: SysVinit runlevel: 5 Compilers: gcc: N/A clang: 3.8.1-24 Shell: bash 
  v: 4.4.12 inxi: 3.0.33 
You do not have the required permissions to view the files attached to this post.
"Don't believe everything you think."
Pax vobiscum,
Mark Rabideau - http://many-roads.com - Reg. Linux User #449130
MX-18.3 kernel: 5.1.11-antix.1-amd64-smp
Dell Latitude E5470
Intel i5-6300U~ 24GB RAM ~ SSD: 1TB
Coding since 1974

User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 19355
Joined: Fri Dec 15, 2006 8:07 pm

Re: Virtualbox 5&6 - MX/antiX kernel conflicts

#10

Post by Stevo » Fri May 10, 2019 5:49 pm

What is the result of

Code: Select all

sudo dpkg-reconfigure virtualbox-dkms
That'll try and rebuild the kernel module in the terminal, so we can see where it's failing.

BTW, I'm trying to build 5.2.28, after figuring out how to download and DFSGify the source (get rid of all the extra stuff Debian removes) There are some scripts to do that automatically, but they all get 6.0.6. Plus it looks like I need to only refresh one patch after disabling some that don't apply to Stretch, such as for Python 3.7 or Java 9. :crossfingers: VBox 6.0.6 does have that annoying problem of not following the theming.

Post Reply

Return to “Bugs and Non-Package Requests Forum”