Welcome!
Important information
-- Required MX 15/16 Repository Changes
-- Information on torrent hosting changes
-- Information on MX15/16 GPG Keys
-- Spectre and Meltdown vulnerabilities

News
-- Introducing our new Website
-- MX Linux on social media: here

Current releases
-- MX-18.3 Point Release release info here
-- Migration Information to MX-18 here
-- antiX-17.4.1 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

[SOLVED]After small update package managers are all messsed up

Report Bugs, Issues and non- pacakage Requests
Post Reply
User avatar
duje
Forum Novice
Forum  Novice
Posts: 9
Joined: Thu May 09, 2019 12:28 pm

[SOLVED]After small update package managers are all messsed up

#1

Post by duje » Fri May 10, 2019 3:52 am

I just did a small update, and all of the sudden I cant install stuff from default package managers, it says file not found, tried on opera, and vivaldi from popular software tab, and stable repo, also when checking up at gnome software I get this error
Screenshot from 2019-05-10 09-49-35.png
seems to be a typo?
You do not have the required permissions to view the files attached to this post.
Last edited by duje on Fri May 10, 2019 4:50 am, edited 1 time in total.

User avatar
Eadwine Rose
Forum Veteran
Forum Veteran
Posts: 8241
Joined: Wed Jul 12, 2006 2:10 am

Re: After small update package managers are all messsed up

#2

Post by Eadwine Rose » Fri May 10, 2019 4:08 am

Can you post the content of MX tools - quick system info?
MX-18.3_x64 May 26 2019 * 4.19.0-5-amd64 ext4 Xfce 4.12.3 * 8-core AMD Ryzen 7 2700
Asus TUF B450-Plus Gaming UEFI * Asus GTX 1050 Ti Nvidia 390.116 * 2x16Gb DDR4 2666 Kingston HyperX Predator
Samsung 860EVO * Samsung S24D330 & P2250 * HP Envy5030

User avatar
duje
Forum Novice
Forum  Novice
Posts: 9
Joined: Thu May 09, 2019 12:28 pm

Re: After small update package managers are all messsed up

#3

Post by duje » Fri May 10, 2019 4:11 am

sure, but before this update everything was working fine

Code: Select all

System:
  Host: mx Kernel: 4.19.0-1-amd64 x86_64 bits: 64 compiler: gcc v: 6.3.0 
  Desktop: Gnome 3.22.3 Distro: MX-18.2_x64 Continuum Apr 7  2019 
  base: Debian GNU/Linux 9 (stretch) 
Machine:
  Type: Desktop Mobo: ASRock model: 970 Pro3 serial: <filter> 
  UEFI: American Megatrends v: P1.10 date: 04/23/2012 
CPU:
  Topology: Quad Core model: AMD Phenom II X4 965 bits: 64 type: MCP 
  arch: K10 rev: 3 L2 cache: 2048 KiB 
  flags: lm nx pae sse sse2 sse3 sse4a svm bogomips: 27140 
  Speed: 800 MHz min/max: 800/3400 MHz Core speeds (MHz): 1: 800 2: 800 
  3: 800 4: 2200 
Graphics:
  Device-1: NVIDIA GF114 [GeForce GTX 560 SE] vendor: Micro-Star MSI 
  driver: nvidia v: 390.116 bus ID: 01:00.0 
  Display: x11 server: X.Org 1.19.2 driver: nvidia resolution: 1024x768~60Hz 
  OpenGL: renderer: GeForce GTX 560 SE/PCIe/SSE2 v: 4.6.0 NVIDIA 390.116 
  direct render: Yes 
Audio:
  Device-1: AMD SBx00 Azalia vendor: ASRock driver: snd_hda_intel v: kernel 
  bus ID: 00:14.2 
  Device-2: NVIDIA GF114 HDMI Audio vendor: Micro-Star MSI 
  driver: snd_hda_intel v: kernel bus ID: 01:00.1 
  Sound Server: ALSA v: k4.19.0-1-amd64 
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: ASRock driver: r8169 v: kernel port: d000 bus ID: 05:00.0 
  IF: eth0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
Drives:
  Local Storage: total: 465.76 GiB used: 33.19 GiB (7.1%) 
  ID-1: /dev/sda vendor: Western Digital model: WD5000AAKX-003CA0 
  size: 465.76 GiB 
Partition:
  ID-1: / size: 455.21 GiB used: 33.19 GiB (7.3%) fs: ext4 dev: /dev/sda2 
  ID-2: swap-1 size: 2.00 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda3                                        
Sensors:                                                                                                        
  System Temperatures: cpu: 45.1 C mobo: N/A gpu: nvidia temp: 35 C 
  Fan Speeds (RPM): N/A gpu: nvidia fan: 40% 
Repos:
  Active apt repos in: /etc/apt/sources.list.d/antix.list 
  1: deb https://mirrors.evowise.com/mxlinux-packages/antix/stretch/ stretch main
  Active apt repos in: /etc/apt/sources.list.d/debian-stable-updates.list 
  1: deb http://debian.iskon.hr/debian/ stretch-updates main contrib non-free
  Active apt repos in: /etc/apt/sources.list.d/debian.list 
  1: deb http://debian.iskon.hr/debian/ stretch main contrib non-free
  2: deb http://security.debian.org/ stretch/updates main contrib non-free
  Active apt repos in: /etc/apt/sources.list.d/mx.list 
  1: deb https://mirrors.evowise.com/mxlinux-packages/mx/repo/ stretch main non-free
  Active apt repos in: /etc/apt/sources.list.d/opera-stable.list 
  1: deb https://deb.opera.com/opera-stable/ stable non-free #Opera Browser (final releases)
  Active apt repos in: /etc/apt/sources.list.d/various.list 
  1: deb http://deb.opera.com/opera/ stable non-free
Info:
  Processes: 180 Uptime: 28m Memory: 7.77 GiB used: 1.77 GiB (22.7%) 
  Init: SysVinit runlevel: 5 Compilers: gcc: 6.3.0 Shell: bash v: 4.4.12 
  inxi: 3.0.33 

User avatar
duje
Forum Novice
Forum  Novice
Posts: 9
Joined: Thu May 09, 2019 12:28 pm

Re: After small update package managers are all messsed up

#4

Post by duje » Fri May 10, 2019 4:24 am

this is wat i get at the end while trying to install vivaldi at the end, and nothing installs

Code: Select all

Reading package lists...
E: Failed to fetch https://mirrors.evowise.com/mxlinux-packages/mx/repo/dists/stretch/main/binary-i386/Packages.gz  Hash Sum mismatch
   Hashes of expected file:
    - Filesize:506597 [weak]
    - SHA256:c802f168c0459aaf9854723e40f253a64680623ad997856b0ec1113a5300e70a
    - SHA1:b7d6238a7e38edd7246ec86610ec7f9cb2c31c92 [weak]
    - MD5Sum:e581fc9cee873e4e0cad1bae8aafce2d [weak]
   Hashes of received file:
    - SHA256:e424722a75b362706bd113acd50d93ae46764e17d69794d4f0229c16f115e182
    - SHA1:5b4890c5cb33c06e6d15e3a44f4b5ba038639ad4 [weak]
    - MD5Sum:2e2dd67930840cf2d18f1751eb500a1d [weak]
    - Filesize:506158 [weak]
   Last modification reported: Thu, 09 May 2019 12:35:57 +0000
   Release file created at: Fri, 10 May 2019 02:06:27 +0000
E: Some index files failed to download. They have been ignored, or old ones used instead.
i get the same error when just pressing reload in synaptic

User avatar
duje
Forum Novice
Forum  Novice
Posts: 9
Joined: Thu May 09, 2019 12:28 pm

Re: After small update package managers are all messsed up

#5

Post by duje » Fri May 10, 2019 4:31 am

Ok guys, I seem to fix it by switching to another source, it seems to be an issue with anycast worldwide

User avatar
Eadwine Rose
Forum Veteran
Forum Veteran
Posts: 8241
Joined: Wed Jul 12, 2006 2:10 am

Re: After small update package managers are all messsed up

#6

Post by Eadwine Rose » Fri May 10, 2019 4:33 am

Ah good, glad to hear it! :) You did use the repo manager?

If that indeed solves it, can you go back to the first post, click that pencil icon and put SOLVED in the post title? Thanks!

Welcome to the forums!
MX-18.3_x64 May 26 2019 * 4.19.0-5-amd64 ext4 Xfce 4.12.3 * 8-core AMD Ryzen 7 2700
Asus TUF B450-Plus Gaming UEFI * Asus GTX 1050 Ti Nvidia 390.116 * 2x16Gb DDR4 2666 Kingston HyperX Predator
Samsung 860EVO * Samsung S24D330 & P2250 * HP Envy5030

User avatar
duje
Forum Novice
Forum  Novice
Posts: 9
Joined: Thu May 09, 2019 12:28 pm

Re: After small update package managers are all messsed up

#7

Post by duje » Fri May 10, 2019 4:47 am

yeah I switched to another source and that solved installation issue, however I still get the same error when checking for updates in Gnome Software, which to me seems like a one letter typo probably because Gnome Software uses worldwide source by default.
Sure ill put it, and tnx for the welcome

User avatar
asqwerth
Forum Veteran
Forum Veteran
Posts: 4584
Joined: Sun May 27, 2007 5:37 am

Re: [SOLVED]After small update package managers are all messsed up

#8

Post by asqwerth » Fri May 10, 2019 8:16 am

Is gnome software compatible with MX? Where did you install it from? Normal debian repositories?
Desktop: Intel i5-4460, 16GB RAM, Intel integrated graphics
Clevo N130WU-based Ultrabook: Intel i7-8550U (Kaby Lake R), 16GB RAM, Intel integrated graphics (UEFI)
ASUS X42D laptop: AMD Phenom II, 6GB RAM, Mobility Radeon HD 5400

Post Reply

Return to “Bugs and Non-Package Requests Forum”