Welcome!

The kernel problem with recent updates has been solved. Find the solution here

Important information
-- Required MX 15/16 Repository Changes
-- Information on torrent hosting changes
-- Information on MX15/16 GPG Keys
-- Spectre and Meltdown vulnerabilities

News
-- Introducing our new Website
-- MX Linux on social media: here

Current releases
-- MX-18.3 Point Release release info here
-- Migration Information to MX-18 here
-- antiX-17.4.1 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

Pepakura fails to run under Wine.

Report Bugs, Issues and non- package Requests
Post Reply
John Gay
Forum Novice
Forum  Novice
Posts: 21
Joined: Mon May 06, 2019 7:56 am

Pepakura fails to run under Wine.

#1

Post by John Gay » Mon May 06, 2019 8:17 am

I've just started playing with MX Linux and am really looking forward to getting to know it.
I have an HP XW8600 with a Zeon x5260, 32G RAM and 4 X 500GB Drives.
It's got an NVidia graphics card, but I don't remember they type right now.

I installed Wine using the MX Package Installer. Then I tried to install Pepakura Designer from tamasoft.co.jp
The Pepakura Install Wizard appears to work fine and it only fails after trying to open the program.
I get a DIB Init Faild [OK] and a Rendering Content Create Failed [OK] error boxes twice then a Wine Program Error box opens.

When I try to run it manually with the wine commandline is says init_opengl Failed to load OSMesa.so.8: cannot open shared object file.
I did try installing the OpenGL32.dll as suggested on WineHQ, but that is only for a rendering problem within the program. I didn't bother with that on my Bodhi Laptop yet.

Running wine --check-libs reports libOSMesa.so.8: missing.

I have installed libosmesa6 but wine still reports it is missing.

I vaguely remember having a similar issue when I first installed this on my Bodhi Linux Laptop, but I thing installing libosmesa6 fixed it there.

Otherwise, I really like to look and feel of MX Linux and am really looking forward to making it my regular OS.

Cheers,

John Gay

User avatar
fehlix
Forum Veteran
Forum Veteran
Posts: 4574
Joined: Wed Apr 11, 2018 5:09 pm

Re: Pepakura fails to run under Wine.

#2

Post by fehlix » Mon May 06, 2019 8:33 am

John Gay wrote:
Mon May 06, 2019 8:17 am
I installed Wine using the MX Package Installer.
Yes, install through MX Package Installer -> Popular Apps : Wine , which will install the package winehq-staging
John Gay wrote:
Mon May 06, 2019 8:17 am
I have installed libosmesa6 but wine still reports it is missing.
As this is probably a 32bit wine running, you might try to install libosmesa6:i386 also.
Gigabyte Z77M-D3H, Intel Xeon E3-1240 V2 (Quad core), 32GB RAM,
GeForce GTX 770, Samsung SSD 850 EVO 500GB, Seagate Barracuda 4TB

John Gay
Forum Novice
Forum  Novice
Posts: 21
Joined: Mon May 06, 2019 7:56 am

Re: Pepakura fails to run under Wine.

#3

Post by John Gay » Mon May 06, 2019 9:03 am

Thanks for the nearly instantaneous reply!
Hadn't even thought of that.
I'll try that tonight and see if it fixes my problem!
If it does, then my Lenovo X200 is up for an upgrade! Just to see how well this distro works on old hardware.

Cheers,

John Gay

John Gay
Forum Novice
Forum  Novice
Posts: 21
Joined: Mon May 06, 2019 7:56 am

Re: Pepakura fails to run under Wine.

#4

Post by John Gay » Mon May 06, 2019 8:21 pm

Installing libosmesa6:i386 has fixed my problem.
Pepakura now runs fine. Though I did have to use apt-get install to force the i386 version to install. But that's a minor quibble.
Thanx again for the amazing distro and quick help.

John Gay
Forum Novice
Forum  Novice
Posts: 21
Joined: Mon May 06, 2019 7:56 am

Re: Pepakura fails to run under Wine.

#5

Post by John Gay » Thu May 16, 2019 8:44 pm

Test drive on Thinkpad X200 successful. After installing both libosmesa6 and libosmesa6:i386 pepakura runs.
But running from DVD system started thrashing. But considering the DVD Drive is in the loading dock I'm sure it'll be O.K. from hard drive.

Post Reply

Return to “Bugs and Non-Package Requests Forum”