Welcome!

The kernel problem with recent updates has been solved. Find the solution here

Important information
-- Required MX 15/16 Repository Changes
-- Information on torrent hosting changes
-- Information on MX15/16 GPG Keys
-- Spectre and Meltdown vulnerabilities

News
-- Introducing our new Website
-- MX Linux on social media: here

Current releases
-- MX-18.3 Point Release release info here
-- Migration Information to MX-18 here
-- antiX-17.4.1 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

Update to PIA VPN

Report Bugs, Issues and non- package Requests
User avatar
fehlix
Developer
Posts: 4866
Joined: Wed Apr 11, 2018 5:09 pm

Re: Update to PIA VPN

#31

Post by fehlix » Mon May 20, 2019 5:29 pm

TerryL wrote:
Mon May 20, 2019 5:22 pm
I got this working (with I assume the latest version).
Have you tried latest PIAVPN installer from MX Package installer -> popular apps should work in normal sysVinit.
:puppy:
Gigabyte Z77M-D3H, Intel Xeon E3-1240 V2 (Quad core), 32GB RAM,
GeForce GTX 770, Samsung SSD 850 EVO 500GB, Seagate Barracuda 4TB

User avatar
handy
Forum Regular
Forum Regular
Posts: 338
Joined: Mon Apr 23, 2018 2:00 pm

Re: Update to PIA VPN

#32

Post by handy » Mon May 20, 2019 7:24 pm

I only noticed yesterday in a post by richb, where he mentioned as an aside that the dev's had made the PIA-VPN client work on MX without systemd. :D

So I PM'd him & asked if all I had to do was delete the old version & install the new package.

He said yes, & to use the mx-packageinstaller "Popular Applications" tab / Network / PIAVPN

Which I did, with not problems. :number1:

The terminal command that you need to use to delete what needs to be deleted (from a not running PIA-VPN client install) follows:

Code: Select all

rm -rf ~/.pia_manager/
Clevo N'book (2014): P150SM-A
CPU: i7-4810MQ (Haswell) Speed: 2800/3800 MHz
RAM: 16 GiB 1600 MHz DDR3
GPU-1: i915
GPU-2: NVIDIA GK104M [GeForce GTX 880M] vRAM: 8GB 2500 Mhz DDR5
Storage: TOSHIBA 931.51 GiB. HGST 931.51 GiB. Crucial 223.57 GiB (M.2 SSD)

User avatar
TerryL
Forum Novice
Forum  Novice
Posts: 28
Joined: Wed Jun 13, 2018 3:05 pm

Re: Update to PIA VPN

#33

Post by TerryL » Tue May 28, 2019 7:39 pm

I hadn't see that, just tried and it works.

Now, what happens when their next update comes along... we'll wait and see

Thanks for the heads up

User avatar
TerryL
Forum Novice
Forum  Novice
Posts: 28
Joined: Wed Jun 13, 2018 3:05 pm

Re: Update to PIA VPN

#34

Post by TerryL » Tue May 28, 2019 7:47 pm

Oh, and I deleted the .pia whatever directory via the file manager, not "old school" but far less likely that old fumble fingers here will screw up an "rm -rf" command and end up crying like a... whatever cries
;)

User avatar
TerryL
Forum Novice
Forum  Novice
Posts: 28
Joined: Wed Jun 13, 2018 3:05 pm

Re: Update to PIA VPN

#35

Post by TerryL » Tue Jun 04, 2019 8:37 pm

Well, there's my answer. Just update from PIA 1.2 to 1.2.1 with no bother

Post Reply

Return to “Bugs and Non-Package Requests Forum”