Welcome!

The kernel problem with recent updates has been solved. Find the solution here

Important information
-- Required MX 15/16 Repository Changes
-- Information on torrent hosting changes
-- Information on MX15/16 GPG Keys
-- Spectre and Meltdown vulnerabilities

News
-- Introducing our new Website
-- MX Linux on social media: here

Current releases
-- MX-18.3 Point Release release info here
-- Migration Information to MX-18 here
-- antiX-17.4.1 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

(SOLVED) MX-18 fresh installation - CPU 100% ????

Report Bugs, Issues and non- pacakage Requests
fanisatt
Forum Novice
Forum  Novice
Posts: 49
Joined: Sun Dec 24, 2017 8:29 am

Re: (Solved) MX-18 fresh installation - CPU 100% ????

#11

Post by fanisatt » Sat Feb 02, 2019 4:30 am

@ baldyeti
No error !! It is a blank screen.
I don't know if I have to do something with nvidia drivers I have already installed with 4.19 !
Last edited by fanisatt on Sat Feb 02, 2019 2:04 pm, edited 1 time in total.

User avatar
baldyeti
Forum Regular
Forum Regular
Posts: 198
Joined: Sat Dec 05, 2009 4:37 pm

Re: MX-18 fresh installation - CPU 100% ????

#12

Post by baldyeti » Sat Feb 02, 2019 4:39 am

Ah sorry i do not have a system with an nvidia adapter anymore.

I thought once you have it in place it should automatically install for kernels you add but i am not sure.

You could try (perhaps from a text/console session <Ctrl><Alt><F1>) to rename the /etc/X11/xorg.conf file the nvidia driver uses, then reboot under the new kernel.
If you then get to the graphical desktop you would probably be using the nouveau driver and could decide to re-install the proprietary driver under the debian kernel if you need it.

User avatar
dolphin_oracle
Forum Veteran
Forum Veteran
Posts: 11564
Joined: Sun Dec 16, 2007 1:17 pm

Re: MX-18 fresh installation - CPU 100% ????

#13

Post by dolphin_oracle » Sat Feb 02, 2019 9:11 am

installing from MX-PI 's kernel area should have rebuilt the nvidia driver if it was installed with our nvidia-driver tool.

try this:

Code: Select all

dpkg-reconfigure nvidia-kernel-dkms
and post the output.
http://www.youtube.com/runwiththedolphin
lenovo ThinkPad T530 - MX-18
lenovo s21e - MX-18, antiX-17.3.1 (live-USB)
FYI: mx "test" repo is not the same thing as debian testing repo.

fanisatt
Forum Novice
Forum  Novice
Posts: 49
Joined: Sun Dec 24, 2017 8:29 am

Re: MX-18 fresh installation - CPU 100% ????

#14

Post by fanisatt » Sat Feb 02, 2019 10:28 am

Thank you all for your replies.
I tried "sudo ddm-mx -p nvidia" and the nvidia drivers uninstalled successfully.
After this , I could boot with the DEBIAN kernel and my system seems ok now.
Best regards.
(Solved)

User avatar
richb
Administrator
Posts: 18870
Joined: Wed Jul 12, 2006 2:17 pm

Re: MX-18 fresh installation - CPU 100% ????

#15

Post by richb » Sat Feb 02, 2019 10:33 am

Please add {Solved} to the title of your first post
Forum Rules
Guide - How to Ask for Help

Rich
SSD Production: MX 18.1
AMD A8 7600 FM2+ CPU R7 Graphics, 16 GIG Mem. Three Samsung EVO SSD's 250 GB, 350 GB HD

User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 19360
Joined: Fri Dec 15, 2006 8:07 pm

Re: MX-18 fresh installation - CPU 100% ????

#16

Post by Stevo » Sat Feb 02, 2019 12:52 pm

You should also be able to reinstall the Nvidia drivers on the 4.9 kernel, as apparently they were not rebuilt automatically when you reinstalled.

Does the 4.9 kernel enable the CPU speed scaling now?

fanisatt
Forum Novice
Forum  Novice
Posts: 49
Joined: Sun Dec 24, 2017 8:29 am

Re: MX-18 fresh installation - CPU 100% ????

#17

Post by fanisatt » Sat Feb 02, 2019 2:00 pm

@ Stevo
Oh yes !! All done successfully !

Post Reply

Return to “Bugs and Non-Package Requests Forum”