Welcome!

The kernel problem with recent updates has been solved. Find the solution here

Important information
-- Required MX 15/16 Repository Changes
-- Information on torrent hosting changes
-- Information on MX15/16 GPG Keys
-- Spectre and Meltdown vulnerabilities

News
-- Introducing our new Website
-- MX Linux on social media: here

Current releases
-- MX-18.3 Point Release release info here
-- Migration Information to MX-18 here
-- antiX-17.4.1 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

Wifi does not reconnect after hibernate/sleep

Report Bugs, Issues and non- package Requests
Post Reply
CiaraRSeeley
Forum Novice
Forum  Novice
Posts: 35
Joined: Sat Dec 01, 2018 12:05 pm

Wifi does not reconnect after hibernate/sleep

#1

Post by CiaraRSeeley » Mon Jan 07, 2019 2:04 pm

Hello,

I assume this behaviour is a bug, so I want to share it here. Perhaps there is even a solution?

I go to sleep or hibernate, I come back and the network applet tells me, that I am still connected. Since it thinks I am still connected, it does not reconnect me. Though the internet is not working. The only thing I can do is close the connection manually and reconnect manually. Waiting does not help.

It would be helpful if it would automatically reconnect after sleep/hibernate.

Code: Select all

System:    Host: mx Kernel: 4.19.0-1-amd64 x86_64 bits: 64 compiler: gcc v: 6.3.0 
           Desktop: Xfce 4.12.3 Distro: MX-18_x64 Continuum Dec 20  2018 
           base: Debian GNU/Linux 9 (stretch) 
Machine:   Type: Desktop System: Intel product: KBL-R MRD v: 0.1 serial: <filter> 
           Mobo: Intel model: MIR1 v: RVP7 serial: <filter> UEFI [Legacy]: American Megatrends 
           v: 5.12 date: 07/12/2018 
CPU:       Topology: Quad Core model: Intel Core i7-8650U bits: 64 type: MT MCP arch: Kaby Lake 
           rev: A L2 cache: 8192 KiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 33792 
           Speed: 813 MHz min/max: 400/4200 MHz Core speeds (MHz): 1: 808 2: 824 3: 828 4: 835 
           5: 800 6: 827 7: 829 8: 829 
Graphics:  Device-1: Intel driver: i915 v: kernel bus ID: 00:02.0 
           Display: x11 server: X.Org 1.19.2 driver: modesetting unloaded: fbdev,vesa 
           resolution: 1920x1080~60Hz 
           OpenGL: renderer: Mesa DRI Intel UHD Graphics 620 (Kabylake GT2) v: 4.5 Mesa 18.2.6 
           direct render: Yes 
Audio:     Device-1: Intel driver: snd_hda_intel v: kernel bus ID: 00:1f.3 
           Sound Server: ALSA v: k4.19.0-1-amd64 
Network:   Device-1: Intel Wireless 3165 driver: iwlwifi v: kernel port: f040 bus ID: 01:00.0 
           IF: wlan0 state: up mac: <filter> 
           Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8169 
           v: kernel port: e000 bus ID: 02:00.0 
           IF: eth0 state: down mac: <filter> 
Drives:    Local Storage: total: 491.78 GiB used: 124.70 GiB (25.4%) 
           ID-1: /dev/sda vendor: SanDisk model: SD8SN8U512G1027 size: 476.94 GiB 
           ID-2: /dev/sdb type: USB vendor: Generic model: Flash size: 14.84 GiB 
Partition: ID-1: / size: 19.10 GiB used: 8.09 GiB (42.3%) fs: ext4 dev: /dev/sda6 
           ID-2: /home size: 347.75 GiB used: 116.61 GiB (33.5%) fs: ext4 dev: /dev/sda7 
Sensors:   System Temperatures: cpu: 57.0 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Repos:     Active apt repos in: /etc/apt/sources.list.d/antix.list 
           1: deb https://mxlinux.mirror.iphh.net/packages/antix/stretch/ stretch main
           Active apt repos in: /etc/apt/sources.list.d/debian-stable-updates.list 
           1: deb http://ftp.de.debian.org/debian/ stretch-updates main contrib non-free
           Active apt repos in: /etc/apt/sources.list.d/debian.list 
           1: deb http://ftp.de.debian.org/debian/ stretch main contrib non-free
           2: deb http://security.debian.org/ stretch/updates main contrib non-free
           Active apt repos in: /etc/apt/sources.list.d/headset.list 
           1: deb [arch=amd64] http://headsetapp.co/headset-electron/debian stable non-free
           Active apt repos in: /etc/apt/sources.list.d/megasync.list 
           1: deb https://mega.nz/linux/MEGAsync/Debian_9.0/ ./
           Active apt repos in: /etc/apt/sources.list.d/mx.list 
           1: deb https://mxlinux.mirror.iphh.net/packages/mx/repo/ stretch main non-free
           No active apt repos in: /etc/apt/sources.list.d/various.list 
           Active apt repos in: /etc/apt/sources.list.d/vivaldi.list 
           1: deb http://repo.vivaldi.com/stable/deb/ stable main
Info:      Processes: 272 Uptime: 5h 55m Memory: 15.46 GiB used: 3.55 GiB (22.9%) Init: SysVinit 
           runlevel: 5 Compilers: gcc: 6.3.0 Shell: bash v: 4.4.12 inxi: 3.0.29 

User avatar
kc1di
Forum Novice
Forum  Novice
Posts: 93
Joined: Sun Sep 28, 2008 8:47 am

Re: Wifi does not reconnect after hibernate/sleep

#2

Post by kc1di » Sun Jan 13, 2019 4:43 am

what is the output of

Code: Select all

iwconfig
?

User avatar
Stevo
Developer
Posts: 20113
Joined: Fri Dec 15, 2006 8:07 pm

Re: Wifi does not reconnect after hibernate/sleep

#3

Post by Stevo » Sun Jan 13, 2019 6:22 pm

Try this solution from our wiki: https://mxlinux.org/wiki/networking/wifi-suspend-issues

In your case, like mine, the driver is "iwlwifi". I have to do this for two laptops.
Possibly we could add the config file with an assortment of module names to the default install or to a MX config package, since several users have reported the same problem.

CiaraRSeeley
Forum Novice
Forum  Novice
Posts: 35
Joined: Sat Dec 01, 2018 12:05 pm

Re: Wifi does not reconnect after hibernate/sleep

#4

Post by CiaraRSeeley » Thu Jan 17, 2019 10:09 am

Great! It worked! Awesome! Thank you.

Post Reply

Return to “Bugs and Non-Package Requests Forum”