Welcome!

The kernel problem with recent updates has been solved. Find the solution here

Important information
-- Required MX 15/16 Repository Changes
-- Information on torrent hosting changes
-- Information on MX15/16 GPG Keys
-- Spectre and Meltdown vulnerabilities

News
-- Introducing our new Website
-- MX Linux on social media: here

Current releases
-- MX-18.3 Point Release release info here
-- Migration Information to MX-18 here
-- antiX-17.4.1 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

XUL based Applications besides Palemoon

Report Bugs, Issues and non- package Requests
Post Reply
User avatar
galaxysurfer
Forum Regular
Forum Regular
Posts: 137
Joined: Mon Jul 16, 2018 5:14 am

XUL based Applications besides Palemoon

#1

Post by galaxysurfer » Fri Jan 04, 2019 3:10 pm

Hi,

I came across this page http://thereisonlyxul.org/while looking for compatible extensions for my Palemoon install. Is it possible to get the email client as well as any of the not already included XUL based offerings to our package Library?

Thanx & Keep up the great work!

User avatar
galaxysurfer
Forum Regular
Forum Regular
Posts: 137
Joined: Mon Jul 16, 2018 5:14 am

Re: XUL based Applications besides Palemoon

#2

Post by galaxysurfer » Fri Jan 04, 2019 3:23 pm

What I was hoping for were the Hyperbola offerings.

User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 19577
Joined: Fri Dec 15, 2006 8:07 pm

Re: XUL based Applications besides Palemoon

#3

Post by Stevo » Fri Jan 04, 2019 4:24 pm

Isn't our Thunderbird 52.9 still based on XUL?

That page is sorta old, and I don't think there's been much work on the email client at all--try and find where to get the source, for example.

User avatar
galaxysurfer
Forum Regular
Forum Regular
Posts: 137
Joined: Mon Jul 16, 2018 5:14 am

Re: XUL based Applications besides Palemoon

#4

Post by galaxysurfer » Fri Jan 04, 2019 4:40 pm

I was mainly wanting a pre web based email client like Thunderbird Ver 52 build with newer version hahaving moved to WebExtension APIs since they are still tied to Mozilla. Ideally I would like a security updated version of Fossamail. I like Moonchild's iteration of Goanna gecko for 64 bit support. I have many email accounts that I agreggate which Thunderbird tends to crash. Unfortunately Fossamail has been mothballed & the replacement by another developer isn't including the calendar & other functionality I use. Maybe the better question to ask is if you will support Thunderbird 52 version with security updates in the future or will move to the latest version of Thunderbird based on WebExtension APIs?

User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 19577
Joined: Fri Dec 15, 2006 8:07 pm

Re: XUL based Applications besides Palemoon

#5

Post by Stevo » Fri Jan 04, 2019 4:48 pm

Mozilla will probably stop supporting Thunderbird 52 in the near future, if they haven't quit already. Debian already has moved Thunderbird 60.4 into Stretch to address this, and they also have some updated extensions in the upstream repos that support the new API...but everyone has some favorite one that's not been updated. :frown:

We also have 60.X in the test repo, and may be forced eventually to move it to main. We build our own version to fix some issue with the language packs, I think.

User avatar
Eadwine Rose
Forum Veteran
Forum Veteran
Posts: 8681
Joined: Wed Jul 12, 2006 2:10 am

Re: XUL based Applications besides Palemoon

#6

Post by Eadwine Rose » Fri Jan 04, 2019 5:03 pm

Stevo wrote:
Fri Jan 04, 2019 4:48 pm
Mozilla will probably stop supporting Thunderbird 52 in the near future, if they haven't quit already. Debian already has moved Thunderbird 60.4 into Stretch to address this, and they also have some updated extensions in the upstream repos that support the new API...but everyone has some favorite one that's not been updated. :frown:

We also have 60.X in the test repo, and may be forced eventually to move it to main. We build our own version to fix some issue with the language packs, I think.
60.3.1 is on my working machine, has been running fine for me in any case. 60.4 is one I didn't upgrade to because I didn't really trust the changelog issues bit. But 60.3.1 is working fine for me :)
MX-18.3_x64 May 26 2019 * 4.19.0-5-amd64 ext4 Xfce 4.12.3 * 8-core AMD Ryzen 7 2700
Asus TUF B450-Plus Gaming UEFI * Asus GTX 1050 Ti Nvidia 390.116 * 2x16Gb DDR4 2666 Kingston HyperX Predator
Samsung 860EVO * Samsung S24D330 & P2250 * HP Envy5030

Post Reply

Return to “Bugs and Non-Package Requests Forum”