Welcome!
Important information
-- Spectre and Meltdown vulnerabilities
-- Change in MX sources

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-17.1 Final release info here
-- antiX-17 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

HPcupsfilter SHIVA inside while loop bug (bug already in launchpad)

Report Bugs, Issues and non- pacakage Requests
Post Reply
Message
Author
User avatar
Eadwine Rose
Forum Veteran
Forum Veteran
Posts: 6396
Joined: Wed Jul 12, 2006 2:10 am

HPcupsfilter SHIVA inside while loop bug (bug already in launchpad)

#1 Post by Eadwine Rose » Mon Nov 26, 2018 9:30 am

This is more of a let-you-know than a help-me-solve-this-please.


Running driver 3.18.7 here, but read over on this link in the very last post that the latest available in the test repo, 3.18.10, has the same issue: https://bugs.launchpad.net/hplip/+bug/1787289


My printer DOES print, it just fills up the log with messages, which I can live with to be honest. I'd much rather it fills up the log than that it won't print like some of the guys in that topic seem to have happen. ;)


This is what this looks like in my syslog:

Code: Select all

Nov 26 14:12:03 mx17 hpcups[23183]: prnt/hpcups/HPCupsFilter.cpp 642: DEBUG: SHIVA inside the while loop
Nov 26 14:12:03 mx17 hp[23184]: io/hpmud/musb.c 427: Found interface conf=0, iface=1, altset=0, index=1
Nov 26 14:12:03 mx17 hp[23184]: io/hpmud/musb.c 389: Active kernel driver on interface=1 ret=0
Nov 26 14:12:03 mx17 hp[23184]: io/hpmud/musb.c 535: claimed 7/1/2 interface
Nov 26 14:12:03 mx17 hp[23184]: io/hpmud/musb.c 781: read actual device_id successfully fd=1 len=283
Nov 26 14:12:03 mx17 hp[23184]: io/hpmud/musb.c 561: released 7/1/2 interface
Nov 26 14:12:03 mx17 hp[23184]: io/hpmud/musb.c 961: new PRINT channel=2 clientCnt=1 channelCnt=1
Nov 26 14:12:03 mx17 hp[23184]: io/hpmud/musb.c 427: Found interface conf=0, iface=1, altset=0, index=1
Nov 26 14:12:03 mx17 hp[23184]: io/hpmud/musb.c 389: Active kernel driver on interface=1 ret=0
Nov 26 14:12:03 mx17 hp[23184]: io/hpmud/musb.c 535: claimed 7/1/2 interface
Nov 26 14:12:03 mx17 hpcups[23183]: prnt/hpcups/HPCupsFilter.cpp 642: DEBUG: SHIVA inside the while loop
Nov 26 14:12:09 mx17 hpcups[23183]: prnt/hpcups/HPCupsFilter.cpp 642: DEBUG: SHIVA inside the while loop
Nov 26 14:12:10 mx17 hpcups[23183]: prnt/hpcups/HPCupsFilter.cpp 642: DEBUG: SHIVA inside the while loop
Nov 26 14:12:16 mx17 hpcups[23183]: prnt/hpcups/HPCupsFilter.cpp 642: DEBUG: SHIVA inside the while loop
Nov 26 14:12:29 mx17 hpcups[23183]: prnt/hpcups/HPCupsFilter.cpp 642: DEBUG: SHIVA inside the while loop
Nov 26 14:12:44 mx17 hp[23184]: io/hpmud/musb.c 561: released 7/1/2 interface
Nov 26 14:12:44 mx17 hp[23184]: io/hpmud/musb.c 976: removed PRINT channel=2 clientCnt=0 channelCnt=0

It invokes the deity for every printed page. :laugh:


I just printed the book I am writing to start checking for silly errors (already checked on the computer, but on paper other stuff stands out), so for today Shiva was hailed a total of 103 times. The book should be holy by now I think :worship:
MX-17.1_x64 Horizon 3-2018 * 4.15.0-1-amd64 ext4 Xfce 4.12.3 * AMD Asus M4A785TD-V EVO AM3 * ASUS GF GT640-1GD5-L NVIDIA 384.130 * AMD Proc. Athl II X4 635, sAM3 * HDA ATI SB VT1708S An * 2x4Gb DDR3 1600 Kingst * 22" Samsung SyncM P2250 * HP Envy5030

User avatar
Eadwine Rose
Forum Veteran
Forum Veteran
Posts: 6396
Joined: Wed Jul 12, 2006 2:10 am

Re: HPcupsfilter SHIVA inside while loop bug (bug already in launchpad)

#2 Post by Eadwine Rose » Mon Nov 26, 2018 11:47 am

Hrmmm not quite sure I've got the right bug thing linked in my post..

https://bugs.launchpad.net/hplip/+bug/1788706 also contains the shiva thing.. maybe that is a generic message? But in any case here it says reverting to 3.18.6 sorts out their issue. It contains so much jargon that I am getting confuzzled.


if someone would care to take a looksee because I feel none are an exact match to what I have. NO RUSH!! As I said: printer works, so I am happy ;)
MX-17.1_x64 Horizon 3-2018 * 4.15.0-1-amd64 ext4 Xfce 4.12.3 * AMD Asus M4A785TD-V EVO AM3 * ASUS GF GT640-1GD5-L NVIDIA 384.130 * AMD Proc. Athl II X4 635, sAM3 * HDA ATI SB VT1708S An * 2x4Gb DDR3 1600 Kingst * 22" Samsung SyncM P2250 * HP Envy5030

Post Reply

Return to “Bugs and Non-Package Requests Forum”