Welcome!
Important information
-- Spectre and Meltdown vulnerabilities
-- Change in MX sources

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-17.1 Final release info here
-- antiX-17 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

ckbcomp: Can not find file "symbols/cz-us-qwerty" in any known directory

Report Bugs, Issues and non- pacakage Requests
Post Reply
Message
Author
User avatar
postcd
Forum Novice
Forum  Novice
Posts: 51
Joined: Mon Oct 29, 2018 2:02 pm

ckbcomp: Can not find file "symbols/cz-us-qwerty" in any known directory

#1 Post by postcd » Tue Oct 30, 2018 6:03 am

Hello,

i faced issue with keyboard when i yesterday installed MX Linux (latest) as a newbie. Because default was english keyboard, when i clicked the US flag nothing happened (i thought it will offer me some language settings), i added czech keymap (click MX menu, search for keyboard, clicked Keyboard "app" and then on Layout tab add czech keymap and made sure it is above english, but that not helped to change language, i had to remove english one and then it started typing czech characters.

during boot appears message like:
...nerating /boot/initrd.img-4.15.0-1-amd64
/usr/bin/ckbcomp: Can not find file "symbols/cz-us-qwerty" in any known directory
Warning: error while trying to store keymap file - ignoring request to install /etc/boottime.kmap.gz
Interesting log lines from /var/log files:
boot:569:Tue Oct 30 10:00:41 2018: [....] Starting cgroup management daemon: cgmanager[....] Setting up console font and keymap.../usr/bin/ckbcomp: Can not find file "symbols/cz-us-qwerty" in any known directory
Xorg.0.log:608:[ 24.878] (**) Option "xkb_layout" "cz-us-qwerty,us"
Xorg.0.log.old:608:[ 25.510] (**) Option "xkb_layout" "cz-us-qwerty,us"
this may be an issue/bug in MX Linux, let me know if you need further commands to be run please. Thank You
Last edited by postcd on Tue Oct 30, 2018 7:04 am, edited 1 time in total.
OS: 4.15.4-1~mx17+1 (2018-02-23) x86_64 ; XFCE 4 ; MB: G31M ES2L rev. 2.0 ; GPU: AMD Radeon RX 560 ; full HW specs. as of Oct 30/2018

User avatar
Richard
Posts: 2151
Joined: Fri Dec 12, 2008 10:31 am

Re: ckbcomp: Can not find file "symbols/cz-us-qwerty" in any known directory

#2 Post by Richard » Tue Oct 30, 2018 6:24 am

Welcome to the MX Linux forum.

The easiest way is to choose the general keyboard, with the F3 key, in the beginning of the MX Installer.
Then you avoid having to do so much searching.


You can do this in a console as root

Code: Select all

dpkg-reconfigure keyboard-configuration
then choose your desired layout.
or
you can use the provided utility by clicking on the menu button >
Menu > Settings > Keyboard > Layout > Add then scroll to Czech and choose your preferred keyboard.

and then there's https://wiki.debian.org/Keyboard with other methods.

All because it is a confusion.
I don't know who you would blame.
It's a common failing and a matter of trial and error to determine the correct parameter for a given keyboard.
Or maybe I've just never found the correct listing.
MX171: Lenovo T430: Intel Ivy Bridge i5-3320M, 8GB RAM, 4.18.0-2-amd64, 119GB SSD
MX171: EeePC 1005HA: Dual Core Atom N270, 1GB RAM, 4.9.0-8-686, 150GB HDD
Thunar/Doublecmd, LibO613, Dropbox, Firefox, CherryTree, Vbox. LinuxCounter #208633

User avatar
fehlix
Forum Guide
Forum Guide
Posts: 2068
Joined: Wed Apr 11, 2018 5:09 pm

Re: ckbcomp: Can not find file "symbols/cz-us-qwerty" in any known directory

#3 Post by fehlix » Tue Oct 30, 2018 9:59 am

postcd wrote:
Tue Oct 30, 2018 6:03 am
but that not helped to change language, i had to remove english one and then it started typing czech characters.
...
How did you remove english keyboard? There is no "cz-us-qwerty" keyboard layout within the Keyboard selecting GUI nor within terminal keyboard configuration "dpkg-reconfigure keyboard-configuration"?
How did you added orselected such a layout?
Anyway, I would do this:
Select system wide valid keyboard using : dpkg-reconfigure keyboard-configuration
and check/select user-session wide using Keyboard selecting gui from Settings.

Note: You can avoid this by selecting proper keyboard when you install MX Linux.
Gigabyte Z77M-D3H, Intel Xeon E3-1240 V2 (Quad core), 32GB RAM,
GeForce GTX 770, Samsung SSD 850 EVO 500GB, Seagate Barracuda 4TB

User avatar
postcd
Forum Novice
Forum  Novice
Posts: 51
Joined: Mon Oct 29, 2018 2:02 pm

Re: ckbcomp: Can not find file "symbols/cz-us-qwerty" in any known directory

#4 Post by postcd » Tue Oct 30, 2018 11:16 am

fehlix wrote:
Tue Oct 30, 2018 9:59 am
How did you remove english keyboard? There is no "cz-us-qwerty" keyboard layout within the Keyboard selecting GUI nor within terminal keyboard configuration "dpkg-reconfigure keyboard-configuration"?
How did you added or selected such a layout?
"when i clicked the US flag (in the left sidebar of the XFCE 4 XM Linux interface) nothing happened (i thought it will offer me some language settings), i added czech keymap (click MX menu, search for keyboard, clicked Keyboard "app" and then on Layout tab Add czech keymap (Add button) and made sure it is above english entry.


Image


I am using "Czech (with <\|>) key"

I deleted US keyb. layout by clicking the entry (was below the czech one on the screenshot) and click Delete button.
fehlix wrote:
Tue Oct 30, 2018 9:59 am
Anyway, I would do this:
Select system wide valid keyboard using : dpkg-reconfigure keyboard-configuration
and check/select user-session wide using Keyboard selecting gui from Settings.

Note: You can avoid this by selecting proper keyboard when you install MX Linux.
Maybe i can use the Keyboard GUI app as seen on the screenshot instead of command line command, right? Because when i run your keyboard reconfigure command, it offer me same keyboard model (Generic 105 key) as seen on the screenshot above..
OS: 4.15.4-1~mx17+1 (2018-02-23) x86_64 ; XFCE 4 ; MB: G31M ES2L rev. 2.0 ; GPU: AMD Radeon RX 560 ; full HW specs. as of Oct 30/2018

User avatar
fehlix
Forum Guide
Forum Guide
Posts: 2068
Joined: Wed Apr 11, 2018 5:09 pm

Re: ckbcomp: Can not find file "symbols/cz-us-qwerty" in any known directory

#5 Post by fehlix » Tue Oct 30, 2018 12:32 pm

postcd wrote:
Tue Oct 30, 2018 11:16 am
Maybe i can use the Keyboard GUI app as seen on the screenshot instead of command line command, right?
Yes.
To be clear:
The command line

Code: Select all

sudo dpkg-reconfigure keyboard-configuration
will allow you to change system wide default keyboard layout.

The Keyboard gui from Settings will allow you to have one or more keyboard layouts
within the user session. This will not change the default system wide settings.

Please note further do not run root-sessions.
MX is meant to run as normal user. Root user shall be used exceptional or
for experts only.)
You can create more troublesome situation if you do so.
E.g if you run root session with a different keyboard layout which is not
the system layout you get lot's of issues.
:puppy:
Gigabyte Z77M-D3H, Intel Xeon E3-1240 V2 (Quad core), 32GB RAM,
GeForce GTX 770, Samsung SSD 850 EVO 500GB, Seagate Barracuda 4TB

User avatar
postcd
Forum Novice
Forum  Novice
Posts: 51
Joined: Mon Oct 29, 2018 2:02 pm

Re: ckbcomp: Can not find file "symbols/cz-us-qwerty" in any known directory

#6 Post by postcd » Tue Oct 30, 2018 1:00 pm

Thanks for explaining the difference between setting keyboard layout for the system (via "dpkg-reconfigure ***" command) and for the user (via GUI).

Btw, the locale drop down menu on login is too hard to orientate regarding alphabetical sorting (has no filtering field, do not react on typing to filter out relevant entries), example "Czech" is very hard to find in it. I added US keyb. layout as a secondary one via Keyboard config. GUI and switching both layouts works nice. (not rebooted yet)
OS: 4.15.4-1~mx17+1 (2018-02-23) x86_64 ; XFCE 4 ; MB: G31M ES2L rev. 2.0 ; GPU: AMD Radeon RX 560 ; full HW specs. as of Oct 30/2018

User avatar
fehlix
Forum Guide
Forum Guide
Posts: 2068
Joined: Wed Apr 11, 2018 5:09 pm

Re: ckbcomp: Can not find file "symbols/cz-us-qwerty" in any known directory

#7 Post by fehlix » Tue Oct 30, 2018 1:12 pm

postcd wrote:
Tue Oct 30, 2018 1:00 pm
Btw, the locale drop down menu on login is too hard to orientate regarding alphabetical sorting
Well spotted. We might think to provide an alternative solution like only display/list of a defined set of keyboard layouts at login screen.
Workaround: Set system wide layout to the prefered one, so you can enter you password.
And change keyboard during session with keyboard switcher or key-combo.
:puppy:
Gigabyte Z77M-D3H, Intel Xeon E3-1240 V2 (Quad core), 32GB RAM,
GeForce GTX 770, Samsung SSD 850 EVO 500GB, Seagate Barracuda 4TB

Post Reply

Return to “Bugs and Non-Package Requests Forum”