Welcome!
Important information
-- Spectre and Meltdown vulnerabilities
-- Change in MX sources

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-17.1 Final release info here
-- antiX-17 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

[Solved] Missing mouse theme integration in QT applications

Report Bugs, Issues and non- pacakage Requests
Post Reply
Message
Author
User avatar
dreamer
Forum Regular
Forum Regular
Posts: 224
Joined: Sun Oct 15, 2017 11:34 am

[Solved] Missing mouse theme integration in QT applications

#1 Post by dreamer » Sun Oct 14, 2018 8:48 am

I'm using Breeze mouse theme from the repos and I'm not seeing any mouse theme integration in QT applications. Anyone else seeing this?
QT apps seem to fallback to "generic" mouse theme.
Last edited by dreamer on Sun Oct 14, 2018 5:30 pm, edited 1 time in total.

User avatar
fehlix
Forum Guide
Forum Guide
Posts: 2030
Joined: Wed Apr 11, 2018 5:09 pm

Re: Missing mouse theme integration in QT applications

#2 Post by fehlix » Sun Oct 14, 2018 12:17 pm

dreamer wrote:
Sun Oct 14, 2018 8:48 am
Anyone else seeing this?
QT apps seem to fallback to "generic" mouse theme.
Works for me. I'm using Capitaine Cursors. :p
Gigabyte Z77M-D3H, Intel Xeon E3-1240 V2 (Quad core), 32GB RAM,
GeForce GTX 770, Samsung SSD 850 EVO 500GB, Seagate Barracuda 4TB

User avatar
dreamer
Forum Regular
Forum Regular
Posts: 224
Joined: Sun Oct 15, 2017 11:34 am

Re: Missing mouse theme integration in QT applications

#3 Post by dreamer » Sun Oct 14, 2018 12:30 pm

fehlix wrote:
Sun Oct 14, 2018 12:17 pm
dreamer wrote:
Sun Oct 14, 2018 8:48 am
Anyone else seeing this?
QT apps seem to fallback to "generic" mouse theme.
Works for me. I'm using Capitaine Cursors. :p
How do I make it work? ;)

User avatar
dolphin_oracle
Forum Veteran
Forum Veteran
Posts: 9575
Joined: Sun Dec 16, 2007 1:17 pm

Re: Missing mouse theme integration in QT applications

#4 Post by dolphin_oracle » Sun Oct 14, 2018 12:53 pm

on my system, cursor theme changes in Qt will be picked up after a login/logout

tested with "obsidian" mouse cursor theme
http://www.youtube.com/runwiththedolphin
lenovo ThinkPad T530 - MX-17
lenovo s21e & 100s - antiX-17, MX17(live-usb)
FYI: mx "test" repo is not the same thing as debian testing repo.

User avatar
dreamer
Forum Regular
Forum Regular
Posts: 224
Joined: Sun Oct 15, 2017 11:34 am

Re: Missing mouse theme integration in QT applications

#5 Post by dreamer » Sun Oct 14, 2018 2:43 pm

dolphin_oracle wrote:
Sun Oct 14, 2018 12:53 pm
on my system, cursor theme changes in Qt will be picked up after a login/logout

tested with "obsidian" mouse cursor theme
The integration was only missing in MXPI and other QT programs running as root. KDE is a known "theme breaker" so I proceeded to completely remove a bunch of (maybe 200) KDE related packages in Synaptic. That did the trick. :popcorn: It's kind of strange, but I'm glad it worked.

User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 16568
Joined: Fri Dec 15, 2006 8:07 pm

Re: Missing mouse theme integration in QT applications

#6 Post by Stevo » Sun Oct 14, 2018 3:40 pm

Root has its own theming. You'll have to run the appearance settings as root to set the cursor theme--for KDE, "kdesu systemsettings5" if you've set the symlink for kdesu as has been suggested in the past.

User avatar
dreamer
Forum Regular
Forum Regular
Posts: 224
Joined: Sun Oct 15, 2017 11:34 am

Re: Missing mouse theme integration in QT applications

#7 Post by dreamer » Sun Oct 14, 2018 5:26 pm

Stevo wrote:
Sun Oct 14, 2018 3:40 pm
Root has its own theming. You'll have to run the appearance settings as root to set the cursor theme--for KDE, "kdesu systemsettings5" if you've set the symlink for kdesu as has been suggested in the past.
Yes, that's true. I didn't think about that because root GTK apps like Synaptic automatically follow user set mouse theme in XFCE and without KDE installed this is true for root QT apps as well.

Post Reply

Return to “Bugs and Non-Package Requests Forum”