Welcome!
Important information
-- Spectre and Meltdown vulnerabilities
-- Change in MX sources

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-17.1 Final release info here
-- antiX-17 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

no dell_smbios: No dell-smbios drivers are loaded

Report Bugs, Issues and non- pacakage Requests
Post Reply
Message
Author
galaxysurfer
Forum Novice
Forum  Novice
Posts: 21
Joined: Mon Jul 16, 2018 5:14 am

no dell_smbios: No dell-smbios drivers are loaded

#1 Post by galaxysurfer » Thu Oct 04, 2018 12:13 pm

i recently installed MXLinux 17.1 on my old trusty Dell Latitude D830 laptop
dell_smbios: No dell-smbios drivers are loaded error message on startup I found this reference to the issue https://bugs.debian.org/cgi-bin/bugrepo ... bug=893976 Has this been addressed in our version of linux kernel? Is it something I need to do on my end to fix this?

galaxysurfer

galaxysurfer
Forum Novice
Forum  Novice
Posts: 21
Joined: Mon Jul 16, 2018 5:14 am

Re: no dell_smbios: No dell-smbios drivers are loaded

#2 Post by galaxysurfer » Thu Oct 04, 2018 12:30 pm

i see the solution seems to be to update to 4.15.17.1 kernel. what is the procedure for updating kernels here so nothing breaks?

User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 16286
Joined: Fri Dec 15, 2006 8:07 pm

Re: no dell_smbios: No dell-smbios drivers are loaded

#3 Post by Stevo » Thu Oct 04, 2018 2:09 pm

Most people will instead update to the latest backported upstream Debian or Liquorix kernels to fix issues like that. Currently we are pushing 4.18 versions of those in the test repo, which hopefully will solve your issue. As is normal for newer kernels and out-of-kernel DKMS drivers, you might have to also upgrade those from the test repo if you're using those (examples are virtualbox and Nvidia DKMS packages).

Since you have an older machine, the standard Debian 4.9 kernel should also be a good choice for you.

turtlebay777
Forum Regular
Forum Regular
Posts: 199
Joined: Sat Apr 14, 2018 2:40 pm

Re: no dell_smbios: No dell-smbios drivers are loaded

#4 Post by turtlebay777 » Thu Oct 04, 2018 3:50 pm

Is the Debian 4.9 Meltdown and Spectre patched?
MX package installer says Meltdown patched only for Debian 4.9

User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 16286
Joined: Fri Dec 15, 2006 8:07 pm

Re: no dell_smbios: No dell-smbios drivers are loaded

#5 Post by Stevo » Thu Oct 04, 2018 6:46 pm

Yes, the 4.9 Debian kernel has the same retpoline fixes for Spectre as newer kernels, as well as still getting the same security upstream fixes as the newer kernels.

We have spectre-meltdown-checker in the MX repo so you can check your running kernels.

Post Reply

Return to “Bugs and Non-Package Requests Forum”