Page 1 of 1

Synaptic Package Manager Does Not Launch App Web Links

Posted: Fri Aug 31, 2018 8:11 pm
by stevedude
Is anyone else having this issue?

I did a clean install of MX Linux 17 just a few weeks ago [details below] and today when I was perusing some of the applications in Synaptic, I clicked the website link provided with the package for more information. It did not matter what package I tried this with, I received the same error each time like something is not set correctly in Synaptic. I searched bugzilla and Google, can't seem to find a similar issue reported.

Firefox is the default browser.

It's not a deal breaker, but it is nice to be able to obtain more information about the package and/or developer.

[Screenshot]
Synaptic.png
There is no proxy network or anything like that. Synaptic Preferences > Network setting
Synaptic2.png

Re: Synaptic Package Manager Does Not Launch App Web Links

Posted: Fri Aug 31, 2018 8:53 pm
by dolphin_oracle
looks like policykit is preventing synaptic from launching the browsers, and perhaps with good reason, as it looks to me that synaptic tries to launch the browser with root level permissions. probably not the best thing to use when going on the internet.

I could get it to work with sudo synaptic, which bypasses policykit, but personally its a bad idea in my mind. synaptic doens't get updated all that often, so the function may be a hold over from the old days. gksu synaptic didn't allow the browser to launch either, probably because the root account doesn't have a default browser.

copying the url and pasting into a browser seems safer, if less convenient. the copy/paste function worked ok on the browser links for me.