Welcome!
Important information
-- Spectre and Meltdown vulnerabilities
-- Change in MX sources

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-17.1 Final release info here
-- antiX-17 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

Synaptic Package Manager Does Not Launch App Web Links

Report Bugs, Issues and non- pacakage Requests
Post Reply
Message
Author
User avatar
stevedude
Forum Novice
Forum  Novice
Posts: 30
Joined: Sat Aug 11, 2018 8:19 pm

Synaptic Package Manager Does Not Launch App Web Links

#1 Post by stevedude » Fri Aug 31, 2018 8:11 pm

Is anyone else having this issue?

I did a clean install of MX Linux 17 just a few weeks ago [details below] and today when I was perusing some of the applications in Synaptic, I clicked the website link provided with the package for more information. It did not matter what package I tried this with, I received the same error each time like something is not set correctly in Synaptic. I searched bugzilla and Google, can't seem to find a similar issue reported.

Firefox is the default browser.

It's not a deal breaker, but it is nice to be able to obtain more information about the package and/or developer.

[Screenshot]
Synaptic.png
There is no proxy network or anything like that. Synaptic Preferences > Network setting
Synaptic2.png
You do not have the required permissions to view the files attached to this post.
OS:MX-17.1_x64|Kernel:4.15.0-1-amd64 x86_64|Xfce 4.12.3|Mobo:TUF X470-PLUS|CPU AMD Ryzen 5, 2600 MHz
Graphics:GeForce GTX 1060,driver:nvidia v:390.77|Audio:NVIDIA snd_hda_intel
Netwrk:Realtek RTL8111|Seagate:ST2000DM006, 1.82 TB|Mem:15.6 GB

User avatar
dolphin_oracle
Forum Veteran
Forum Veteran
Posts: 10001
Joined: Sun Dec 16, 2007 1:17 pm

Re: Synaptic Package Manager Does Not Launch App Web Links

#2 Post by dolphin_oracle » Fri Aug 31, 2018 8:53 pm

looks like policykit is preventing synaptic from launching the browsers, and perhaps with good reason, as it looks to me that synaptic tries to launch the browser with root level permissions. probably not the best thing to use when going on the internet.

I could get it to work with sudo synaptic, which bypasses policykit, but personally its a bad idea in my mind. synaptic doens't get updated all that often, so the function may be a hold over from the old days. gksu synaptic didn't allow the browser to launch either, probably because the root account doesn't have a default browser.

copying the url and pasting into a browser seems safer, if less convenient. the copy/paste function worked ok on the browser links for me.
http://www.youtube.com/runwiththedolphin
lenovo ThinkPad T530 - MX-17
lenovo s21e & 100s - antiX-17, MX17(live-usb)
FYI: mx "test" repo is not the same thing as debian testing repo.

Post Reply

Return to “Bugs and Non-Package Requests Forum”