Welcome!
Important information
-- Spectre and Meltdown vulnerabilities
-- Change in MX sources

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-17.1 Final release info here
-- antiX-17 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

KeepassXC

Report Bugs, Issues and non- pacakage Requests
Post Reply
Message
Author
galaxysurfer
Forum Novice
Forum  Novice
Posts: 28
Joined: Mon Jul 16, 2018 5:14 am

KeepassXC

#1 Post by galaxysurfer » Wed Aug 29, 2018 12:43 pm

Previous install of stable ver 2.20 & then upgraded to MX test repo ver 2.34 when updated version it now shows 2 links in packages search under all applications & when open program still showing as ver 2.20 so not sure if new version overwrites old one or just install a new version beside old one? No indication of 2.34 version being present when open program only shows in package installer that newer one is installed. not sure which is best new version debian official is at 2.3.1 & unofficial at 2.3.4-1

User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 17007
Joined: Fri Dec 15, 2006 8:07 pm

Re: KeepassXC

#2 Post by Stevo » Wed Aug 29, 2018 1:52 pm

Hmm--you're right, but it appears in my tests that the Debian 2.3.1 version, such as the one that can be installed from stretch-backports, also displays 2.2.0.

Let's see if there' are any other bug reports about this issue.

User avatar
fehlix
Forum Guide
Forum Guide
Posts: 2395
Joined: Wed Apr 11, 2018 5:09 pm

Re: KeepassXC

#3 Post by fehlix » Wed Aug 29, 2018 2:24 pm

galaxysurfer wrote:
Wed Aug 29, 2018 12:43 pm
Previous install of stable ver 2.20 & then upgraded to MX test repo ver 2.34 when updated version it now shows 2 links in packages search under all applications & when open program still showing as ver 2.20 so not sure if new version overwrites old one or just install a new version beside old one? No indication of 2.34 version being present when open program only shows in package installer that newer one is installed. ...
I cannot reproduce, what you described above.
Just installed KeePassXC from stable version 2.2.0
Than installed version 2.3.4 from MX-Test
Closing and reopening KeePassXC shows version 2.3.4.
Within MXPI under stable repos I do see only one entry for keepassxc 2.2.0 with popup-hint: stating newer version 2.3.4 is already installed.
Within MXPI under test repos I do see also only one entry for keepassxc 2.3.4

As both packaged install the binary under /usr/bin/keepassxc,
you can only have the latest installed version here.
Either you have installed manually somewher else, or you did not close
and reopen keepassxc, showing still the old uninstalled version 2.2.0

--fehlix
Gigabyte Z77M-D3H, Intel Xeon E3-1240 V2 (Quad core), 32GB RAM,
GeForce GTX 770, Samsung SSD 850 EVO 500GB, Seagate Barracuda 4TB

User avatar
Jerry3904
Forum Veteran
Forum Veteran
Posts: 23010
Joined: Wed Jul 19, 2006 6:13 am

Re: KeepassXC

#4 Post by Jerry3904 » Wed Aug 29, 2018 2:48 pm

Maybe try logging out and back in would help
Production: 4.15.0-1-amd64, MX-17.1, AMD FX-4130 Quad-Core, GeForce GT 630/PCIe/SSE2, 8 GB, SSD 120 GB, Data 1TB
Testing: AAO 722: 4.15.0-1-386. MX-17.1, AMD C-60 APU, 4 GB
Personal: XPS 13, 4.18.0-19.3-liquorix, 4 GB

User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 17007
Joined: Fri Dec 15, 2006 8:07 pm

Re: KeepassXC

#5 Post by Stevo » Wed Aug 29, 2018 2:57 pm

I have the same 2.2.0 displaying on my system, but I wasn't able to reproduce it on a 64-bit new MX 17.1 in Virtual Box by first installing the 2.2.0 version, then upgrading to the 2.3.1 in backports, then the 2.3.4 in our test repo. Those show the correct version. I also tried downgrading to 2.2.0, removing it with the --purge flag, and then removing ~/.config/keepassxc, but somehow 2.2.0 versioning persists. But you are running 2.3.4.

Post Reply

Return to “Bugs and Non-Package Requests Forum”