Welcome!
Important information
-- Spectre and Meltdown vulnerabilities
-- Change in MX sources

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-17.1 Final release info here
-- antiX-17 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

MX Boot Options – „Boot to“ Memory Test with Boot-“Loop“

Report Bugs, Issues and non- pacakage Requests
Message
Author
User avatar
fehlix
Forum Guide
Forum Guide
Posts: 2018
Joined: Wed Apr 11, 2018 5:09 pm

Re: MX Boot Options – „Boot to“ Memory Test with Boot-“Loop“

#11 Post by fehlix » Sun Aug 12, 2018 1:29 pm

Adrian wrote:
Sun Aug 12, 2018 1:21 pm
fehlix wrote:
Sun Aug 12, 2018 1:08 pm
grub-reboot will only work in conjuntion with GRUB_DEFAULT=saved, as both grubenv-entries for default and next-boot
will be ignore if GRUB_DEFAULT is not set to "saved" within generatd grub.cfg.
Doesn't seem to be correct at least in my trials, I left GRUB_DEFAULT to something else and used grub-reboot that set memtest as default at the next reboot. I'm satisfied with forcing a 5 seconds timeout when somebody selects memtest. It's a good failsafe should not confuse people too much.
Will verfy this again .... I'm not too old to learn something new :p
But the 5 seconds are a good survival time!
Gigabyte Z77M-D3H, Intel Xeon E3-1240 V2 (Quad core), 32GB RAM,
GeForce GTX 770, Samsung SSD 850 EVO 500GB, Seagate Barracuda 4TB

User avatar
Adrian
Forum Veteran
Forum Veteran
Posts: 8987
Joined: Wed Jul 12, 2006 1:42 am

Re: MX Boot Options – „Boot to“ Memory Test with Boot-“Loop“

#12 Post by Adrian » Sun Aug 12, 2018 1:33 pm

male wrote:
Sun Aug 12, 2018 1:21 pm
Adrian wrote:
male wrote:Unfortunately I can't check this, because the MXBO tool is not offered to me during the update.
Why is that, you are not on MX-17?
surely ;)

Code: Select all

inxi -r
Repos:     Active apt repos in: /etc/apt/sources.list.d/antix.list 
           1: deb http://nl.mxrepo.com/antix/stretch stretch main
           Active apt repos in: /etc/apt/sources.list.d/debian-stable-updates.list 
           1: deb http://ftp.de.debian.org/debian/ stretch-updates main contrib non-free
           Active apt repos in: /etc/apt/sources.list.d/debian.list 
           1: deb http://ftp.de.debian.org/debian/ stretch main contrib non-free
           2: deb http://security.debian.org/ stretch/updates main contrib non-free
           Active apt repos in: /etc/apt/sources.list.d/mx.list 
           1: deb http://nl.mxrepo.com/mx/repo/ stretch main non-free
           No active apt repos in: /etc/apt/sources.list.d/various.list
Look it's here:
http://nl.mxrepo.com/mx/repo/pool/main/ ... t-options/

User avatar
male
Forum Regular
Forum Regular
Posts: 293
Joined: Thu Jan 23, 2014 8:38 am

Re: MX Boot Options – „Boot to“ Memory Test with Boot-“Loop“

#13 Post by male » Sun Aug 12, 2018 4:08 pm

@Adrian
my tests with your MXBO:
the setting 0 of the "Menu timeout" actually does not allow anything else than booting the default OS/memtest.
Pressing the Shift key with the start button of the computer at the same time has no effect, because two further necessary functions

Code: Select all

GRUB_HIDDEN_TIMEOUT=0
and
GRUB_DISABLE_OS_PROBER=true
are missing in the current /etc/default/grub of MX

Well, no danger for now.
Your preset value 5 works correctly

I thank you. ;)
Male is the capital of the Maldives and its wonderful people.

User avatar
fehlix
Forum Guide
Forum Guide
Posts: 2018
Joined: Wed Apr 11, 2018 5:09 pm

Re: MX Boot Options – „Boot to“ Memory Test with Boot-“Loop“

#14 Post by fehlix » Sun Aug 12, 2018 5:28 pm

Adrian wrote:
Sun Aug 12, 2018 1:21 pm
fehlix wrote:
Sun Aug 12, 2018 1:08 pm
grub-reboot will only work in conjuntion with GRUB_DEFAULT=saved, as both grubenv-entries for default and next-boot
will be ignore if GRUB_DEFAULT is not set to "saved" within generatd grub.cfg.
Doesn't seem to be correct at least in my trials, I left GRUB_DEFAULT to something else and used grub-reboot that set memtest as default at the next reboot. I'm satisfied with forcing a 5 seconds timeout when somebody selects memtest. It's a good failsafe should not confuse people too much.
Herewith confirmed:
grub-reboot "next-menuentry" will always make grub to take "next-menuentry" as default for the next boot-only regardless of GRUB_DEFAULT was set to GRUB_DEFAULT=saved or set to fixed menu-entry GRUB_DEFAULT="xyz".
Further after reboot/next-boot, the "next-menuentry" is cleared from grubenv.
The boot after that reboot, will have the prior default-entry again as the default.
Gigabyte Z77M-D3H, Intel Xeon E3-1240 V2 (Quad core), 32GB RAM,
GeForce GTX 770, Samsung SSD 850 EVO 500GB, Seagate Barracuda 4TB

User avatar
fehlix
Forum Guide
Forum Guide
Posts: 2018
Joined: Wed Apr 11, 2018 5:09 pm

Re: MX Boot Options – „Boot to“ Memory Test with Boot-“Loop“

#15 Post by fehlix » Mon Aug 13, 2018 12:21 pm

Adrian wrote:
Sun Aug 12, 2018 12:53 pm
OK, made the change to use "grub-reboot" option, but I saw at least once that exiting from Memtest didn't reset that, so I will also add manually the 5 second timeout in case somebody selects Memtest
OK, you have now fixed this "big" issue, but you introduced a "smaller" issue, unfortunately:
Start MXBO and select memtest: OK memtest is now sticky for one-time next-boot.
Close MXBO.
Start MXBO again.
Choose another "Boot to" save and close.
Quiz: What will the user see next reboot? He might think the last choosen, right?
As you have not cleared the sticky next-boot entry, he will always boot into memtest,
regardless, what he tries to select for next boot within MXBO.
Solution: Always clear next-boot, when user saves another entry.
Use this command to clear next-boot entry:

Code: Select all

grub-editenv /boot/grub/grubenv unset next_entry
Gigabyte Z77M-D3H, Intel Xeon E3-1240 V2 (Quad core), 32GB RAM,
GeForce GTX 770, Samsung SSD 850 EVO 500GB, Seagate Barracuda 4TB

User avatar
Adrian
Forum Veteran
Forum Veteran
Posts: 8987
Joined: Wed Jul 12, 2006 1:42 am

Re: MX Boot Options – „Boot to“ Memory Test with Boot-“Loop“

#16 Post by Adrian » Mon Aug 13, 2018 12:43 pm

Good point, I will change that.

Post Reply

Return to “Bugs and Non-Package Requests Forum”