Welcome!
Important information
-- Spectre and Meltdown vulnerabilities
-- Change in MX sources

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-17.1 Final release info here
-- antiX-17 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

urandom warning(s) during boot

Report Bugs, Issues and non- pacakage Requests
Post Reply
Message
Author
User avatar
oops
Forum Regular
Forum Regular
Posts: 357
Joined: Tue Apr 10, 2018 5:07 pm

urandom warning(s) during boot

#1 Post by oops » Mon Jun 11, 2018 11:30 am

Hello,
For information, I have a warning at the boot time (into 2 computers) and until the default MX17 kernel 4.15 (4.16 & 4.17 now) like:
"7 urandom warning(s) missed due to ratelimiting"

Code: Select all

 dmesg | egrep -i --color 'warn|random|ratelimit'
[    0.000000] random: get_random_bytes called from start_kernel+0x77/0x3f8 with crng_init=0
[    5.777020] random: fast init done
[    6.360642] random: systemd-udevd: uninitialized urandom read (16 bytes read)
[    6.361292] random: systemd-udevd: uninitialized urandom read (16 bytes read)
[    6.361484] random: systemd-udevd: uninitialized urandom read (16 bytes read)
[    8.276543] random: crng init done
[    8.276628] random: 7 urandom warning(s) missed due to ratelimiting
So I have tried to install and configure haveged:

Code: Select all

update-rc.d haveged defaults
$ cat /proc/sys/kernel/random/entropy_avail
3916

$ cat /etc/default/haveged
# Configuration file for haveged
# Options to pass to haveged:
#   -w sets low entropy watermark (in bits)
DAEMON_ARGS="-w 1024"

After  reboot:
$ ps -ef | grep haveged
root      2564     1  0 17:02 ?        00:00:04 /usr/sbin/haveged -w 1024

$ cat /dev/random | rngtest -c 1000
rngtest 5
Copyright (c) 2004 by Henrique de Moraes Holschuh
This is free software; see the source for copying conditions.  There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
rngtest: starting FIPS tests...
rngtest: bits received from input: 20000032
rngtest: FIPS 140-2 successes: 1000
rngtest: FIPS 140-2 failures: 0
rngtest: FIPS 140-2(2001-10-10) Monobit: 0
rngtest: FIPS 140-2(2001-10-10) Poker: 0
rngtest: FIPS 140-2(2001-10-10) Runs: 0
rngtest: FIPS 140-2(2001-10-10) Long run: 0
rngtest: FIPS 140-2(2001-10-10) Continuous run: 0
rngtest: input channel speed: (min=354.212; avg=3325.202; max=2170138.889)Kibits/s
rngtest: FIPS tests speed: (min=1.700; avg=27.628; max=53.880)Mibits/s
rngtest: Program run time: 6629169 microseconds
... But at the boot time I always have this warning with dmesg ... So, how can I do to resolve this warning, if someone has an idea ?
$ inxi -S : System: Host:XEON Kernel: 4.16.0-xeon-01.efi x86_64 bits: 64 Desktop: Xfce 4.12.3 - Distro: MX-17.1_x64 Horizon


Post Reply

Return to “Bugs and Non-Package Requests Forum”